1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

sputtering and tach going crazy please help

Discussion in 'Technical Chat' started by baggedhilux, Sep 14, 2010.

  1. Sep 14, 2010 at 4:35 PM
    #1
    baggedhilux

    baggedhilux [OP] Active Member

    Joined:
    Jun 20, 2010
    Member:
    #39237
    Messages:
    44
    Gender:
    Male
    First Name:
    kyle
    west monroe louisiana
    Vehicle:
    bagged 84 hilux
    system,airride,4link,wheels,flat black,white tails,shaved doors body molding tail handle gas door,interrior,ummm exhaust and intake filter,comming soon body drop and chop top and paint
    ok i have a 22re with 299.9 miles on it lol and new bat new alt new starter new voltage regulater new spark plug wires but my truck sputters and the rpms are goin crazy what could it be?!?!?!?!??!?!??!?!?!??!?!?!?!?!?
     
  2. Sep 14, 2010 at 4:36 PM
    #2
    WNYTACOMA

    WNYTACOMA Well-Known Member

    Joined:
    Nov 23, 2008
    Member:
    #10961
    Messages:
    1,333
    Gender:
    Male
    Clarence, New York
    Vehicle:
    09 Metalic Grey TRD OFF ROAD
    Toyota Nerf steps Bugflector 2 Tool box Weathertech floor liners Wet Okole F/R - Bk/Char
    Was there a hovering craft above and bright light beams shining downward?
     
  3. Sep 14, 2010 at 4:39 PM
    #3
    baggedhilux

    baggedhilux [OP] Active Member

    Joined:
    Jun 20, 2010
    Member:
    #39237
    Messages:
    44
    Gender:
    Male
    First Name:
    kyle
    west monroe louisiana
    Vehicle:
    bagged 84 hilux
    system,airride,4link,wheels,flat black,white tails,shaved doors body molding tail handle gas door,interrior,ummm exhaust and intake filter,comming soon body drop and chop top and paint
    real funny dude but i actually need some help not a smart ass
     
  4. Sep 14, 2010 at 5:39 PM
    #4
    Manlaan

    Manlaan Well-Known Member

    Joined:
    Jan 25, 2010
    Member:
    #30054
    Messages:
    1,028
    Gender:
    Male
    First Name:
    Greg
    Riverton, Utah
    Vehicle:
    2002 XtraCab SR5 V6 4x4 Black
    See Signature
    You really dont give anyone much to go on.

    RPMs going crazy... what ranges?
    Does this happen at idle only? or while foot is on the gas?

    You obviously felt it was electrical in nature having replaced so many electrical components. Is there a reason why you felt that way?

    Basically, it could be air or fuel related just as easily. Something as simple as a vacuum line not hooked up to something much more major like cpu problem. Any engine codes?

    You really didn't give us much to work with, so I'm going to have to agree with the alien diagnosis at this point. ;)
     
  5. Sep 14, 2010 at 6:59 PM
    #5
    EnolaGaia

    EnolaGaia Well-Known Member

    Joined:
    Sep 9, 2006
    Member:
    #9
    Messages:
    1,129
    Gender:
    Male
    Midwest USA
    Vehicle:
    '01 & '04 S-Runners
    01 SR: Double Cab conversion, S/C, lowered.
    (1) For tech help on a 1984 Toyota pickup, I'd recommend ToyotaMinis.com:

    http://www.toyotaminis.com/

    (2) If your '84 22RE is wired like the next-generation 1985 model (which is as far back as my wiring diagrams go ...), the tach signal comes off the ignition coil. Did you replace the ignition coil? If you're sure everything else is hooked up correctly, I'd start with the coil. If it's bad or has a wiring fault that might explain both symptoms.
     
  6. Sep 14, 2010 at 10:26 PM
    #6
    baggedhilux

    baggedhilux [OP] Active Member

    Joined:
    Jun 20, 2010
    Member:
    #39237
    Messages:
    44
    Gender:
    Male
    First Name:
    kyle
    west monroe louisiana
    Vehicle:
    bagged 84 hilux
    system,airride,4link,wheels,flat black,white tails,shaved doors body molding tail handle gas door,interrior,ummm exhaust and intake filter,comming soon body drop and chop top and paint
    been onb toyota mins no one help you helped more and btw it is when foot is in and out of gas and im more certain its a electrical problem than any because everything else turns out good it just happened coming home yesterday
     
  7. Sep 14, 2010 at 11:08 PM
    #7
    Manlaan

    Manlaan Well-Known Member

    Joined:
    Jan 25, 2010
    Member:
    #30054
    Messages:
    1,028
    Gender:
    Male
    First Name:
    Greg
    Riverton, Utah
    Vehicle:
    2002 XtraCab SR5 V6 4x4 Black
    See Signature
    So what exactly does "rpm going crazy" mean? Are you talking about it almost dieing then jumping back up to 800 rpm? Or are you talking going from idle to 3000 rpm and back? Or are you saying it goes from 800 to 1000 rpm?

    Are you doing anything when the "craziness" happens, like turning the wheel, pressing the brakes, have the clutch in, have the ac on, coming to a stop or accelerating from a stop, playing music through an amp, etc.

    How often does it happen? Every time you drive? Only when the engine is/isn't warmed up? Only when coming off of the highway to a stop?

    Any other signs that are out of the ordinary, like black exhaust, rough idle, misfires, poor acceleration, belt noise, or anything?

    Being so old (didnt' catch the year before), I'm not even certain if it is injected or carburated... I assume the 22RE is injected and the 22R is carb though.

    You really have to help narrow it down some. Worst case is make a video of it happening so someone might be able to help narrow it down as to where to start looking for the problem.
     
  8. Sep 15, 2010 at 9:13 PM
    #8
    baggedhilux

    baggedhilux [OP] Active Member

    Joined:
    Jun 20, 2010
    Member:
    #39237
    Messages:
    44
    Gender:
    Male
    First Name:
    kyle
    west monroe louisiana
    Vehicle:
    bagged 84 hilux
    system,airride,4link,wheels,flat black,white tails,shaved doors body molding tail handle gas door,interrior,ummm exhaust and intake filter,comming soon body drop and chop top and paint
    ok i did actually make a video its on my facebook and no to all of those its just runnin like she the motor has 330 miles on it (380 not 380,000) it was runnin fine tll i was on the way home the other day and started acting stupid as hell and by crazy i mean jumpin to like six grand if i barely hit the gas and it sounds as if it should be reading 1500 or 20 with increasing acceleration its ok i guess but steady cruise no if you wanna see the video look for me on facebook kyle vc day these are parts ive replaced plugs,plufg wires,fuell filter dist cap so idk just some one please help lol
     
To Top