1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

sputtering

Discussion in 'Performance and Tuning' started by Djmo1968, Jan 23, 2011.

  1. Jan 23, 2011 at 9:33 AM
    #1
    Djmo1968

    Djmo1968 [OP] New Member

    Joined:
    Jan 23, 2011
    Member:
    #49751
    Messages:
    1
    Gender:
    Male
    First Name:
    Drew
    Windham Ct
    Vehicle:
    97 tacoma
    I hit a huge puddle the other day. Didnt see it because it was so dark and foggy. Almost instantly the truck began to sputter and barely run. The engine light comes on and blinks. I checked the air box and plugs n wires. doesnt have a distributer so i cant seem to figure out the prob..... HELP???
     
  2. Jan 23, 2011 at 12:29 PM
    #2
    7350livin

    7350livin Member

    Joined:
    Jan 23, 2011
    Member:
    #49748
    Messages:
    10
    Was the airbox dry?
     
  3. Jan 24, 2011 at 9:02 AM
    #3
    BAMFTACO

    BAMFTACO Pabst Blue Ribbon on ice

    Joined:
    Feb 3, 2010
    Member:
    #30639
    Messages:
    10,296
    Gender:
    Male
    First Name:
    JUAN
    Malibu, CA
    Vehicle:
    Taco
    Lift- king 2.5 with light racing uppers,tc coil bucket gusset, timbern bumps ,defined extended shackles with shackle brace. Armor- tire gate, custom tube bumper, kr fab rear bumper,trail gear wiy 78 in sliders Performance-intake manifold spacer, vibrant resonator as muffler, hps silicone hoses Random stuff- kenwood head unit,b&m t shifter, hood bug deflector, rear dust lights with custom bed bar and hi lift mount.
    You might have gotten water in one of the sensors and clean up the air box make sure its dry and also the filter too
     
To Top