1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Squeak in Alcan DS rear leaf

Discussion in 'Suspension' started by glwood6, Jul 29, 2009.

  1. Jul 29, 2009 at 11:39 PM
    #1
    glwood6

    glwood6 [OP] Well-Known Member

    Joined:
    Jul 25, 2008
    Member:
    #8125
    Messages:
    1,346
    Gender:
    Male
    First Name:
    Gary
    Albuquerque, NM
    Vehicle:
    '13 MGM AC 4x4 TRD OR
    Husky front mud flaps, OEM bed mat, 3D floor mats, Wet Okole seat covers, fog lights anytime mod, rear diff breather extension, aluminum Relentless tailgate reinforcement, NWexpo corner gussets.
    Got an annoying squeak on every bump or dip in the road. I can re-create it by pushing down on the rear DS corner of the bumper. I've pinned it down to one of the spacers between the springs...any suggestions on what to put on that to stop the squeak? I tried silicone spray, that worked for a while but the squeak came back after about a week...

    These are Alcan replacement springs.

    Thanks...
     
  2. Jul 29, 2009 at 11:41 PM
    #2
    THXEY

    THXEY Panda Jerk

    Joined:
    Dec 15, 2008
    Member:
    #11614
    Messages:
    12,788
    Gender:
    Male
    First Name:
    Jacob
    San Diego
    Vehicle:
    2013 Subaru WRX
    STi Short Shifter.OEM floor illumination kit. Rally Armor Mud Flaps. BC BR Coilovers. Invidia N1 Exhaust
    pressure washer...... or just take out the leafs and clean em real nice and deep like...
     
  3. Jul 29, 2009 at 11:48 PM
    #3
    glwood6

    glwood6 [OP] Well-Known Member

    Joined:
    Jul 25, 2008
    Member:
    #8125
    Messages:
    1,346
    Gender:
    Male
    First Name:
    Gary
    Albuquerque, NM
    Vehicle:
    '13 MGM AC 4x4 TRD OR
    Husky front mud flaps, OEM bed mat, 3D floor mats, Wet Okole seat covers, fog lights anytime mod, rear diff breather extension, aluminum Relentless tailgate reinforcement, NWexpo corner gussets.
    Thanks, I'll give the pressure washer a go.
     
  4. Jul 29, 2009 at 11:50 PM
    #4
    THXEY

    THXEY Panda Jerk

    Joined:
    Dec 15, 2008
    Member:
    #11614
    Messages:
    12,788
    Gender:
    Male
    First Name:
    Jacob
    San Diego
    Vehicle:
    2013 Subaru WRX
    STi Short Shifter.OEM floor illumination kit. Rally Armor Mud Flaps. BC BR Coilovers. Invidia N1 Exhaust
    it helped for me.... til i went offroading again haha.... just make sure you spray it out reeaallly well!
     
  5. Jul 30, 2009 at 8:19 AM
    #5
    nelson18matt

    nelson18matt Well-Known Member

    Joined:
    Mar 19, 2009
    Member:
    #14939
    Messages:
    13,831
    Gender:
    Male
    Arizona
    Vehicle:
    2004 Long Travel Tacoma
    *SOLD*
    my deavers do the same thing...for me it's the bushings binding up w/ the shackle when the springs are moving. grease em up REALLY good and it will help but prob not go away 100%...look into maybe getting some greasable shackles...i hear that helps
     
  6. Jul 30, 2009 at 10:52 PM
    #6
    glwood6

    glwood6 [OP] Well-Known Member

    Joined:
    Jul 25, 2008
    Member:
    #8125
    Messages:
    1,346
    Gender:
    Male
    First Name:
    Gary
    Albuquerque, NM
    Vehicle:
    '13 MGM AC 4x4 TRD OR
    Husky front mud flaps, OEM bed mat, 3D floor mats, Wet Okole seat covers, fog lights anytime mod, rear diff breather extension, aluminum Relentless tailgate reinforcement, NWexpo corner gussets.
    Thanks, but mine's not the shackles. They did squeak at first, and I took them all apart and greased them well. Those squeaks went away. This one is coming from one of the round pads between two of the leaf springs.
     
To Top