1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Squeak!!

Discussion in 'Technical Chat' started by sull625, May 30, 2013.

  1. May 30, 2013 at 11:27 PM
    #1
    sull625

    sull625 [OP] Well-Known Member

    Joined:
    May 30, 2013
    Member:
    #105274
    Messages:
    101
    Gender:
    Male
    First Name:
    Dave
    Montana
    Vehicle:
    04 SR5 TRD DoubleCab
    I'm new to the forum. I just picked up a 04 Tacoma. Love the truck but noticed an annoying squeak in the front passenger side. It sounds like its coming from a control arm bushing but I'm unsure. Anyone out there have this issue? If so was it the bushings? Thanks for your help!
     
  2. May 31, 2013 at 12:02 PM
    #2
    sull625

    sull625 [OP] Well-Known Member

    Joined:
    May 30, 2013
    Member:
    #105274
    Messages:
    101
    Gender:
    Male
    First Name:
    Dave
    Montana
    Vehicle:
    04 SR5 TRD DoubleCab
    Any advice would help.
     
  3. May 31, 2013 at 4:13 PM
    #3
    sull625

    sull625 [OP] Well-Known Member

    Joined:
    May 30, 2013
    Member:
    #105274
    Messages:
    101
    Gender:
    Male
    First Name:
    Dave
    Montana
    Vehicle:
    04 SR5 TRD DoubleCab
    No help here?
     
  4. May 31, 2013 at 4:15 PM
    #4
    thebigsmit

    thebigsmit Well-Known Member

    Joined:
    Jan 13, 2013
    Member:
    #95107
    Messages:
    95
    Gender:
    Male
    First Name:
    Brent
    South Carolina
    Vehicle:
    2013 Tacoma TRD Off Road
    3 inch Toytec lift, Westin E series bull bar, HID/Halo retrofit, sway bar disconnect
    I took my truck to the dealer for the same problem you are describing. When going over a bump the front suspension seems to squeak. It was a radiator bushing.
     
  5. May 31, 2013 at 5:29 PM
    #5
    sull625

    sull625 [OP] Well-Known Member

    Joined:
    May 30, 2013
    Member:
    #105274
    Messages:
    101
    Gender:
    Male
    First Name:
    Dave
    Montana
    Vehicle:
    04 SR5 TRD DoubleCab
    Radiator bushing? Where is it located? Did you replace or just lube?
     
  6. May 31, 2013 at 5:38 PM
    #6
    thebigsmit

    thebigsmit Well-Known Member

    Joined:
    Jan 13, 2013
    Member:
    #95107
    Messages:
    95
    Gender:
    Male
    First Name:
    Brent
    South Carolina
    Vehicle:
    2013 Tacoma TRD Off Road
    3 inch Toytec lift, Westin E series bull bar, HID/Halo retrofit, sway bar disconnect
    No idea where it is. They completely replaced it. Should be able to get one from your dealer. Like I said, that was the problem with my truck, yours could be different.
     
  7. Jun 1, 2013 at 6:35 AM
    #7
    sull625

    sull625 [OP] Well-Known Member

    Joined:
    May 30, 2013
    Member:
    #105274
    Messages:
    101
    Gender:
    Male
    First Name:
    Dave
    Montana
    Vehicle:
    04 SR5 TRD DoubleCab
    True true
     
To Top