1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

squeaking after installing tc uca?

Discussion in '2nd Gen. Tacomas' started by ozmon420, Sep 18, 2010.

  1. ozmon420

    ozmon420 [OP] Well-Known Member

    Joined:
    Aug 23, 2008
    Member:
    #8699
    Messages:
    1,035
    Gender:
    Male
    miami, florida
    Vehicle:
    08 tacoma
    18x9 pro comp 7031 rims, alpine iva-d310 w/sirius sat radio, ipod connection, tv tuner, reverse camera, bug deflector, wet okole seat covers, tinted windows, running boards, toytec coilovers front set at 2.5'' , AAL rear,5100's rear, TC UCA, leer topper, bruteforce rear bumper, ARB rear locker.
    dont know why i have squeaking coming from the front end after i installed tc uca's. wanted to know if anyone else has the same problem.
     
  2. TRICOMA

    TRICOMA Tacoma with the TRI package

    Joined:
    Jan 20, 2009
    Member:
    #12770
    Messages:
    4,906
    Gender:
    Male
    First Name:
    Tri
    Carlsbad, CA
    Vehicle:
    2010 Tacoma DC SB 4x4 TRD Off Road
    King Off-Road Shock Coilover 2.5 with Resi in the front. King Off-Road Shocks 2.5 with Resi's for the rears, Rear Spring TSB, KMC XD Enduros 16x8, Black Vinyl Fenders, Bed compartment locks, Cobra 19 DX IV with Lil Wil mag mount antenna, CoverKing Seat covers front and rear, Built Right UCAs, Aluminess Expedition Bumper, GY Wrangler MT/R with Kevlar 265/75-16, Custom hybrid style rock sliders.
    Grease the joints and spray some Dupont Dry teflon on the UniBall
     
To Top