1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Squeaky Front Suspension

Discussion in 'Suspension' started by dunkadizzle08, Apr 6, 2009.

  1. Apr 6, 2009 at 8:19 PM
    #1
    dunkadizzle08

    dunkadizzle08 [OP] New Member

    Joined:
    Feb 3, 2009
    Member:
    #13247
    Messages:
    1
    Gender:
    Male
    Vehicle:
    03 Prerunner V6
    Hey guys im kind of a newb...

    Ive got a 2003 prerunner with bilstein 5100's up front and it seems that whenever i hit smaller bumps my front suspension squeaks really badly like an old bed. I have pressure washed the entire underside of the truck and all of the front suspension components and the squeak went away for about and hour then it came back just as bad as before. It seems to squeak worse when i hit smaller bumps or when the truck bounces slightly after hitting speed bumps or large dips. If anyone has any suggestions or input please HELP!!! The noise is EXTREMELY annoying!

    Thanks,
    Seth
     
  2. Mar 28, 2010 at 9:58 PM
    #2
    mneuls

    mneuls Well-Known Member

    Joined:
    Jul 9, 2008
    Member:
    #7836
    Messages:
    280
    Gender:
    Male
    Fort St John, British Columbia, Canada
    Vehicle:
    5100's and dakar leaf 3"lift, Satoshi grill,
    Bilstein 5100's front and back, dakar 3" leaf springs, Westin bull bar, piaa driving lights, piaa replacement bulbs, H/U, 2x10" mtx tt65 subs, 1000w clarion monoblock, Mtx surround speakers. green wire mod. Flowmaster 40, airaid intake. scanguage II.
    I'm having the same problem. I have 4x4 offroad with 1.5"bilsteins and 2"truxx spacer and it squaks like mad. on every little crack in the road. I tried lubing it, but it don't help much. have you had any luck fixing this?
     
  3. Mar 28, 2010 at 10:05 PM
    #3
    ETaco23

    ETaco23 Marshall offroad Fabrication

    Joined:
    Feb 2, 2008
    Member:
    #4544
    Messages:
    5,333
    Gender:
    Male
    First Name:
    Evan
    PNW
    Vehicle:
    13' Pyrite Mica TRD Offroad DCSB 4x4
    Color Match Grille, Bed mat, Icon's with JBA UCA's, Dakars and 295 BFG KO2, Bora 1" spacers, Snugtop Canopy, and my "Marshall Fabrication" Rock Sliders.
    Mine squeaks also, but I just figure it just part of putting on aftermarket parts. (UCA's). Atleast im pretty sure its my UCA's. :)
    But my guess would have to be either lower shock mount or upper spring perch. Those would have to be my 2 geuss's of where they could be coming from. And maybe get some PB or WD-40 and spray the 2 area's to see if it go's away, then you know where it is.
     
  4. Mar 28, 2010 at 10:07 PM
    #4
    I Liquid I

    I Liquid I Well-Known Member

    Joined:
    Feb 11, 2010
    Member:
    #31207
    Messages:
    764
    Gender:
    Male
    Puerto Rico
    Vehicle:
    06 BSP Double Cab Long Bed
    Too many mods to list
    Checked the bushings?

    I have the same problem in the back suspension of mine and it is the bushings. Lubing them should work sometimes, but its better to replace.
     
  5. Mar 28, 2010 at 11:44 PM
    #5
    socal trd

    socal trd Well-Known Member

    Joined:
    Dec 26, 2009
    Member:
    #28167
    Messages:
    1,155
    Gender:
    Male
    First Name:
    frank
    SOCAL SGV
    Vehicle:
    06 Trd off road lifted
    9.5'Headrest TV's ,09 led tail lights, 2011 sport grill, matching sport bumper , eyelids, Billsteins 5100's all around.de-badged,wicked flow,camburg uca's
    i have sway a ways and the squeaking is driving me crasy.i took it to the shop i go to thinking i need to rebuild them but they told me i didnt,
     
  6. Mar 29, 2010 at 7:48 AM
    #6
    nelson18matt

    nelson18matt Well-Known Member

    Joined:
    Mar 19, 2009
    Member:
    #14939
    Messages:
    13,842
    Gender:
    Male
    Goodyear, Arizona
    Vehicle:
    2004 Long Travel Tacoma
    *SOLD*
    thats what happens when you start moding the truck. noise come with aftermarket parts...

    my truck sqeaks and squeals like a horny pig
     
  7. Mar 29, 2010 at 11:56 AM
    #7
    mneuls

    mneuls Well-Known Member

    Joined:
    Jul 9, 2008
    Member:
    #7836
    Messages:
    280
    Gender:
    Male
    Fort St John, British Columbia, Canada
    Vehicle:
    5100's and dakar leaf 3"lift, Satoshi grill,
    Bilstein 5100's front and back, dakar 3" leaf springs, Westin bull bar, piaa driving lights, piaa replacement bulbs, H/U, 2x10" mtx tt65 subs, 1000w clarion monoblock, Mtx surround speakers. green wire mod. Flowmaster 40, airaid intake. scanguage II.
    i fixed it... for now. used release lubricant. after a hard-core suspension wash. the sound is gone for now. also i found my airbox was squeaking.
     
To Top