1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Squeeky sound from driveshaft?

Discussion in 'Technical Chat' started by MikeyD, Dec 31, 2010.

  1. Dec 31, 2010 at 3:30 PM
    #1
    MikeyD

    MikeyD [OP] Well-Known Member

    Joined:
    Jul 3, 2009
    Member:
    #19233
    Messages:
    823
    Gender:
    Male
    First Name:
    Mike
    Sayreville NJ
    Vehicle:
    2007 Toyota tacoma 4x4
    BHLM, HID kit, yellow fogs, Grill craft, Hellas behind grillcraft, LED cup holder mod, after market horn, extra reverse lights, under body glow for off roading at night, pro comp 7089's wrapped in 255/75/17 bfg mud terrains, Toytec coiovers sat at 3.25, 2" add a leaf with 5100's, Satoshi grill mod
    Today as i was driving this really loud squeeking sound was occuring. I cant pin point where its coming from but its towards the rear of the truck. Sounds like something that is spinning is what is making the sound. Also, i dont know if this is related but my driveshaft seems like it has a little play in it. When i let off the gas and then step on the gas i hear a thud from the rear. I went underneath the truck and where the drive shaft connects to the diff it seems like their is a little play in it. If any one can help me figure out what this squeeking noise is i would greatly appreciate it.
     
  2. Dec 31, 2010 at 4:26 PM
    #2
    MikeyD

    MikeyD [OP] Well-Known Member

    Joined:
    Jul 3, 2009
    Member:
    #19233
    Messages:
    823
    Gender:
    Male
    First Name:
    Mike
    Sayreville NJ
    Vehicle:
    2007 Toyota tacoma 4x4
    BHLM, HID kit, yellow fogs, Grill craft, Hellas behind grillcraft, LED cup holder mod, after market horn, extra reverse lights, under body glow for off roading at night, pro comp 7089's wrapped in 255/75/17 bfg mud terrains, Toytec coiovers sat at 3.25, 2" add a leaf with 5100's, Satoshi grill mod
    I think i have pinpointed the problem. The squeeky sound i believe is the carrier bearing and the clunk is a U joint. Both prematurely wore out because of the 2"s of rear lift i have. I do not have axle shims which is my fault. That probably could of prevent the u joint from wearing out. Also do you guys think i should just upgrade to a tom wood 1 piece shaft. Mine as well if im going to replace this other stuff.
     
  3. Feb 5, 2011 at 8:48 PM
    #3
    revhappyleon

    revhappyleon Well-Known Member

    Joined:
    Aug 26, 2009
    Member:
    #21839
    Messages:
    202
    Gender:
    Male
    First Name:
    Manny
    Tampa near macdill
    Vehicle:
    07 Prerunner V6 6-speed(custom dual exhaust)
    dual exhaust, foglight anytime, satoshi, chlm, aux backup lights and electric fan conversion
    idk but you should find out how much the carrier bearing runs since mine went out too :D
     
To Top