1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

SRS Airbag Indicator light came on today...

Discussion in '2nd Gen. Tacomas (2005-2015)' started by wwjdweldingman, May 16, 2009.

  1. May 16, 2009 at 6:35 PM
    #1
    wwjdweldingman

    wwjdweldingman [OP] Member

    Joined:
    Feb 16, 2009
    Member:
    #13681
    Messages:
    61
    Gender:
    Male
    sourthern cali
    Vehicle:
    2wd 05 Prerunner SR5 w/ LSD
    double din dvd system. tinted windows, billet grill, AFE intake, HIDs 8000K high/low, black headlight mod.
    Has anyone had experience in this happening to there truck? and if so what was the cause of you light coming on???

    any input would be helpful

    thanks:)
     
  2. May 16, 2009 at 6:40 PM
    #2
    Brunes

    Brunes abides. Staff Member

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,730
    Gender:
    Male
    First Name:
    Rotorhead
    Big Easy, USA
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit Upcoming: ATO Gas Tank Skid and Sliders w/ kickout. ATO Shackle Flip Kit. Down the line: Front/Rear ARB Lockers w/ OBA. 4.56 Gears
    Lose connectors, failed sensors, or random computer problems can all cause issues.

    Since your light is on- The system should be in a fail safe and will not fire for anything. I'd get it to a dealership and get it looked at ASAP if it was me.
     
  3. May 16, 2009 at 6:42 PM
    #3
    oldtacomaguy

    oldtacomaguy four forty four

    Joined:
    Dec 11, 2006
    Member:
    #444
    Messages:
    9,787
    Gender:
    Male
    First Name:
    Dave
    SE Conn.
    Vehicle:
    08 SR-5 4WD Impulse Red Pearl
    Alpine deck and amp, Polk speakers front and rear, Kenwood subwoofer, windows tinted to 20%, Sockmonkey decals, TSB, Eibach springs and Bilstein 5100's
    Mine came on when the truck was almost new. I found a loose connector under the drivers seat and replugged it. Good ever since.
     
  4. May 16, 2009 at 6:51 PM
    #4
    wwjdweldingman

    wwjdweldingman [OP] Member

    Joined:
    Feb 16, 2009
    Member:
    #13681
    Messages:
    61
    Gender:
    Male
    sourthern cali
    Vehicle:
    2wd 05 Prerunner SR5 w/ LSD
    double din dvd system. tinted windows, billet grill, AFE intake, HIDs 8000K high/low, black headlight mod.
    thanks for your input ill have to check under the seats and start taking panels off to check all the connectors..
     
  5. May 20, 2009 at 9:40 PM
    #5
    wwjdweldingman

    wwjdweldingman [OP] Member

    Joined:
    Feb 16, 2009
    Member:
    #13681
    Messages:
    61
    Gender:
    Male
    sourthern cali
    Vehicle:
    2wd 05 Prerunner SR5 w/ LSD
    double din dvd system. tinted windows, billet grill, AFE intake, HIDs 8000K high/low, black headlight mod.
    so i took my truck to the dealer today to check the light, and they charged me $55 and found 6 fault codes, cleared them and reset the light and told me if it comes on again its most likely my ECU.. and it'll need to be replaced.. :eek:
     
  6. May 20, 2009 at 9:43 PM
    #6
    tacoholic

    tacoholic 09 but I drive a 012 Expedition...

    Joined:
    Jan 11, 2009
    Member:
    #12480
    Messages:
    4,072
    Gender:
    Male
    First Name:
    Jeff...I'm pretty sure
    East Bay, CA
    Vehicle:
    Quite possibly, someday...
    Ouch, poor Taco. :( Hope it doesn't happen again.
     
  7. May 21, 2009 at 6:52 AM
    #7
    Veccster

    Veccster bass turds

    Joined:
    Aug 8, 2008
    Member:
    #8407
    Messages:
    2,085
    Gender:
    Male
    First Name:
    Eric
    Pittsburgh - The City of Champions
    Vehicle:
    2009 DC V6 TRDsport
    5100's all around - fronts at 1.75", 265/70/17 Bridgestone Revo 2, HID headlights and fog lights, factory skid plate, ss exhaust tip, tube steps, Access roll-up tonneau cover, Redline hood struts, 6 D-rings, seat MagLite, LED dome, fumoto oil drain, DTRL, fog light anytime, Kenwood/Clarion speakers, Pop-N-Lock 5300, LED bed lights and a few other things...
    I believe many auto parts stores will check your codes for free.

    That does suck! We had random lights coming on in our Jeep and found that the battery was leaking acid onto the main wire harness and it needed replaced.

    I hope it doesn't happen again!
     
To Top