1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

SRS (Airbag) Light On

Discussion in 'Technical Chat' started by mox540, Aug 23, 2010.

  1. Aug 23, 2010 at 11:19 AM
    #1
    mox540

    mox540 [OP] Member

    Joined:
    Sep 16, 2009
    Member:
    #22861
    Messages:
    7
    Gender:
    Male
    Camarillo
    Vehicle:
    06 SR5
    I have an 06 Tacoma with 123K on it, I was driving down the freeway and the SRS light came on. I was at the dealer for a recall issue and aked them to take a look at it. They said that I need a new sprial cable and to install it would run over $600!! The thing is that I've done a little research and if the sprial cable is truly broken the horn and cruise control should not work, they both work fine. Any ideas?
     
  2. Aug 23, 2010 at 11:39 AM
    #2
    BlueT

    BlueT Well-Known Member

    Joined:
    Mar 30, 2009
    Member:
    #15341
    Messages:
    5,645
    Gender:
    Male
    NorthEast
    Vehicle:
    07 Dbl Cab LB with LSD
    I moded 1999 Taco so much it had turned to Land Cruiser
    Search more on this site there are few people that replaced them already, you can ask them if their horn and CC was not working but I think this is only from 1 gens that got slightly different cable otherwise each of this wires are 100% separated so failure of one does not mean failure of other. :)
     
  3. Aug 23, 2010 at 11:47 AM
    #3
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,741
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    The horn can still work if the cable is bad, it just depends on which part of the cable actually failed.

    Cruise control does not go throught the sprial cable.
     
  4. Oct 12, 2010 at 7:15 PM
    #4
    akcoma

    akcoma Member

    Joined:
    Dec 20, 2009
    Member:
    #27881
    Messages:
    7
    Gender:
    Male
    First Name:
    alfredo
    Mckinney, TX
    Vehicle:
    '07 PreRunner
    I had a similar problem back in summer. Long story short the spiral cable was broken....but instead of paying $300 for the cable and labor to change it at the dealership I bought mine thru Toyota of Dallas website for $200 dollars and installed it myself:D...and had money left over to buy a Fluke 87 multimeter to diagnose electrical problems(ebay)!!!!!!!!!!!!! :cheers:Search the forums and you should be able to do it yourself.....
     
  5. Oct 12, 2010 at 7:19 PM
    #5
    Asgard

    Asgard Well-Known Member

    Joined:
    Apr 19, 2008
    Member:
    #6078
    Messages:
    1,093
    Gender:
    Male
    First Name:
    Chris
    Vehicle:
    06 PreRunner DC SR5 w/LSD
    X2
    Did they get a code ?
    B1801 = broken spiral cable
     
To Top