1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Stock Radio

Discussion in 'Audio & Video' started by RyanPont, May 3, 2011.

  1. May 3, 2011 at 7:43 PM
    #1
    RyanPont

    RyanPont [OP] Well-Known Member

    Joined:
    Mar 9, 2011
    Member:
    #52704
    Messages:
    119
    Gender:
    Male
    Ive got a Second Gen Tacoma, 2009. It has your basic radio, single disc, am/fm. Occasionally when the radio is on the lights that show what station its on go out. I cant change the station or see what station its on, I cant change it to cd player, no preset buttons work, on off dosent work either But the radio still plays the station and the volume knob works. Electric Gremlin?, or loose connection or maybe the radio is junk?
     
  2. May 3, 2011 at 7:53 PM
    #2
    Superx2

    Superx2 Well-Known Member

    Joined:
    Feb 20, 2011
    Member:
    #51552
    Messages:
    1,619
    Gender:
    Male
    First Name:
    Joey
    Iowa
    id say electric gremlin.
     
  3. May 5, 2011 at 7:06 AM
    #3
    Tango Bravo

    Tango Bravo Sailing the Seven Seas

    Joined:
    May 3, 2011
    Member:
    #55980
    Messages:
    74
    Gender:
    Male
    First Name:
    Thomas
    SoCal
    Vehicle:
    09 4x4
    Nothing yet, but once i get money well see what happens...
    go complain to the dealer
    i have the same truck and had the same problem
    they replaced the whole head unit
     
  4. May 5, 2011 at 8:21 AM
    #4
    tig1

    tig1 Well-Known Member

    Joined:
    Jun 3, 2009
    Member:
    #17976
    Messages:
    370
    Gender:
    Male
    First Name:
    Paul
    Saint John,New Brunswick,Canada
    Vehicle:
    2009 tacoma
    n fabs,window visor tonneau ,bilstein 5100's all round.245/75R16Toyo A/T II
    I had the same problem with my 2009,so I went to the dealer an they told me that there was a problem with alot of the 2009 radio's .they replaced mine no charge.Toyota might have a recall on it now,call and check.

    later tig1
     
  5. May 5, 2011 at 8:40 AM
    #5
    Zombie Runner

    Zombie Runner Are these black helicopters for me?

    Joined:
    Mar 13, 2008
    Member:
    #5246
    Messages:
    15,036
    Gender:
    Male
    First Name:
    Kevin
    Wichita Falls, TX
    Vehicle:
    Tundra, double cab.
    LED interior lights, stubby antenna, Pioneer in dash screen, good driver mod.
    im pretty sure there is a TSB on it. take it to the dealer and let them know the problem
     
  6. May 7, 2011 at 8:32 AM
    #6
    RyanPont

    RyanPont [OP] Well-Known Member

    Joined:
    Mar 9, 2011
    Member:
    #52704
    Messages:
    119
    Gender:
    Male
    What if the radio is working fine right now and i bring it to the dealer? They have to believe me, its not like i would try to get a stock radio just for the hell of it, id try to get something better than that
     
  7. May 9, 2011 at 8:10 AM
    #7
    tig1

    tig1 Well-Known Member

    Joined:
    Jun 3, 2009
    Member:
    #17976
    Messages:
    370
    Gender:
    Male
    First Name:
    Paul
    Saint John,New Brunswick,Canada
    Vehicle:
    2009 tacoma
    n fabs,window visor tonneau ,bilstein 5100's all round.245/75R16Toyo A/T II
    the radio's that were installed were bad when they put them in at the factory.my dealer at Saint John Toyota confirmed it and said I wasn't the only 2009.

    later tig1
     
To Top