1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

stock radio

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Jmartin89, Nov 11, 2009.

  1. Nov 11, 2009 at 2:50 AM
    #1
    Jmartin89

    Jmartin89 [OP] Well-Known Member

    Joined:
    Oct 5, 2009
    Member:
    #23813
    Messages:
    148
    Gender:
    Male
    First Name:
    James
    TEXAS
    Vehicle:
    09 tacoma TRD off road
    265/75/16 buckshot mudders, 3" lift OME 886 coils, LR UCA's, TRD cold air intake, AllPro rear bumper, rock sliders, and front bumper
    ive heard on here a lot of people talking about how bad the stock radio's are and i just wanted to know what problems everyone has with them i think mine is great it sounds good to me
     
  2. Nov 11, 2009 at 3:00 AM
    #2
    NWtacoma

    NWtacoma Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18142
    Messages:
    1,685
    Gender:
    Male
    Kent,WA
    Vehicle:
    2011 TRD Sport 4x4
    265/70/17 bfg AT
    I dont have any problems and mine sounds fine
     
  3. Nov 11, 2009 at 3:07 AM
    #3
    gupster88

    gupster88 Well-Known Member

    Joined:
    May 2, 2009
    Member:
    #16692
    Messages:
    3,791
    Gender:
    Male
    First Name:
    Brett
    Almost Heaven
    Vehicle:
    '17 Inferno DCSB O/R
    STOCK 4 NOW
    i actually prefer my stock head unit over getting an aftermarket unit. i mean you can't beat a built in 6 disc changer and all that...no probs or complaints with mine so far
     
  4. Nov 11, 2009 at 3:16 AM
    #4
    FARNORCAL

    FARNORCAL Well-Known Member

    Joined:
    Oct 26, 2009
    Member:
    #24923
    Messages:
    682
    Gender:
    Male
    First Name:
    Ryan
    EVERYWHERE
    Vehicle:
    06 Tacoma4x4 DC LB Silver TRD Sport
    SEE BUILD
    I just had to add an Ipod Adapter besides the the JBL's are rather decent.
     
  5. Nov 11, 2009 at 4:14 AM
    #5
    Capita

    Capita Well-Known Member

    Joined:
    Jun 6, 2009
    Member:
    #18096
    Messages:
    2,673
    Gender:
    Male
    Corner Brook, Newfoundland, Canada
    Vehicle:
    09 TRD Sport Double Cab
    Love my stock 6 disk changer. Used it every day with not a single issue. No complaints here at all. Quite happy with it.
     
  6. Nov 11, 2009 at 4:52 AM
    #6
    badguybuster

    badguybuster Well-Known Member

    Joined:
    Mar 8, 2009
    Member:
    #14475
    Messages:
    2,437
    Gender:
    Male
    West (by GOD) Virginia
    Vehicle:
    2008 Tundra Off Road SR5
    6000K HID Headlights 6000k HID Fog Lights Window visors (all 4) Tri-Fold Tonno Bedlined Rockers Bedlined Bumpers Bilstein 5100 Toytec 1/2" spacers 3" TSB Leafs and AAL's (Toytec) Differential 1" Drop Sway Bar Relocators BHLM Mod Debadged Pro Comp 7089s Hankook Dynapro 35" M/T's Billett Grill 55 watt fog lights in grill 55 watt fog lights on Pre-Runner Light Bar Rear Bilstein 5100's Flowmaster Super 10's Yellow Fog Light Mod Titanium Burl Wood Grain Dash Mod Leather Arm Rest Mod TRD Steering wheel Mod Painted Engine Cover Painted Fuse Box TRD Seat Belt Covers Bed Light Mod Extended/Braided Brake Lines Back up light mod
    My only complaint is crappy radio reception
     
  7. Nov 11, 2009 at 5:01 AM
    #7
    pataco

    pataco Well-Known Member

    Joined:
    Jan 1, 2009
    Member:
    #12092
    Messages:
    2,070
    Gender:
    Male
    Down by the lake
    Vehicle:
    05 4x4 trd dc white
    FOX 2.0 RESIS,LRUCAS,BILLY 5100S ON THE REAR.MAGNAFLOW 11264,COLOR MATCHED GRILL,YELLOW FOG MOD.OVER HEAD DVD,FEDERAL COURAGIA M/T
    stock here.sounds great imo.i think the younger folks on here r swaping them out as that is normal.i no i did when i was young just because i thought i had to.lol.
     
  8. Nov 11, 2009 at 5:11 AM
    #8
    V-TRAIN

    V-TRAIN Well-Known Member

    Joined:
    Jul 27, 2009
    Member:
    #20225
    Messages:
    863
    Gender:
    Male
    N. CACKALACKY
    Vehicle:
    08 TRD SPORT LONG BED
    DEMELLO ROCK CRUSHER SLIDERS, PIAA LIGHTS, TSB 4 LEAF PACK, CBI OFFROAD REAR BUMPER LINEXED, CBI OFFROAD FRONT BUMPER LINEXED, REAR 5100's, 1.5" TSB AAL, ICON EXTENDED TRAVEL COILOVERS @ 3", TOTAL CHAOS UCA's, HELLA MICRO DRIVING LIGHTS, IPOD INTERFACE, THULE ROOF RACK, UWS SLIM LINE BLACK TOOL BOX, 17" BBS RD TRUCK WHEELS, GOODYEAR WRANGLER DURATRAC IN 285/70/17
    love my stock unit, hardly ever use it. i installed a ipod interface, that is all i listen to. i have never put a cd in my truck. that is the best investment you can make, it sounds better than a cd.
     
  9. Nov 11, 2009 at 5:46 AM
    #9
    epa4wd

    epa4wd Well-Known Member

    Joined:
    Mar 17, 2009
    Member:
    #14828
    Messages:
    2,139
    Gender:
    Male
    First Name:
    Eduardo
    Vehicle:
    2015 TRD Sport
    Clazzio Seat Covers Extang Tri-Fold Soft Tonneau Cover TRD Skid Plate AMP Research Electric Steps 43% Llumar Security tint TRD Exhaust Fox 2.0 coilovers and rear shocks 16" TRD Fake Beadlocks Custom LED Cube mounts in foglight location TRD Pro Grill Wheelers progressive aal
    I liked mine it sounded decent enough for me, I changed it only because it started having issues (flickering lights) replaced it under warranty and replacement was also bad (screen went blank) so I went with aftermarket unit with stock speakers.
     
  10. Nov 11, 2009 at 6:28 AM
    #10
    dktaco

    dktaco Yes MAObama is a joke!

    Joined:
    Nov 9, 2009
    Member:
    #25643
    Messages:
    286
    Gender:
    Male
    First Name:
    Josh
    So. Cal (D-town aka Downey)
    Vehicle:
    05' Pre-Runner SR5 6-spd Modded
    5100's set @ 2.5", Wheeler's AAL, Toyota factory trailer hitch w/ a Reese 3.5" drop ball, Gaylord's Tonneau cover, BLHM w/ 35w 6000k HID's, Lumincs yellow fogs, Sylvania 886 bulbs in taillights for reverse lights, Debadged, Dee-Zee nerf bars, Shorty black antenna, 3M rubberized billet grille & surround, Toyo Open Country AT's 31's, K&N intake, 40 series Flowmaster, Redline Racing Synthetic fluid all the way around, Wet Okole set covers, dash mat, Sirius Starmate 5 hardwired, Cobra radar detector hardwired, paint always taken care of the finest products from Autogeek.net and a Porter Cable dual action polisher.
    Stock unit with US Aux for Sirius Satellite and i-pod hookup and no complaints.
     
  11. Nov 13, 2009 at 9:21 PM
    #11
    keppert

    keppert Sure..Whatever.

    Joined:
    Oct 26, 2009
    Member:
    #24951
    Messages:
    20
    Gender:
    Male
    First Name:
    Keith
    West Seattle, WA.
    Vehicle:
    10 DC 4X4 TRD Sport
    None, yet.
    Mine stopped working the other day. Didn't come on for two days then it came on for 1/2 hour then shut off again. I took it in to the dealer and they said that they have gotten a lot of calls about it. One guy had to wait 5 weeks to get one. They told me that Toyota just got around 1000 new ones in so hopefully I won't have to wait too long.

    Oh by the way, I have the JBL radio.
     
  12. Nov 13, 2009 at 9:28 PM
    #12
    hendooman

    hendooman The Stroker Ace

    Joined:
    Mar 6, 2009
    Member:
    #14421
    Messages:
    3,040
    Gender:
    Male
    First Name:
    Jeff
    KC
    Vehicle:
    2015 TRD PRO 4Runner
    I don't know that it sounds bad at low to med volume...it just has no balls at higher volume, and you lose the bass
     
  13. Nov 13, 2009 at 10:35 PM
    #13
    oldtimertoyota

    oldtimertoyota Well-Known Member

    Joined:
    Aug 5, 2009
    Member:
    #20697
    Messages:
    274
    Gender:
    Male
    New Mexico
    Vehicle:
    2009 4X4 Double Cab
    How do you add one of these?

    My original radio started messing up the first week I got my truck, my dealership replaced it though it took several months to get a radio in, back ordered.
     
  14. Nov 14, 2009 at 1:24 AM
    #14
    numbah57

    numbah57 GIVE THE MALL A BREAK...WHEEL THAT SHIT

    Joined:
    Oct 11, 2009
    Member:
    #24160
    Messages:
    3,460
    Gender:
    Male
    First Name:
    kahai
    Maui, Hawaii
    Vehicle:
    09 tacoma 2.7 Beaten not Babied
    URD ARB G2 PELFREY BAMF LCE AFE
    sometimes mines likes to shut off and not turn back on, or wierd characters pop up and then it turns off...gets very annoying
     
  15. Nov 14, 2009 at 6:17 AM
    #15
    Meeocky

    Meeocky GEAUX TIGERS!

    Joined:
    Sep 15, 2008
    Member:
    #9238
    Messages:
    30
    Louisiana
    Vehicle:
    Black '05 Tacoma
    My stock radio is fine. Anything in it's place besides a decently mounted touch screen looks odd. It doesn't "flow" with the dash like the stock headunit IMHO.

    I listen to my iPod as well,but use a pos fm transmitter. Which iPod adapters are you guys using?
     
  16. Nov 14, 2009 at 7:02 AM
    #16
    Old Soul

    Old Soul Well-Known Member

    Joined:
    May 9, 2009
    Member:
    #16995
    Messages:
    367
    Gender:
    Male
    NC
    Vehicle:
    09 AC V6 SR5 2WD SWB
    not to many, love it the way it is
    I do the " hit the dash mod " when the radio in my 09 messes up. seems to work everytime. to the op, the 2009 models had a bad batch of radios put in them and that is what you have heard about. flickering screen, ghostly controls that work on their own, it seems to be worst in the heat
     
  17. Nov 14, 2009 at 7:27 AM
    #17
    oldtimertoyota

    oldtimertoyota Well-Known Member

    Joined:
    Aug 5, 2009
    Member:
    #20697
    Messages:
    274
    Gender:
    Male
    New Mexico
    Vehicle:
    2009 4X4 Double Cab
    Your radio should be under warranty, take your truck in and get a new one.

    Old Soul, you need to do the same as well.

    My dealership swapped the radio out. I was really worried they would damage/scratch the dash, I'm really picky with this stuff. They did a great job and I could not tell they were in the dash, I guess they've had a lot of practice!:rolleyes:
     
  18. Nov 14, 2009 at 7:30 AM
    #18
    ClemsonTacoma

    ClemsonTacoma Well-Known Member

    Joined:
    Apr 20, 2009
    Member:
    #16193
    Messages:
    3,613
    Gender:
    Male
    First Name:
    Cam
    Lexington, SC
    Vehicle:
    Tacoma
    Pioneer DEH-P5100UB single din HU and black dash kit, Alpine 12" sub custom inverted box bed liner'd, various interior trim painted black, 48 blue LED domelight, cheepo floor mats, hose clamp mod, Cobra CB and knock off firestik, Stock steelie rims, with 265/75/16 Sumitomo HTR Sport A/T's
    WTF how did everybody get their new radio so soon! It's been 4 months!
     
  19. Nov 14, 2009 at 7:33 AM
    #19
    otter

    otter Well-Known Member

    Joined:
    Jul 27, 2009
    Member:
    #20249
    Messages:
    265
    Gender:
    Male
    First Name:
    Rob
    MI
    Vehicle:
    09 4 cyl Reg Cab
    Now that I've had my radio replaced, the only issue I have is that the aux input doesn't seem to be amplified adequately, so even at max volume the stuff I listen to isn't loud enough to hear clearly over road noise. I doubt I care enough to replace it, but if my taco ever becomes my DD, then I'll be getting a new headunit for it.
     
  20. Nov 14, 2009 at 7:33 AM
    #20
    otter

    otter Well-Known Member

    Joined:
    Jul 27, 2009
    Member:
    #20249
    Messages:
    265
    Gender:
    Male
    First Name:
    Rob
    MI
    Vehicle:
    09 4 cyl Reg Cab
    Call your dealer and bitch. It "only" took my dealer about 1.5 months to get mine.
     
To Top