1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Strange humming sound, possible bad power brake assist

Discussion in '1st Gen. Tacomas (1995-2004)' started by prerunnerSD, Aug 29, 2010.

  1. Aug 29, 2010 at 6:41 PM
    #1
    prerunnerSD

    prerunnerSD [OP] "I Brake for Tailgaters"

    Joined:
    Sep 7, 2009
    Member:
    #22428
    Messages:
    237
    Gender:
    Male
    First Name:
    Jonathan
    Northeast USA
    Vehicle:
    01 Tacoma Limited 6 cylinder 4X4
    Grill guard Front and rear Bilstein 5100's Front Coilovers Rear AAL "I Brake for Tailgaters" Firestone Destination A/T (P265/75/R16)
    weird whistle sound from car when brakes are depressed or i am not accelerating. anyone ever have this problem? what should i do, its starting to drive me a little nuts, lol.
     
  2. Aug 29, 2010 at 8:59 PM
    #2
    zero4

    zero4 Metal Cutter

    Joined:
    Sep 10, 2006
    Member:
    #31
    Messages:
    440
    Gender:
    Male
    First Name:
    Will
    Northridge, CA
    Vehicle:
    01' DCab 3.4L TRD
    Donahoe CO, Donahoe Rear Resi, Deaver J59, 16" Pro Comp, 33" BFG AT, Hayden Trans Oil Cooler, Oil Filter Relocator, FM 40, ES Bushings, Beefed CB Drop, Deckplate, K&N Drop-In, DO Bed Bar, Cobra 75 WXST, Firestik Firefly, Philips D1R, Clarion Remote Start, Husky Liners
    Link doesn't work:

     
To Top