1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Strange soun from engine

Discussion in 'New Members' started by silverboy, May 17, 2010.

  1. May 17, 2010 at 7:53 PM
    #1
    silverboy

    silverboy [OP] Member

    Joined:
    May 17, 2010
    Member:
    #37331
    Messages:
    19
    Gender:
    Male
    Hi, evrery one I have a question, I just bougth a toyota tacoma 2001 like a month ago and I did the oil change myself and after that I notice some noises on the engine like pinging noise and I went to the dealership and they told me just put fuel system cleaner for 3 or 4 tanks of gas and that it fixed it.
     
  2. May 19, 2010 at 8:45 PM
    #2
    jdkeller

    jdkeller How many words can be fit in this s

    Joined:
    Nov 26, 2008
    Member:
    #11040
    Messages:
    12,983
    Gender:
    Male
    First Name:
    Jonathan
    Inland Empire, Ca
    Vehicle:
    2008 Tacoma Prerunner TRD Offroad
    Dome light LED, 6000k HID Headlights and fogs, Grillcraft black mesh, rear 5100's, Total Chaos UCA's, 285/75/16 BFG KM2's, Spidertrax spacers, Blacked out emblems, cb,kenwood tm270 ham radio, All Pro 3" leaf pack, Fox 2.0 coilovers, Revenge Fab Sliders, u bolt flip kit, Pioneer avh4200, bed bar with light and antenna, Wet Okoles, Weathertech Mats, Wet Okole Armrests, Rear KR Fab bumper, bed mat, N-Fab spare tire carrier with full size spare on 16" TRD rim, Bedlinered flares and grille. Camburg Spindles, All Pro front fenders.
    Evrery? Bougth? That it fixed it?

    Please go and slap every single one of your past teachers. But only if you graduated.
     
  3. May 19, 2010 at 8:47 PM
    #3
    MAXTacoma

    MAXTacoma Well-Known Member

    Joined:
    Feb 15, 2007
    Member:
    #917
    Messages:
    4,339
    Gender:
    Male
    Vehicle:
    Lexus GS 350
    What is this the 3rd thread with misspellings?
     
To Top