1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

strange troubles, help, anyone?

Discussion in '1st Gen. Tacomas (1995-2004)' started by daveyboy, Jan 25, 2010.

  1. Jan 25, 2010 at 6:46 PM
    #1
    daveyboy

    daveyboy [OP] New Member

    Joined:
    Jan 25, 2010
    Member:
    #30026
    Messages:
    1
    Gender:
    Male
    First Name:
    Dave
    Idaho
    Vehicle:
    98, 2.7L
    Hi gents, and any ladies out there. New to the forum, sortof. I like to come and read up to get help on maintaining the truck. Awesome site!! So anyway, I've been having a problem with the truck that's been ongoing for a while and I wanted to see if anyone else has run into this and how you fix it.
    Oay, so here's my problem: my truck is a 98, 2.7L, manual. No matter what gear I'm in, if the rpm's get below 2100, the truck starts...lurching, I guess you could call it, and once I get above 2100 rpms, it stops the lurch. also, the check engine light comes on and blinks a few times and then goes away. Don't know if the engine light and the lurching are related.
    So, any thoughts?
    much appreciated,
    Dave
     
  2. Jan 25, 2010 at 10:32 PM
    #2
    mikesdoublecab

    mikesdoublecab LT Chase Truck

    Joined:
    Jun 15, 2008
    Member:
    #7334
    Messages:
    6,593
    Gender:
    Male
    First Name:
    Mohawk Mike
    Glendale, CA
    Vehicle:
    01 Tacoma DoubleCab V6 Prerunner
    Engage Offroad long travel front and rear with some fat tires.
    dirty MAF sensor...

    dirty fuel filter...

    O2 sensor(s)...
     
To Top