1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Supercharger Noise

Discussion in '2nd Gen. Tacomas (2005-2015)' started by JonnyT9111, Jan 27, 2010.

  1. Jan 27, 2010 at 9:18 PM
    #1
    JonnyT9111

    JonnyT9111 [OP] New Member

    Joined:
    Jan 27, 2010
    Member:
    #30196
    Messages:
    1
    Gender:
    Male
    TRD Supercharger
    I just purchased a used 2006 Tacoma with a dealer installed TRD supercharger. Today I got home from work around 7pm. I just went out to the garage (midnight) and the intercooler was pumping and circulating fluids. Is this normal 5 hours after the vehicle was turned off?

    Please post up. I am curious.

    Thanks in advance.

    Jon
     
  2. Jan 27, 2010 at 9:20 PM
    #2
    NWtacoma

    NWtacoma Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18142
    Messages:
    1,685
    Gender:
    Male
    Kent,WA
    Vehicle:
    2011 TRD Sport 4x4
    265/70/17 bfg AT
  3. Jan 27, 2010 at 9:44 PM
    #3
    Ptowntaco

    Ptowntaco Camburg :)

    Joined:
    Sep 14, 2009
    Member:
    #22772
    Messages:
    990
    Gender:
    Male
    First Name:
    Bryce
    Petaluma Ca.
    Vehicle:
    2000 Prerunner TRD
    Tint, Socked, Deck Plate mod, Camburg 2.5 coils, Camburg UCA, 5100's in the rear, Custom Deaver leaf pack, Micky Thomson Classic Locks, BFG KM2, CB
    Welcome to TW and i would bring it back to the dealer and have them look at it if you just got it... It dosnt sound right too me?
     
  4. Jan 27, 2010 at 11:46 PM
    #4
    rossk35

    rossk35 Do Work Son!

    Joined:
    Mar 26, 2009
    Member:
    #15197
    Messages:
    945
    Gender:
    Male
    hawaii
    Vehicle:
    07 TRD Sport Supercharged
    TRD S/C/TRD Intake/TRD Boost Gauge/DT Headers/OEM TL/ZKW retro/Pioneer DVD w/Ipod/Magnaflow/20% Tint/BHLM/JL 10" sub, JL VR components, JL 450/4 amp/Helwig Sway bar/Viper 791/ 18" limited 4runner rims
    Completely normal. It comes on every few hours for a minute or so because its tied into the efi fuse which does a few checks. Fuel pressure, etc. Mine does it all the time.
     
  5. Jan 27, 2010 at 11:52 PM
    #5
    roxspin72

    roxspin72 Enjoying my addiction

    Joined:
    Feb 9, 2008
    Member:
    #4659
    Messages:
    1,830
    Gender:
    Male
    NC
    Vehicle:
    Speedway Blue, TRD, 4X4,
    Oh Yeah!!!
    +1

    This is true, although I have not installed my SC yet, but upon reading multiple amounts of threads on XR-Underground; I did run across this topic. You have no worries..

    Enjoy the Boost.:D
     
  6. Jan 28, 2010 at 11:57 AM
    #6
    Coupe

    Coupe Well-Known Member

    Joined:
    Feb 10, 2009
    Member:
    #13485
    Messages:
    1,645
    Gender:
    Male
    Houston, Texas
    Vehicle:
    08 X-Runner
    Lots baby!
    It should only run for a few minutes then shut off. I believe this happens about every 4 hours as a regular diagnostic check.
     
  7. Jan 28, 2010 at 5:31 PM
    #7
    c0astie31

    c0astie31 TACO SUPREME

    Joined:
    Oct 15, 2009
    Member:
    #24349
    Messages:
    347
    Gender:
    Male
    First Name:
    Dennis
    Long Island ny
    Vehicle:
    2011 4Runner Trail Edition
    A LOT
    what he said, mine does it too
     
  8. Jan 28, 2010 at 5:52 PM
    #8
    Razorecko

    Razorecko Well-Known Member

    Joined:
    Jun 7, 2009
    Member:
    #18125
    Messages:
    1,447
    Gender:
    Male
    Vehicle:
    '09 Pyrite DCLB TRD Supercharged
    I have the trd blower on my taco also. Completely normal although a little un-nerving at first
     
To Top