1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Sway bar bolt at frame just turns and turns???

Discussion in 'Suspension' started by Fabulous, Sep 8, 2010.

  1. Sep 8, 2010 at 12:43 PM
    #1
    Fabulous

    Fabulous [OP] Well-Known Member

    Joined:
    Jul 17, 2009
    Member:
    #19807
    Messages:
    832
    Gender:
    Male
    First Name:
    Fabian
    Calgary, AB
    Vehicle:
    2006 Tacoma double-cab TRD Sport
    Homertaco grill, Light Racing UCA's, 2.8" front lift (5100's at 0.85 setting and Eibach springs) 2" AAL with rear 5100's, Wet Okole seat covers fr/ bk. 17 x 9 Incubus Crusher wheels w/ 4.5" backspacing. 30% tinted front windows.
    Hey all, I'm installing my front 5100's, and came accross a problem which is causing me great concern. While trying to remove my sway bar one of the bolts that connets to the frame won't come out...it just turns, and turns. I think what happened is the nut welded to the frame on the inside busted loose. I got my shocks out and ready to go, but now I'm worried that this semi-loose bolt on my sway bar is going to cause problems because only three will be holding it tight. Is there any way to get into this area to hold the nut to tighten it? I'm really worried this might f-up the drivability of my truck, so any help is really, really appreciated.
     
  2. Sep 8, 2010 at 12:45 PM
    #2
    wiscdave

    wiscdave Lets Do It!

    Joined:
    Mar 20, 2008
    Member:
    #5392
    Messages:
    2,547
    Gender:
    Male
    Northern Wisconsin
    Vehicle:
    Tundra Rock Warrior
    Past ride - 3" OME 885s&Shocks/ TSB 1.5AAL/ AX184 Rims 285 Firestone destination ATs/ 2 Shallow mount P310s in Supercrew Box - Punch 601s, Beefed up Hunter Brush guard, Tint, Fog light mod, AFE Drop in, AC and Fog light mods, scangauge
    on the end of the bolt is a spot to put an allen wrench to hold it..
     
  3. Sep 8, 2010 at 12:48 PM
    #3
    Fabulous

    Fabulous [OP] Well-Known Member

    Joined:
    Jul 17, 2009
    Member:
    #19807
    Messages:
    832
    Gender:
    Male
    First Name:
    Fabian
    Calgary, AB
    Vehicle:
    2006 Tacoma double-cab TRD Sport
    Homertaco grill, Light Racing UCA's, 2.8" front lift (5100's at 0.85 setting and Eibach springs) 2" AAL with rear 5100's, Wet Okole seat covers fr/ bk. 17 x 9 Incubus Crusher wheels w/ 4.5" backspacing. 30% tinted front windows.
    Not this one...this is one of the bolts that attach the sway bar to the frame...
     
  4. Sep 8, 2010 at 12:49 PM
    #4
    Masada

    Masada Well-Known Member

    Joined:
    Sep 10, 2009
    Member:
    #22555
    Messages:
    3,096
    Gender:
    Male
    First Name:
    Taylor
    Laveen, AZ
    Vehicle:
    05 Tacoma 4x4 TRD Off Road
    All Pro Steel Plate Front Bumper| All Pro Light Bar| All Pro IFS Skid Plate| All Pro E-locker guard| PIAA 510 Fog Lights| Hella 700FF| Fox 2.5 Coilover| Bilstein 5100 on the rear| BHLM| Grill Craft MX Series insert| Added two D-rings to bed|AVID Off Road sliders| AFE Dry Flow S| Gibson Cat Back| Custom Bedbar with hilift mount| Camburg 1" Uni-Ball UCA's| Hi-Lift 48" Extreme
    Yep, found that out on the prerunners...My 05 4x4 doesn't have a place for an allen wrench.
     
  5. Sep 8, 2010 at 12:50 PM
    #5
    AndrewFalk

    AndrewFalk Science!

    Joined:
    May 8, 2010
    Member:
    #36740
    Messages:
    2,062
    Gender:
    Male
    The North East
    Vehicle:
    2010 5 speed 5 lug
    :)
    Cut the bolt and buy a new one.
     
  6. Sep 8, 2010 at 12:52 PM
    #6
    Lentsnh

    Lentsnh Well-Known Member

    Joined:
    Nov 22, 2008
    Member:
    #10953
    Messages:
    9,550
    Gender:
    Male
    Vehicle:
    2007 Hummer H3 Tactical Edition
    None yet- Future: HIDs, Tinted tails, LED interior lights,
    is there any play in the threads? like does the bolt move up and down in the thread sleeve?

    Threads MAY be stripped... pull down on the bolt while turning and it should start to work its way through the "rough patch".
     
  7. Sep 8, 2010 at 12:54 PM
    #7
    Fabulous

    Fabulous [OP] Well-Known Member

    Joined:
    Jul 17, 2009
    Member:
    #19807
    Messages:
    832
    Gender:
    Male
    First Name:
    Fabian
    Calgary, AB
    Vehicle:
    2006 Tacoma double-cab TRD Sport
    Homertaco grill, Light Racing UCA's, 2.8" front lift (5100's at 0.85 setting and Eibach springs) 2" AAL with rear 5100's, Wet Okole seat covers fr/ bk. 17 x 9 Incubus Crusher wheels w/ 4.5" backspacing. 30% tinted front windows.
    You don't understand...there is a nut that is supposed to be welded to the inside of the frame, in the boxed section that broke loose. If I cut the bolt, then what? I'd be in the same position as the nut on the inside would still be loose.
     
  8. Sep 8, 2010 at 12:56 PM
    #8
    huntark03

    huntark03 I'd rather be hunting!

    Joined:
    Aug 4, 2010
    Member:
    #41207
    Messages:
    835
    Gender:
    Male
    First Name:
    Chris
    Maumelle, AR
    Vehicle:
    2005 Limited Tundra DC 4X4
    Spidertrax Wheel Spacers aFe Pro Dry Drop in Air Filter Weathertech Liners Bilstein 5100s w/ OME 885 coils and ToyTec 1.5" AALs Light Racing UCAs
    Mine did the same thing when I was removing my driver's side one. I tightened the bolt back down and tried backing it out again and everything was normal. It also went back in just fine after I installed my 5100's. Hope that helps...
     
  9. Sep 8, 2010 at 12:57 PM
    #9
    Lentsnh

    Lentsnh Well-Known Member

    Joined:
    Nov 22, 2008
    Member:
    #10953
    Messages:
    9,550
    Gender:
    Male
    Vehicle:
    2007 Hummer H3 Tactical Edition
    None yet- Future: HIDs, Tinted tails, LED interior lights,
    Only way I can think of, because the frame is boxed in the front... Take off the bumper skin and the bumper reinforcement.


    I dont think its sealed at the front of the frame. Maybe be to the extreme but you gotta do what has to be done.
     
  10. Sep 8, 2010 at 12:59 PM
    #10
    huntark03

    huntark03 I'd rather be hunting!

    Joined:
    Aug 4, 2010
    Member:
    #41207
    Messages:
    835
    Gender:
    Male
    First Name:
    Chris
    Maumelle, AR
    Vehicle:
    2005 Limited Tundra DC 4X4
    Spidertrax Wheel Spacers aFe Pro Dry Drop in Air Filter Weathertech Liners Bilstein 5100s w/ OME 885 coils and ToyTec 1.5" AALs Light Racing UCAs

    I didn't remove my whole sway bar...you should be able to swing it up and out of the way....
     
  11. Sep 8, 2010 at 1:04 PM
    #11
    Fabulous

    Fabulous [OP] Well-Known Member

    Joined:
    Jul 17, 2009
    Member:
    #19807
    Messages:
    832
    Gender:
    Male
    First Name:
    Fabian
    Calgary, AB
    Vehicle:
    2006 Tacoma double-cab TRD Sport
    Homertaco grill, Light Racing UCA's, 2.8" front lift (5100's at 0.85 setting and Eibach springs) 2" AAL with rear 5100's, Wet Okole seat covers fr/ bk. 17 x 9 Incubus Crusher wheels w/ 4.5" backspacing. 30% tinted front windows.
    I can shine a flashlight in this small hole, and I see that the nut was spot welded in 4 spots on the inside of the frame...those broke loose. Maybe there was too much rust/ buildup on it that when I was turning it, it just broke loose?! I think I'm screwed here unless I can get something in there to jam the nut from turning, and tighten it.
     
  12. Sep 8, 2010 at 1:06 PM
    #12
    Fabulous

    Fabulous [OP] Well-Known Member

    Joined:
    Jul 17, 2009
    Member:
    #19807
    Messages:
    832
    Gender:
    Male
    First Name:
    Fabian
    Calgary, AB
    Vehicle:
    2006 Tacoma double-cab TRD Sport
    Homertaco grill, Light Racing UCA's, 2.8" front lift (5100's at 0.85 setting and Eibach springs) 2" AAL with rear 5100's, Wet Okole seat covers fr/ bk. 17 x 9 Incubus Crusher wheels w/ 4.5" backspacing. 30% tinted front windows.
    I'm not worried about getting the sway bar out of the way...I'm worried about when I button everything up, one of the 4 sway bar bolts that attach to the frame will be loose.
     
  13. Sep 8, 2010 at 1:07 PM
    #13
    Lentsnh

    Lentsnh Well-Known Member

    Joined:
    Nov 22, 2008
    Member:
    #10953
    Messages:
    9,550
    Gender:
    Male
    Vehicle:
    2007 Hummer H3 Tactical Edition
    None yet- Future: HIDs, Tinted tails, LED interior lights,
    Only way I can think of, because the frame is boxed in the front... Take off the bumper skin and the bumper reinforcement.


    I dont think its sealed at the front of the frame. Maybe be to the extreme but you gotta do what has to be done.


    Use a crowbar or a long screw driver..
     
  14. Sep 8, 2010 at 2:12 PM
    #14
    Fabulous

    Fabulous [OP] Well-Known Member

    Joined:
    Jul 17, 2009
    Member:
    #19807
    Messages:
    832
    Gender:
    Male
    First Name:
    Fabian
    Calgary, AB
    Vehicle:
    2006 Tacoma double-cab TRD Sport
    Homertaco grill, Light Racing UCA's, 2.8" front lift (5100's at 0.85 setting and Eibach springs) 2" AAL with rear 5100's, Wet Okole seat covers fr/ bk. 17 x 9 Incubus Crusher wheels w/ 4.5" backspacing. 30% tinted front windows.
    I don't think that'll do it...it's much too far to get at that way, plus the nut is square.
     
  15. Sep 8, 2010 at 4:31 PM
    #15
    MAtrdguy

    MAtrdguy Well-Known Member

    Joined:
    May 28, 2010
    Member:
    #37957
    Messages:
    226
    Gender:
    Male
    First Name:
    Pete
    Western Ma ( on the lake) / Danvers N Shore
    Vehicle:
    06 Taco DC LB
    None YET
    same thing happened to me. You need to find a 7/16th self tapping screw and force it in there ( make sure it is a hex head screw. 3/8's is too small
     
  16. Sep 8, 2010 at 4:59 PM
    #16
    Fabulous

    Fabulous [OP] Well-Known Member

    Joined:
    Jul 17, 2009
    Member:
    #19807
    Messages:
    832
    Gender:
    Male
    First Name:
    Fabian
    Calgary, AB
    Vehicle:
    2006 Tacoma double-cab TRD Sport
    Homertaco grill, Light Racing UCA's, 2.8" front lift (5100's at 0.85 setting and Eibach springs) 2" AAL with rear 5100's, Wet Okole seat covers fr/ bk. 17 x 9 Incubus Crusher wheels w/ 4.5" backspacing. 30% tinted front windows.
    I can't even get the old one out. It was about 1/3 out when the inside nut snapped off the frame. This lift has been so frustrating I wish I'd never done it...
     
  17. Sep 8, 2010 at 10:17 PM
    #17
    Fabulous

    Fabulous [OP] Well-Known Member

    Joined:
    Jul 17, 2009
    Member:
    #19807
    Messages:
    832
    Gender:
    Male
    First Name:
    Fabian
    Calgary, AB
    Vehicle:
    2006 Tacoma double-cab TRD Sport
    Homertaco grill, Light Racing UCA's, 2.8" front lift (5100's at 0.85 setting and Eibach springs) 2" AAL with rear 5100's, Wet Okole seat covers fr/ bk. 17 x 9 Incubus Crusher wheels w/ 4.5" backspacing. 30% tinted front windows.
    Anyone alse? I don't even know what to do now. I don't think it's safe to drive like this?!
     
  18. Sep 8, 2010 at 10:34 PM
    #18
    zero4

    zero4 Metal Cutter

    Joined:
    Sep 10, 2006
    Member:
    #31
    Messages:
    440
    Gender:
    Male
    First Name:
    Will
    Northridge, CA
    Vehicle:
    01' DCab 3.4L TRD
    Donahoe CO, Donahoe Rear Resi, Deaver J59, 16" Pro Comp, 33" BFG AT, Hayden Trans Oil Cooler, Oil Filter Relocator, FM 40, ES Bushings, Beefed CB Drop, Deckplate, K&N Drop-In, DO Bed Bar, Cobra 75 WXST, Firestik Firefly, Philips D1R, Clarion Remote Start, Husky Liners
    Not sure if you have access to air tools. If there's enough room between the nut & the frame, wedge a flat head or chisel in between to keep pressure on the nut. This will pull the welded nut that broke off back against the frame, then hit with short bursts with an impact gun, 1/2" not necessary, 3/8" gun will do.

    If you don't have air tools & the nut is not a threadlocking type (ie nylock or distorted type) then you might be able to do it by hand.
     
  19. Sep 9, 2010 at 5:32 AM
    #19
    Masada

    Masada Well-Known Member

    Joined:
    Sep 10, 2009
    Member:
    #22555
    Messages:
    3,096
    Gender:
    Male
    First Name:
    Taylor
    Laveen, AZ
    Vehicle:
    05 Tacoma 4x4 TRD Off Road
    All Pro Steel Plate Front Bumper| All Pro Light Bar| All Pro IFS Skid Plate| All Pro E-locker guard| PIAA 510 Fog Lights| Hella 700FF| Fox 2.5 Coilover| Bilstein 5100 on the rear| BHLM| Grill Craft MX Series insert| Added two D-rings to bed|AVID Off Road sliders| AFE Dry Flow S| Gibson Cat Back| Custom Bedbar with hilift mount| Camburg 1" Uni-Ball UCA's| Hi-Lift 48" Extreme
    You can drive with or without a sway bar so I'm not sure it's going to affect the driveability of the truck. Have you called a dealer to see if a mechanic can assit you?
     
  20. Sep 9, 2010 at 5:39 AM
    #20
    huntark03

    huntark03 I'd rather be hunting!

    Joined:
    Aug 4, 2010
    Member:
    #41207
    Messages:
    835
    Gender:
    Male
    First Name:
    Chris
    Maumelle, AR
    Vehicle:
    2005 Limited Tundra DC 4X4
    Spidertrax Wheel Spacers aFe Pro Dry Drop in Air Filter Weathertech Liners Bilstein 5100s w/ OME 885 coils and ToyTec 1.5" AALs Light Racing UCAs
    Could you cut the end of it and ush the rest up onto the frame? Then get a self tapping screw like the other guy said...
     
To Top