1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Sway Bar Issue

Discussion in 'Suspension' started by AFButters, Oct 10, 2009.

  1. Oct 10, 2009 at 6:36 PM
    #1
    AFButters

    AFButters [OP] Rigger, Please

    Joined:
    Sep 10, 2008
    Member:
    #9113
    Messages:
    9,502
    Gender:
    Male
    First Name:
    "Butters"
    Rio Rancho, NM -- From Frisco, TX
    Vehicle:
    2008 DC 4x4 TRD-Sport
    Lifted
    I took the sway bar off of my truck when i installed my OME Lift, well today i was cleaning out the garage and noticed that one of the joints had a small hole in it and the grease/lube inside the joint has leaked out.. it appears from moving it around there was still some inside.. is there anyway to fix this easily.. or is my sway bar f**ked.. you know incase i wanted to put it back on again at some point
     
  2. Oct 10, 2009 at 7:04 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    104,126
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Just replace it. Its an end link.
     
  3. Oct 10, 2009 at 8:17 PM
    #3
    AFButters

    AFButters [OP] Rigger, Please

    Joined:
    Sep 10, 2008
    Member:
    #9113
    Messages:
    9,502
    Gender:
    Male
    First Name:
    "Butters"
    Rio Rancho, NM -- From Frisco, TX
    Vehicle:
    2008 DC 4x4 TRD-Sport
    Lifted
    its not the end link its the middle link
     
  4. Oct 10, 2009 at 8:32 PM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    104,126
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    WTF are you talking about?
     
  5. Oct 10, 2009 at 8:37 PM
    #5
    AFButters

    AFButters [OP] Rigger, Please

    Joined:
    Sep 10, 2008
    Member:
    #9113
    Messages:
    9,502
    Gender:
    Male
    First Name:
    "Butters"
    Rio Rancho, NM -- From Frisco, TX
    Vehicle:
    2008 DC 4x4 TRD-Sport
    Lifted
    its the second joint.. not the very end one
    sway bar.jpg
     
  6. Oct 10, 2009 at 8:40 PM
    #6
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    104,126
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Its one peice, Man...Its an "End Link" or "Stabilizer Link Assembly". Dont sweat it, and if you are gonna run it, get a new one.
     
  7. Oct 10, 2009 at 8:49 PM
    #7
    AFButters

    AFButters [OP] Rigger, Please

    Joined:
    Sep 10, 2008
    Member:
    #9113
    Messages:
    9,502
    Gender:
    Male
    First Name:
    "Butters"
    Rio Rancho, NM -- From Frisco, TX
    Vehicle:
    2008 DC 4x4 TRD-Sport
    Lifted
    aight thanks chris..
     
  8. Oct 10, 2009 at 8:55 PM
    #8
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    104,126
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    ;)
     
  9. Oct 10, 2009 at 8:55 PM
    #9
    DTacoms

    DTacoms Well-Known Member

    Joined:
    Jun 15, 2007
    Member:
    #1844
    Messages:
    660
    Gender:
    Male
    Frisco, Texas
    Vehicle:
    05 4x4 DC LB BSP
    I had similar issue. The rubber at the joint connecting to the knuckle got torn. Do I really need to replace it or is it ok to continue running with it? How much does it cost?

    I see some guys removing the sway bars, so having a sway bar with this condition may be better?
     
  10. Oct 10, 2009 at 8:59 PM
    #10
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    104,126
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Its not a big deal if it gets torn. It will still work. You might get a clunking noise from it, but if it gets bad, just replace the end link.
     
  11. Oct 10, 2009 at 9:52 PM
    #11
    DTacoms

    DTacoms Well-Known Member

    Joined:
    Jun 15, 2007
    Member:
    #1844
    Messages:
    660
    Gender:
    Male
    Frisco, Texas
    Vehicle:
    05 4x4 DC LB BSP
    I'll take your word Chris. Thanks.

    But, I will Toyota extra care to see if they'll cover it.
     
  12. Oct 10, 2009 at 9:53 PM
    #12
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    104,126
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Good idea.
     
To Top