1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Taco Radio Problems

Discussion in 'Technical Chat' started by rhion82, Jan 18, 2010.

  1. Jan 18, 2010 at 3:33 PM
    #1
    rhion82

    rhion82 [OP] El Duderino

    Joined:
    Jun 29, 2009
    Member:
    #19084
    Messages:
    1,549
    Gender:
    Male
    First Name:
    Mitchell
    Ringgold, GA
    Vehicle:
    10 Taco w/ SOS bumper and skids, complete OME lift, and 4x sliders
    Well today when I went to go to the gym I noticed that my radio was not working right. It would not turn on unless I hit the eject switch. Even after I did that the numbers on the display would not come on like it was just a blank screen.. I could not play a CD change the FM1 to FM2 or AM. Only thing I could do was turn the volume up or down and change the station by the knobs. I checked some of the fuses to see if they had been blown but nothing was noticeably different. I'm stuck and I dont know what to do! Please help lol......
     
  2. Jan 18, 2010 at 3:44 PM
    #2
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,188
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    I didnt have the exact same problem as you but when I bought my 06" brand new, it didnt have any radio reception at all so I couldnt pick up any stations. They had to order a whole new radio and swap it out. Then the second time my radio started cutting in and out but that was an alternator problem, not the radios.:eek:
     
  3. Jan 18, 2010 at 3:47 PM
    #3
    kws129

    kws129 Well-Known Member

    Joined:
    Jan 23, 2009
    Member:
    #12880
    Messages:
    248
    Gender:
    Male
    PA
    Vehicle:
    TRD Off Road Double Cab
    You might want to check with Toyota, I won't swear that there is a STB on this but I have talked to several people who have had the "phantom radio" problem.

    I think the biggest problem right now is that if you need a new radio it's a couple month back order since they had a bunch going bad.

    But I would check with Toyota they may replace it for you.
     
  4. Jan 18, 2010 at 3:48 PM
    #4
    kws129

    kws129 Well-Known Member

    Joined:
    Jan 23, 2009
    Member:
    #12880
    Messages:
    248
    Gender:
    Male
    PA
    Vehicle:
    TRD Off Road Double Cab
    'STB' what the......#$^@##. I mean TSB (Technical Service Bulletin)
     
  5. Jan 18, 2010 at 3:48 PM
    #5
    dysfunctnlretard

    dysfunctnlretard Hi

    Joined:
    Jun 5, 2009
    Member:
    #18080
    Messages:
    3,760
    Gender:
    Male
    First Name:
    Manny
    CA
    Vehicle:
    2010 FJC
    55w HIDs, 16" Countersteer Offroads, Yokahama All Terrains, Demello Sliders
    Sound like its time for a Touchscreen Double Din :thumbsup:
     
  6. Jan 18, 2010 at 3:50 PM
    #6
    rhion82

    rhion82 [OP] El Duderino

    Joined:
    Jun 29, 2009
    Member:
    #19084
    Messages:
    1,549
    Gender:
    Male
    First Name:
    Mitchell
    Ringgold, GA
    Vehicle:
    10 Taco w/ SOS bumper and skids, complete OME lift, and 4x sliders
    I'm just afraid that I have to replace it cause I didnt buy from a Toyota Dealer and its a 05. I will go and check to see if all the other lights still work on it.
     
  7. Jan 20, 2010 at 6:16 AM
    #7
    rhion82

    rhion82 [OP] El Duderino

    Joined:
    Jun 29, 2009
    Member:
    #19084
    Messages:
    1,549
    Gender:
    Male
    First Name:
    Mitchell
    Ringgold, GA
    Vehicle:
    10 Taco w/ SOS bumper and skids, complete OME lift, and 4x sliders
    Well when I got in my truck yesterday morning, to my suprise the radio started to play loud as it could. For some reason it just started working again. So hopefully it won't get infected by the "Tacoma Ghost" again or I might just have to call the Ghost Busters.
     
  8. Jan 20, 2010 at 9:13 AM
    #8
    sethr21785

    sethr21785 Well-Known Member

    Joined:
    Jan 15, 2010
    Member:
    #29372
    Messages:
    170
    Gender:
    Male
    First Name:
    Seth
    Windham Maine
    Vehicle:
    09 TRD SPORT
    TRD Short Throw, TRD Exhaust, 5100 1.5, Weathertech floor liners, AFE Filter, Projector Head and fogs, Weathertech vent visors
    Tacoma stereos are horrible. My truck is an 09 and my stereo is always turning itself off, lights dont work most of the time, get weird messages on the screen. Toyota ordered me a new one a few months ago and I am still waiting on it. backorder
     
  9. Jan 20, 2010 at 9:22 AM
    #9
    bigburrito

    bigburrito Local Man

    Joined:
    Mar 13, 2009
    Member:
    #14660
    Messages:
    557
    Gender:
    Male
    DuPage County
    Vehicle:
    '09 TRD OR
    Demello sliders, fog lights anytime, 265/75R16 Duratracs, 60" HiLift, VIAIR OBA 2.5 gallon tank, FM Super 44, TSB springs, 5100s at .85, bent tailgate
    i used to have the phantom radio in the summer, but now since its gotten colder the ghost seems to have gone into hibernation.
    usually when it started acting up i would just give the screen a good push it would work for a while. it seems like there are loose connections in there that just need a jostling every now and then.
     
  10. Jan 20, 2010 at 9:32 AM
    #10
    Fever

    Fever Well-Known Member

    Joined:
    Nov 3, 2009
    Member:
    #25372
    Messages:
    114
    Gender:
    Male
    Portland, Maine
    Vehicle:
    TRD OFF RD
    TRD exhaust,remote starter, heated seats, Westin Bull Bar,TRD CAI, Weathertechs
    I have 2010 and the radio does not cut out like others are reporting and I get radio reception but it is very poor. Radio stations come in but with static, very much below what I would expect.
     
  11. Feb 23, 2010 at 4:57 PM
    #11
    neoimpaler

    neoimpaler New Member

    Joined:
    Feb 23, 2010
    Member:
    #31995
    Messages:
    3
    Gender:
    Male
    VA
    Vehicle:
    09 SR5
    i got a 09 tacoma, during the summer it wouldnt work right. weird stuff. could only change stations/song with steering wheel, volume knob wouldnt work...it even shut itself off when iput the emergency brake in once.

    called the dealer, the lady on the phone laughed. apperently it had happened before. they ordered a new one, installed it, no charge, and its worked fine ever since
     
  12. Mar 9, 2010 at 12:11 PM
    #12
    paidfor

    paidfor Well-Known Member

    Joined:
    Aug 21, 2009
    Member:
    #21536
    Messages:
    755
    Gender:
    Male
    Austin, TX
    Vehicle:
    2013 TRD OR 4x4
    Hidden GPS tracking system. Backflip cover, weather techs, bed mat, tailgate lock, OME 885 springs, blistein shocks, 2.5 in AAL/
    09 here. Mine turns off/on by itself, changes stations by itself and turns on the CD player by itself. I talked to the dealer and they said they would order me a new one. They said there were a lot of complaints about the radio in Tacoma's. They were back ordered for quite some time. Mine is supposed to be in this Sat. I am taking it by there to have it replaced. Hopefully they do not screw anything up doing the swap.
     
  13. Mar 11, 2010 at 11:51 AM
    #13
    JDCPA

    JDCPA Well-Known Member

    Joined:
    Nov 15, 2008
    Member:
    #10777
    Messages:
    933
    Gender:
    Male
    First Name:
    Jim
    SW FL
    Vehicle:
    09 5 Lug Access Cab SR5
    Curt Hitch and etrailer.com wiring harness.
    The stock radio has the sensitivity of a brick.
     
  14. Mar 23, 2010 at 6:12 PM
    #14
    blackwidow2009

    blackwidow2009 Well-Known Member

    Joined:
    Mar 13, 2010
    Member:
    #33112
    Messages:
    221
    Gender:
    Male
    First Name:
    Brian
    Cleveland
    Vehicle:
    09 Access Cab 4X4 TRD w/ SR5
    2.5" front lift Daystar coilover spacer. 2.5" rear lift add-a-leaf N-Fab wheel to wheel nerf/step bar Polished Stainless Leer cap from my 2000 Tacoma --- It does fit; don't let them lie to you

    ok, I read this and all the ones under it (now, above this one lol). I have an '09 and have had the same problems...on/off, no display, no control, hyrogliphic display. Had the radio replaced twice now, they said that there was bad sodering inside from the manufature...some Chinesse company that Toyota buys them from. It only acts up when the radio is hot; like it the summer with no AC on, or even in winter with the heat cranked and the radio loud. If this is the only problem, it is totally do-able. haha
     
  15. Mar 23, 2010 at 6:15 PM
    #15
    tacoballs

    tacoballs member

    Joined:
    Nov 24, 2009
    Member:
    #26472
    Messages:
    100
    Gender:
    Male
    First Name:
    Jeffrey
    Reche Canyon
    Vehicle:
    06 4x4 double cab
    tail lights, lift, wheels and tires,navagation, subwoofer,viper security and electric start,bull bar with 2 5in light, billet grill kit, and a 12 in tv
    i have a stock 05 radio thats just been sitting in my garage for a couple yearsss id be willing to ship it to u to see if it works out or something adn if it works you could spot me a little cash back if not you can keep itt
     
  16. Nov 21, 2014 at 5:55 AM
    #16
    Rotary12

    Rotary12 Member

    Joined:
    Jan 29, 2010
    Member:
    #30299
    Messages:
    11
    Gender:
    Male
    Minnesota
    Topper and bed rug
    My '10 is now starting to mysteriously shut off at random times. Pushing the power button turns it back on, but I'm concerned how much the dealer will charge if it fails now. It's not like you can replace it with an aftermarket radio.
     
  17. Nov 21, 2014 at 9:31 AM
    #17
    texascolt45

    texascolt45 Well-Known Member

    Joined:
    Dec 16, 2012
    Member:
    #93182
    Messages:
    350
    Gender:
    Male
    First Name:
    mike
    groves texas
    Vehicle:
    prerunner 4 cylinder
    wheels,bilsteins,side bars
    Toyota changed my radio twice when it was new,the third one is starting to screw up again,you might check and see what they will do.
     
  18. Nov 21, 2014 at 10:31 AM
    #18
    Rotary12

    Rotary12 Member

    Joined:
    Jan 29, 2010
    Member:
    #30299
    Messages:
    11
    Gender:
    Male
    Minnesota
    Topper and bed rug
    Thanks, I'll do that.
     
To Top