1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Tacoma engine noise

Discussion in '2nd Gen. Tacomas' started by fasttalker372, Nov 22, 2008.

  1. Nov 22, 2008 at 8:00 AM
    #1
    fasttalker372

    fasttalker372 [OP] Member

    Joined:
    Nov 22, 2008
    Member:
    #10943
    Messages:
    8
    Gender:
    Male
    macungie, pa
    Vehicle:
    05 biscaine
    I have a 2WD 2005 Tacoma 4 cyl 5 speed with 70K. When I start it, it sounds fine, but after it warms up, It souds like a diesel when idleing. If I rev it up a little, the noise goes away. Is this just a Toyota noise or is it something more serious?
    thanks,
    chet
     
  2. Nov 22, 2008 at 8:08 AM
    #2
    luk8272

    luk8272 Poodoo

    Joined:
    Feb 24, 2008
    Member:
    #4929
    Messages:
    5,842
    Gender:
    Male
    First Name:
    Lucas
    Kaplan, Louisiana
    Vehicle:
    07 Silver4dr. 4x4, V6 Shortbed
    5% Tint, Bug flector, vent Visors, Removed secondary air filter, Rear Spring TSB w/ Wheeler's Add A Leaf HD Pack, Icon 2.0 rear shocks, Toytec 3" lift up front with Total Chaos UCA's, Debadged, Billet Grille,TRD Offroad rims/17x9 Pro comp 6001 rims, Duratracs 265/75/16 or 285/70/17, Fog light anytime mod, Tailgate hose clamp mod, Pro-dry AFE filter. Extended Differential Breather, ABS on/off, 6000k LEDs from CSJumper, heads/fogs, ScanguageII, Devil horns, Devil horns on third brake light, Mounted 60" Highlift, Mounted Tool Box, Wet Okole Front/Rear Seat Covers, TW sticker, Midland Handheld CB,Painted engine cover, Revenge Fab Sliders, ARE Topper, Weather tech Floorliners.
    Welcom to TW, hopefully we can help. Sounding like a deisel isn't normal, however if you are hearing a ticking noise that is perfectly normal, most of us have it and haven't found a way to stop it. Trial and error some fixes work, some don't it veries from truck to truck. If this is what you are experiencing use the search and type in Ticking, should have a few hits.
     
  3. Nov 22, 2008 at 3:49 PM
    #3
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    104,117
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Welcome to Tacoma WOrld!!!
    My 2000 2.7 made the same sound at idle. Smooth idle, and sound went away when reved, or driveing. Never thought much about it, and never had an issue with the engine in all the years I had it.
     
  4. Nov 22, 2008 at 4:28 PM
    #4
    Ridingontrd

    Ridingontrd Well-Known Member

    Joined:
    May 7, 2008
    Member:
    #6459
    Messages:
    7,967
    Gender:
    Male
    First Name:
    Richard
    Laughlin,N.V
    Vehicle:
    trd sport 4x4 w/towpkg
    aFe prodry,Dynomax ultra flo ss,Scangauge2,Demello front bumper,BudBuilt skids,sliders(local)AllPro rear bumper,Wet O's cobalt blu,w/halfpiping,TRD logo in gold,R/L hood struts,5150's@10"aal 3 pack,T/C uca,Light racing c/o,1"diff.drop,de-badged,
    Welcome to TW.:)
     
  5. Nov 22, 2008 at 10:05 PM
    #5
    surfsupl

    surfsupl Well-Known Member

    Joined:
    Jan 8, 2008
    Member:
    #4161
    Messages:
    8,575
    Gender:
    Male
    First Name:
    Gregg
    WestCoast
    Vehicle:
    I DONT CARE IF IT'S A RE-POST
    Rear Diff Breather~ 5100's ~Fog Light Anytime~Tint~TRD Seat Covers~Weather Tech's~Pioneer H.U.~Lift~Eibach Springs~LED's......blah...blah...blah
    Welcome to TW! Its an on going subject here at TW. I found with my truck that Mobil 1 Tri-Synthetic Motor Oil with SuperSyn with high octane gas seems to quiet mine down. Individual results may very! Good luck!

    :D
     
  6. Nov 23, 2008 at 12:50 AM
    #6
    P. Bauer

    P. Bauer Well-Known Member

    Joined:
    Sep 26, 2008
    Member:
    #9496
    Messages:
    163
    Gender:
    Male
    San Jose
    Vehicle:
    08 Tacoma 4x4 TRD Off-Road
    TRD S/C :: Intake Camburg SwayAway Magnaflow American Racing Donahoe Racing Wheelers OffRoad
    with the TRD S/C. =D

    I am almost positive it is the injectors. The TRD kit came with new injectors and the ticking noise at idle is gone.

    I think the stock injectors are just loud.
     
  7. Nov 23, 2008 at 4:53 AM
    #7
    fasttalker372

    fasttalker372 [OP] Member

    Joined:
    Nov 22, 2008
    Member:
    #10943
    Messages:
    8
    Gender:
    Male
    macungie, pa
    Vehicle:
    05 biscaine
    Hey, Thanks everyone! I've been a little worried and now I feel better. thanks for your help.
     
To Top