1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Take a fools advice regarding Bestop install

Discussion in '2nd Gen. Tacomas (2005-2015)' started by TRDKenE, Apr 2, 2011.

  1. Apr 2, 2011 at 2:21 PM
    #1
    TRDKenE

    TRDKenE [OP] DAMN GOOD DEAL!!

    Joined:
    Jul 6, 2009
    Member:
    #19348
    Messages:
    698
    Gender:
    Male
    First Name:
    Kenny
    Richmond, Virginia
    Vehicle:
    '10 D-CAB OFF-ROAD 4X4
    TRD CAI, GrillCraft.
    DONT unless it is at least 100 degrees outside. I installed mine in 50* weather and its on but a few of the zippers wont zip, between that and the rain/hail it was a F-IN Bitch!!!! Figured I had it sitting inside the house but I guess thats different the 80* of direct sunlight.

    For those of you have who have one installed can you snap some pics of the actual position of the bed rails (front to back and side to side) I just want to make sure I have this thing where it should be. I dont want the damn thing flyin off doin 80 down the highway.
     
  2. Apr 2, 2011 at 2:25 PM
    #2
    FARNORCAL

    FARNORCAL Well-Known Member

    Joined:
    Oct 26, 2009
    Member:
    #24923
    Messages:
    682
    Gender:
    Male
    First Name:
    Ryan
    EVERYWHERE
    Vehicle:
    06 Tacoma4x4 DC LB Silver TRD Sport
    SEE BUILD
    If your having problems with zippers hit it up with some wax. You can maybe pick up some candle sticks. I've used it at work a few times to prevent rust and salt build up ;)
     
To Top