1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

TB and IAC Cleaning

Discussion in 'Technical Chat' started by boshak, Mar 28, 2012.

  1. Mar 28, 2012 at 10:01 PM
    #1
    boshak

    boshak [OP] Well-Known Member

    Joined:
    May 23, 2010
    Member:
    #37663
    Messages:
    519
    Gender:
    Male
    First Name:
    Tony
    Southern California
    Vehicle:
    2003 Manual 4x4 5VZ-FE
    OME 881's, Wheeler's 5-leaf pack, Bilstein 5100's
    I'm getting ready to clean the MAF/TB and IAC valve. What's weird is my dealership couldn't find the rubber gasket between the IAC and TB. He was using my VIN.

    I've been told the gasket part number is 22215-62180. I looked up my VIN on ToyoDIY.com and searched for the part. The part is not applicable to my vehicle but the site shows applicable to other 1st gens.

    Anybody else experience this? Does my truck not have an IAC valve or gasket?
     
  2. Mar 28, 2012 at 10:30 PM
    #2
    boshak

    boshak [OP] Well-Known Member

    Joined:
    May 23, 2010
    Member:
    #37663
    Messages:
    519
    Gender:
    Male
    First Name:
    Tony
    Southern California
    Vehicle:
    2003 Manual 4x4 5VZ-FE
    OME 881's, Wheeler's 5-leaf pack, Bilstein 5100's
  3. Mar 28, 2012 at 11:40 PM
    #3
    Robertgeejr1

    Robertgeejr1 Well-Known Member

    Joined:
    Dec 21, 2011
    Member:
    #69167
    Messages:
    774
    Gender:
    Male
    First Name:
    Robert
    Aorora, Ill, yeah!
    Vehicle:
    1996 Toyota Tacoma SR5 4x4
    I have done all the hi-pro mods for a life time, since I got this truck at a great price, I will be happy with showroom new.
  4. Mar 29, 2012 at 12:21 AM
    #4
    boshak

    boshak [OP] Well-Known Member

    Joined:
    May 23, 2010
    Member:
    #37663
    Messages:
    519
    Gender:
    Male
    First Name:
    Tony
    Southern California
    Vehicle:
    2003 Manual 4x4 5VZ-FE
    OME 881's, Wheeler's 5-leaf pack, Bilstein 5100's
    Thanks Robert. Hopefully I can clarify my scenario...

    I've seen a lot of people remove the IAC valve (exact to the thread you linked). I just found out today that 2003 and up 5vz-fe's got the new ECTS throttle bodies. Dealers says there's no gasket or removable IAC valve and I'm not finding one on the parts list either.

    Do the 2003+ 5vz's have an IAC valve still? Does it need to be cleaned with the throttle body and how?
     
  5. Dec 29, 2013 at 8:26 AM
    #5
    jayyyg84

    jayyyg84 Active Member

    Joined:
    Jun 22, 2010
    Member:
    #39320
    Messages:
    38
    Gender:
    Male
    First Name:
    joe
    atomic city
    Vehicle:
    tacoKruizer
    toyo tech coilover
    Hey bud... So did you ever find out about our trucks being equipped with an isc or iac since our year of 2003 seems to be the only year with this different set. I had some codes come up like I believe p0103 n p0101. High voltage input maf n something with iac. But when you look in the engine there is clearly no iac with that green part you plug into. My mpg went down very bad too after. Any help you an offer I appreciate.
     
To Top