1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Temperamental AC- Sometimes works fine, sometimes only on high, or not at all

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Thombo44, May 26, 2021.

  1. May 26, 2021 at 2:14 PM
    #1
    Thombo44

    Thombo44 [OP] New Member

    Joined:
    May 26, 2021
    Member:
    #366851
    Messages:
    3
    Gender:
    Male
    First Name:
    Thomas
    Vehicle:
    2012 White Tacoma TRD Off Road
    Leveling kit, blacked out rims, step up bar
    Hey everyone, new member here!

    My 2012 Tacoma's AC used to work fine. In the summer of 2020 I noticed it sometimes only worked on high. This issue became more and more frequent. I did some research on this forum and found that it's most likely the blower motor resistor. I was going to replace it, but a few weeks ago the AC went out entirely. It came back on an hour later though. This has happened twice. It'll always come back on pretty soon. The issue of it only blowing on high still persists as well.

    Is this an different problem entirely or should the resistor take care of it?? Any insight is greatly appreciated. Thanks!
     
  2. May 26, 2021 at 2:23 PM
    #2
    Jojee117

    Jojee117 Well-Known Member

    Joined:
    Jul 30, 2018
    Member:
    #261068
    Messages:
    767
    Gender:
    Male
    First Name:
    Joe
    MT
    Vehicle:
    06 TRD Sport Prerunner 4WD swapped
    You can check the resistor plug to see if there is a burned pin. If one of the pins or wires looks burned, atleast you know that's part of the problem. If that's the case, then go ahead and replace the resistor and connector. Hopefully that'll be it.
     
  3. Jun 28, 2021 at 4:23 PM
    #3
    Thombo44

    Thombo44 [OP] New Member

    Joined:
    May 26, 2021
    Member:
    #366851
    Messages:
    3
    Gender:
    Male
    First Name:
    Thomas
    Vehicle:
    2012 White Tacoma TRD Off Road
    Leveling kit, blacked out rims, step up bar
    Just now getting to reply to this. I replaced just the resistor to start and it worked! I have a new wiring harness too in case it gives out in the future. Thanks for the help!
     
    Steves104x4 likes this.
  4. Jun 28, 2021 at 4:30 PM
    #4
    JoshS

    JoshS Well-Known Member

    Joined:
    Aug 31, 2019
    Member:
    #303869
    Messages:
    237
    Gender:
    Male
    First Name:
    Josh
    Vehicle:
    2014 Tacoma TRD Sport DCSB 4x4
    You still have the P/Ns handy for the resistor and harness? I want to pick up some extras myself
     
  5. Jun 29, 2021 at 4:00 PM
    #5
    Thombo44

    Thombo44 [OP] New Member

    Joined:
    May 26, 2021
    Member:
    #366851
    Messages:
    3
    Gender:
    Male
    First Name:
    Thomas
    Vehicle:
    2012 White Tacoma TRD Off Road
    Leveling kit, blacked out rims, step up bar

Products Discussed in

To Top