1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Testing out the GY Wranglers

Discussion in 'Tacoma Videos' started by isu2014, Jul 5, 2010.

  1. Jul 5, 2010 at 1:12 PM
    #1
    isu2014

    isu2014 [OP] RAT Products

    Joined:
    Apr 12, 2010
    Member:
    #35140
    Messages:
    12,646
    Gender:
    Male
    First Name:
    Ryan
    Farmington, MN
    Vehicle:
    01 SUPERCHARGED TRD OR MANUAL 4x4 V6
    View the build. Too much to list.
    Took my truck through a decent swamp yesterday to see how the Goodyear Wrangler silentarmor's handle mud. Stock everything except exhaust. Went with 4 low and locked the rear to be safe.

    http://www.youtube.com/watch?v=iMZ-D4wADu0

    [​IMG]

    [​IMG]


    Now begins the long task of cleaning the weeds and crap from the underbody.
     
  2. Jul 5, 2010 at 2:21 PM
    #2
    DevL

    DevL Well-Known Member

    Joined:
    Feb 23, 2010
    Member:
    #31952
    Messages:
    1,922
    Gender:
    Male
    Boy are your rear springs going to squeak!
     
  3. Jul 5, 2010 at 2:48 PM
    #3
    Jimmyjohn

    Jimmyjohn Well-Known Member

    Joined:
    Mar 6, 2010
    Member:
    #32643
    Messages:
    892
    Gender:
    Male
    First Name:
    Jim
    Big Sky Country Montana
    Vehicle:
    06 SR5 4x4 DLB CAB
    Smitty Blt Bull Bar& Skid Plate, PIAA 525SMR lights
    Well it looks like you had a lot of fun now clean it up!
     
  4. Jul 5, 2010 at 4:33 PM
    #4
    isu2014

    isu2014 [OP] RAT Products

    Joined:
    Apr 12, 2010
    Member:
    #35140
    Messages:
    12,646
    Gender:
    Male
    First Name:
    Ryan
    Farmington, MN
    Vehicle:
    01 SUPERCHARGED TRD OR MANUAL 4x4 V6
    View the build. Too much to list.
    Actually they were squeaking before this from all the car washes i do, so I lubed them up nice and now they are fine.
     
  5. Jul 5, 2010 at 4:53 PM
    #5
    AKTacoma

    AKTacoma Dedicated Crew Chief

    Joined:
    Jun 2, 2010
    Member:
    #38279
    Messages:
    379
    Gender:
    Male
    First Name:
    Chris
    Houma, Louisiana
    Vehicle:
    08 Tacoma DCLB
    What'd you lube em up with?
     
  6. Jul 5, 2010 at 5:04 PM
    #6
    isu2014

    isu2014 [OP] RAT Products

    Joined:
    Apr 12, 2010
    Member:
    #35140
    Messages:
    12,646
    Gender:
    Male
    First Name:
    Ryan
    Farmington, MN
    Vehicle:
    01 SUPERCHARGED TRD OR MANUAL 4x4 V6
    View the build. Too much to list.
    I use tri-flow lubricant. Works very well and it is safe on the rubber bushings and everything.
     
  7. Jul 7, 2010 at 8:20 PM
    #7
    AKTacoma

    AKTacoma Dedicated Crew Chief

    Joined:
    Jun 2, 2010
    Member:
    #38279
    Messages:
    379
    Gender:
    Male
    First Name:
    Chris
    Houma, Louisiana
    Vehicle:
    08 Tacoma DCLB
    Thanks man, I'll definitely give that a shot, my springs squeak a whole bunch!
     
To Top