1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

toyo taco 2000

Discussion in '1st Gen. Tacomas (1995-2004)' started by TheTicosTaco, Mar 19, 2009.

  1. Mar 19, 2009 at 3:24 AM
    #1
    TheTicosTaco

    TheTicosTaco [OP] Member

    Joined:
    Mar 11, 2009
    Member:
    #14589
    Messages:
    15
    Gender:
    Male
    CenCal,
    Vehicle:
    4x4,3rz,lifted,intake,exz,campshell
    intake,exs,liftkit3",3rz,campershell,etc
    hey i just lifted my truck 3" with revtek spacers and rancho struts and fabtek in rear . for some reason over little bumps it feels like front end hit . is that normal ? like if the struts wornt workin .
     
  2. Mar 19, 2009 at 5:34 AM
    #2
    MCRANEY

    MCRANEY WARTHOG

    Joined:
    Mar 2, 2009
    Member:
    #14236
    Messages:
    65
    Gender:
    Male
    CRESTVIEW FL
    Vehicle:
    03 Tacoma 4WD SR5 TRD
    3" Lift 285/75 16R Tires Aries Stainless Steel Grille Guard, KC Lights
    i have the 3 inch revtek lift, left the original billy's on the front and upgraded the rear. mine does not hit, it is just a rough ride, not sure if it is because the lift or the 285/75 stt's i have on it.
     
To Top