1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Tranny Solenoids

Discussion in '4 Cylinder' started by ronggg, Feb 27, 2013.

  1. Feb 27, 2013 at 11:53 AM
    #1
    ronggg

    ronggg [OP] New Member

    Joined:
    Feb 27, 2013
    Member:
    #98604
    Messages:
    2
    Gender:
    Male
    First Name:
    Ron
    CA
    Vehicle:
    04 PreRummer 2wd Auto
    My truck 2004 4cyl Tacoma runs and shifts fine but the check engine light stays on and I cannot pass a smog test. Error codes were PO741 & PO743 this is why I did all the following solenoid testing. When I do an air and voltage test on the 3 internal shift solenoids in the trans, 1 solenoid functions as described, air passes thru in a non voltage situation and does not pass thru in a voltage applied situation. The other two, click, yet air will not pass thru in a voltage applied or un-applied situation. All solenoids register 2-5ohms. When shaken the 1st shift solenoid that passed the air & voltage test make a rattling sound. The other two that will not allow air to pass thru in a voltage applied or not situation do not make a rattling noise when shaken. Is it possible that 2 solenoids that will not allow air to pass are defective and still my truck runs and shifts fine?
     
To Top