1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Tried some fixes, still code P0300

Discussion in '1st Gen. Tacomas (1995-2004)' started by klank, Jul 19, 2022.

  1. Jul 19, 2022 at 3:09 PM
    #1
    klank

    klank [OP] Member

    Joined:
    Nov 9, 2020
    Member:
    #346319
    Messages:
    21
    Gender:
    Male
    been fighting a p0300 for a while now. symptom is a rough idle on startup, sometimes but runs fine after about 10 to 20 seconds. occasionally it feels like ive lost some power. ive read a bunch of stuff on here and tried some fixes. truck is 2002 tacoma 3.4 manual supercharged w/smaller pully, 7th injector kit, 145k miles. ive replaced coils, wires, plugs, fuel filter, MAF, air filter, belts. i had the fuel inectors serviced. checked compression, all was good except cylinder 3 was just sliiightly lower than the rest. timing belt was done less than 50k ago. any leads would b appreciated as i need to get smogged and have some long drives coming up.
     
  2. Jul 19, 2022 at 3:17 PM
    #2
    Diablo169

    Diablo169 ROKRAPR

    Joined:
    Mar 12, 2016
    Member:
    #181079
    Messages:
    2,558
    Gender:
    Male
    First Name:
    Max
    Santa Cruz, CA
    Vehicle:
    99’ Bro-Coma’s Revenge 3RZ 333k
    Stock
    Was all that maintenance work before or after the misfire.
     
  3. Jul 19, 2022 at 3:19 PM
    #3
    klank

    klank [OP] Member

    Joined:
    Nov 9, 2020
    Member:
    #346319
    Messages:
    21
    Gender:
    Male
    everything except timing belt was after the missfire
     
  4. Jul 19, 2022 at 5:47 PM
    #4
    Digiratus

    Digiratus Adventurer

    Joined:
    Mar 26, 2010
    Member:
    #34006
    Messages:
    21,336
    Gender:
    Male
    First Name:
    Mike
    Roaming the PNW
    Vehicle:
    The RedHead
    2002 XtraCab TRD 4x4 SCv6 AutoTrans With Lots of Mods ADS COs w/Compression Adjusters Camburg Uniball UCAs Whiteline Lower Control Arm Bushings Kartek 7" Limit Straps Plastics Guy Front Bumpstops Custom Alcan Springs +800 lbs +3" ADS 10" Stroke Triple Bypass w/Resi Rear Shocks Custom Rear Shock Relocate All-Pro U-bolt Flip w/Timbren Bumpstops 4.88 Nitro Gears ARB Front Locker ARB Twin Compressor Black 17x8 Konig Countersteer Type X 285/70r17 Falken A/T3w Gunmetal 16x8 SCS Ray10s 255/85r16 Maxxis Bighorns Limited Edition (Relentless) Elite Front Bumper Smittybilt X2O 10K Winch Diode Dynamics SS3 Sport Selective Yellow Fog Lights in the Bumper Diode Dynamics SS3 Pro 4,000 Kelvin SAE Driving Lights with Clear Lenses on the Bumper Mini D2S Projectors XB35 Ballasts + 4500K Bulbs Badland Sliders FrankenFab Tire Carrier Swingout bumper w/kitchen BudBuilt Front & Bellypan Skids BAMF Rear Diff Skid Dometic CFX 55im Fridge/Freezer Alpha II Hardshell RTT Badland Custom Bed Rack GM 140 amp alternator Dual Northstar 24F AGM batteries BlueSea 7622 ML-ACR Battery controller Peak DBI Dual Battery Voltage Monitor Magnuson MP62 Supercharger w/2.37" Pulley Haltech Elite 2000 Standalone Computer Denso 650cc Fuel Injectors Doug Thorley Headers Aeromotive Stealth 340 Fuel Pump Magnaflow 18" Muffler w/Vibrant Resonator and upstream CAT delete 13WL Brake Calipers Braided Steel Brake Lines ScanGauge II OBDII Scanner Kenwood TM-71A Dual Band Ham Radio Larson 70CM/2M Antenna Uniden 520xl CB radio 3' Firestik Adjustable tip antenna Pioneer DEH-P9400BH HU Alpine Amps & Type R components (F) and coaxials (R) Wet Okole Seat Covers Weathertech Digital Liners Deck Plate Mod 1" Diff Drop Carrier Bearing Drop
    What spark plugs are you running?
     
  5. Jul 19, 2022 at 5:56 PM
    #5
    klank

    klank [OP] Member

    Joined:
    Nov 9, 2020
    Member:
    #346319
    Messages:
    21
    Gender:
    Male
    ik22. a step down as recomended with the 7th injector kit. although now im pondering if i need different plugs with the smaller 2.2 pully? hmmm
     
  6. Jul 19, 2022 at 6:13 PM
    #6
    Digiratus

    Digiratus Adventurer

    Joined:
    Mar 26, 2010
    Member:
    #34006
    Messages:
    21,336
    Gender:
    Male
    First Name:
    Mike
    Roaming the PNW
    Vehicle:
    The RedHead
    2002 XtraCab TRD 4x4 SCv6 AutoTrans With Lots of Mods ADS COs w/Compression Adjusters Camburg Uniball UCAs Whiteline Lower Control Arm Bushings Kartek 7" Limit Straps Plastics Guy Front Bumpstops Custom Alcan Springs +800 lbs +3" ADS 10" Stroke Triple Bypass w/Resi Rear Shocks Custom Rear Shock Relocate All-Pro U-bolt Flip w/Timbren Bumpstops 4.88 Nitro Gears ARB Front Locker ARB Twin Compressor Black 17x8 Konig Countersteer Type X 285/70r17 Falken A/T3w Gunmetal 16x8 SCS Ray10s 255/85r16 Maxxis Bighorns Limited Edition (Relentless) Elite Front Bumper Smittybilt X2O 10K Winch Diode Dynamics SS3 Sport Selective Yellow Fog Lights in the Bumper Diode Dynamics SS3 Pro 4,000 Kelvin SAE Driving Lights with Clear Lenses on the Bumper Mini D2S Projectors XB35 Ballasts + 4500K Bulbs Badland Sliders FrankenFab Tire Carrier Swingout bumper w/kitchen BudBuilt Front & Bellypan Skids BAMF Rear Diff Skid Dometic CFX 55im Fridge/Freezer Alpha II Hardshell RTT Badland Custom Bed Rack GM 140 amp alternator Dual Northstar 24F AGM batteries BlueSea 7622 ML-ACR Battery controller Peak DBI Dual Battery Voltage Monitor Magnuson MP62 Supercharger w/2.37" Pulley Haltech Elite 2000 Standalone Computer Denso 650cc Fuel Injectors Doug Thorley Headers Aeromotive Stealth 340 Fuel Pump Magnaflow 18" Muffler w/Vibrant Resonator and upstream CAT delete 13WL Brake Calipers Braided Steel Brake Lines ScanGauge II OBDII Scanner Kenwood TM-71A Dual Band Ham Radio Larson 70CM/2M Antenna Uniden 520xl CB radio 3' Firestik Adjustable tip antenna Pioneer DEH-P9400BH HU Alpine Amps & Type R components (F) and coaxials (R) Wet Okole Seat Covers Weathertech Digital Liners Deck Plate Mod 1" Diff Drop Carrier Bearing Drop
    That sounds correct. For Denso coding the 22s are 2 steps colder that stock. I don't think you want to ge any further, even for the 2.2" pulley.

    Have you inspected them? Do they look clean?
     
  7. Jul 19, 2022 at 6:54 PM
    #7
    klank

    klank [OP] Member

    Joined:
    Nov 9, 2020
    Member:
    #346319
    Messages:
    21
    Gender:
    Male
    well they look fine. the first time i threw the code like a year ago, i checked them and cylinder 3 plug was wet. swapped that one out and it was fine for a while. next time it happened the plug wasnt wet. seems off and on more frequently happening
     
  8. Jul 23, 2022 at 12:57 PM
    #8
    Logans2001

    Logans2001 What’s crackin’

    Joined:
    Jan 23, 2016
    Member:
    #175792
    Messages:
    1,177
    Gender:
    Male
    San Diego, CA
    Vehicle:
    2001 v6 4WD auto
    Did you end up finding the culprit? I’m also dealing with a p0300 at the moment. Replacing the upstream O2 sensor tomorrow hoping that helps. I also replaced plugs, coils, wires, hoses, fuel filter within the past 2 years. Fuel pump got done few weeks ago. No change. Injectors have not been touched yet. Hoping it’s that and not something worse.
     
  9. Jul 23, 2022 at 1:02 PM
    #9
    klank

    klank [OP] Member

    Joined:
    Nov 9, 2020
    Member:
    #346319
    Messages:
    21
    Gender:
    Male
    i have not solved it. light stays off mostly if i drive it every day. passed emissions test yesterday luckily so at least im good for another 2 years long as this issue isnt causing engine damage. im assuming some stupid sensor is acting up, and all the head gasket symptom checks seem to be coming back negative to that being the problem. lemme know if ur o2 sensor fixes urs, i out in new o2 sensors probly 40k miles ago...
     
  10. Aug 5, 2022 at 5:04 PM
    #10
    Logans2001

    Logans2001 What’s crackin’

    Joined:
    Jan 23, 2016
    Member:
    #175792
    Messages:
    1,177
    Gender:
    Male
    San Diego, CA
    Vehicle:
    2001 v6 4WD auto
    Thread revival..
    The upstream air/fuel sensor didn’t fix it. Also just replaced all 6 injectors along with the fuel pressure regulator two days ago. That wasn’t it either. Pulled all my plugs and inspected them. They were all dry from what I could tell. Brushed them up a little and put them back. Tightened up the valve cover bolts too. It started up fine for the rest of that day but ended up misfiring again upon start up the next day as well as the CEL. I’m running out of ideas. Guess compression/leak down tests might have to be next. Dreading the worst.
    0300 0420 chase continues.
     
  11. Aug 5, 2022 at 5:10 PM
    #11
    Logans2001

    Logans2001 What’s crackin’

    Joined:
    Jan 23, 2016
    Member:
    #175792
    Messages:
    1,177
    Gender:
    Male
    San Diego, CA
    Vehicle:
    2001 v6 4WD auto
    Question for anyone:
    Is the p0300 a misfire that only occurs upon starting or is it continuous as I drive it and I just can’t tell that it is like I can when I start it?
     
  12. Aug 5, 2022 at 8:49 PM
    #12
    klank

    klank [OP] Member

    Joined:
    Nov 9, 2020
    Member:
    #346319
    Messages:
    21
    Gender:
    Male
    hmmm, my assumption us that if it was still happening while u drive it, then it would trip the engine light again (actually it did that to me once. the engine started stuttering and the engine light was flashing on and off. pulled over restarted the truck and it was fine after that). im currently traveling but i might try another compression test to see if its changed since last time i checked over a year ago.
     
  13. Aug 7, 2022 at 12:32 PM
    #13
    ArizonaBrian

    ArizonaBrian Well-Known Member

    Joined:
    Oct 25, 2019
    Member:
    #309002
    Messages:
    192
    Gender:
    Male
    I know you've said your head gasket test come out good but I would pull the plugs after the vehicle sits overnight and stick a boroscope down in there and see if you're getting any antifreeze pooling up on the cylinders. I had a vehicle that passed a couple different head gasket tests but in a last ditch effort I used a boroscope and found that indeed I had a gasket leak. It would run rough on cold start and clear up after a few seconds after it burned the coolant up.
     
  14. Aug 7, 2022 at 4:06 PM
    #14
    klank

    klank [OP] Member

    Joined:
    Nov 9, 2020
    Member:
    #346319
    Messages:
    21
    Gender:
    Male
    thats a good idea, i shall give it a try. although it definitely doesnt always have a rough start after sitting, it seems like it just happenes randomly although only in the first start up of the day.
     
  15. Aug 7, 2022 at 4:14 PM
    #15
    Logans2001

    Logans2001 What’s crackin’

    Joined:
    Jan 23, 2016
    Member:
    #175792
    Messages:
    1,177
    Gender:
    Male
    San Diego, CA
    Vehicle:
    2001 v6 4WD auto
    I’m experiencing the same. I was attempting to do a compression test just now and noticed my coolant level looks lower than where I usually see it at the very top. The motor is still somewhat warm though. Is that normal? Will the coolant level come back to normal level as the motor cools off completely? I’m not sure of the mechanics of it. Or am I losing coolant and I’m possibly dealing with a head gasket issue?
     
  16. Aug 7, 2022 at 4:23 PM
    #16
    klank

    klank [OP] Member

    Joined:
    Nov 9, 2020
    Member:
    #346319
    Messages:
    21
    Gender:
    Male
    my coolant level was slightly low too, but i also haddnt ever checked it since i bought the vehicle like 8 years ago. but i think u can loose some here and there over time if it boils over into the overflow reservoir?
     

Products Discussed in

To Top