1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Trouble after installing TB Tundra

Discussion in '2nd Gen. Tacomas (2005-2015)' started by BlueT@com@4×4, Jul 4, 2022.

  1. Jul 4, 2022 at 8:39 AM
    #1
    BlueT@com@4×4

    BlueT@com@4×4 [OP] Well-Known Member

    Joined:
    Dec 30, 2020
    Member:
    #351081
    Messages:
    226
    Gender:
    Male
    Vehicle:
    2015 TRD PRO Tacoma
    Hi Guys,
    I just finish installing 2007 TB Tundra on 2nd gen with URD adapter TB plus with K&N 63-9037, the idle between 800 to 1k on warm engine but once I turn AC on the idle back to 600 to 800 sounds normal to me only when I drove it and stop at traffic light the idle take longer to normal state. Another problem comes out with the code, P0505,P0102,P0113,P2433 and P2438 all connected with I just install I clean the code but they coming back, so I don't know where to start fix it or change it. Do I have bad TB Tundra maybe?
    Any input will be appreciate it. Thank you Guys
     
  2. Jul 4, 2022 at 8:49 AM
    #2
    TodayWasTHeDaY

    TodayWasTHeDaY Hoser

    Joined:
    Jul 10, 2017
    Member:
    #223673
    Messages:
    2,031
    Gender:
    Male
    First Name:
    Russ
    Calgary
    Vehicle:
    2015 DCSB SC M/T TRD Sport
    There's a set screw covered under a blob of epoxy. If you back it off about a full turn it improves the idle.

    The ecu takes a while to learn and smooth it out somewhat.
     
  3. Jul 4, 2022 at 8:54 AM
    #3
    BlueT@com@4×4

    BlueT@com@4×4 [OP] Well-Known Member

    Joined:
    Dec 30, 2020
    Member:
    #351081
    Messages:
    226
    Gender:
    Male
    Vehicle:
    2015 TRD PRO Tacoma

    Great, I was thinking that too but don't want cause break the TB itself. Thanks man
    Are you run some setup on your SC?
     
  4. Jul 4, 2022 at 9:12 AM
    #4
    TodayWasTHeDaY

    TodayWasTHeDaY Hoser

    Joined:
    Jul 10, 2017
    Member:
    #223673
    Messages:
    2,031
    Gender:
    Male
    First Name:
    Russ
    Calgary
    Vehicle:
    2015 DCSB SC M/T TRD Sport
    Yeah running same on my SC'd truck. I believe manual trans trucks have more trouble with the idle with those throttle bodies. Also, I'm tuned with Hptuners and JustDSM made some adjustments to the ecu to for the throttle body.
     
  5. Jul 4, 2022 at 9:12 AM
    #5
    TodayWasTHeDaY

    TodayWasTHeDaY Hoser

    Joined:
    Jul 10, 2017
    Member:
    #223673
    Messages:
    2,031
    Gender:
    Male
    First Name:
    Russ
    Calgary
    Vehicle:
    2015 DCSB SC M/T TRD Sport
    I did have some weird issues and codes at one point that a battery disconnect ended up solving as well
     
  6. Jul 4, 2022 at 2:27 PM
    #6
    BlueT@com@4×4

    BlueT@com@4×4 [OP] Well-Known Member

    Joined:
    Dec 30, 2020
    Member:
    #351081
    Messages:
    226
    Gender:
    Male
    Vehicle:
    2015 TRD PRO Tacoma
    Awesome. Thanks for great tips
     
  7. Jul 4, 2022 at 3:27 PM
    #7
    BlueT@com@4×4

    BlueT@com@4×4 [OP] Well-Known Member

    Joined:
    Dec 30, 2020
    Member:
    #351081
    Messages:
    226
    Gender:
    Male
    Vehicle:
    2015 TRD PRO Tacoma
    I try the screw under expo back full turn not much different even all the way until I take it off the idle still high, only when first start is work but after drive little bit back to high. The code coming back but I take negative cable from battery and wait 20 minutes see what happen.
     
  8. Jul 4, 2022 at 6:05 PM
    #8
    Geeves77

    Geeves77 Well-Known Member

    Joined:
    Feb 16, 2020
    Member:
    #319439
    Messages:
    2,011
    Gender:
    Male
    First Name:
    Mark
    Northeast
    Vehicle:
    2011 Tacoma DCSB
    3 inch Icon lift with UCA’s
    Re-learn idle process done?
     
  9. Jul 4, 2022 at 7:58 PM
    #9
    BlueT@com@4×4

    BlueT@com@4×4 [OP] Well-Known Member

    Joined:
    Dec 30, 2020
    Member:
    #351081
    Messages:
    226
    Gender:
    Male
    Vehicle:
    2015 TRD PRO Tacoma
    I did many times not success but the last one is work, right now around 600 to 800 but I turn the AC on the idle jump into 1K , still not consistent idle .. need figure out to lower when the AC is on.
     

Products Discussed in

To Top