1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Trouble installing lights on avid light bar

Discussion in '2nd Gen. Tacomas (2005-2015)' started by PreRunner, May 24, 2010.

  1. May 24, 2010 at 12:20 PM
    #1
    PreRunner

    PreRunner [OP] Well-Known Member

    Joined:
    Feb 7, 2010
    Member:
    #30930
    Messages:
    401
    Gender:
    Male
    At first I got PIAA 520 ATP's, they did not fit. Now I'm trying to mount a pair of lightforce lance 140's, and also having trouble. When the lenses are aimed straight forward, the mounting bracket will not line up. Pic below. What should I do ... find some way to shim that difference (no idea how), or bend the light bar's mounting tabs down? It's also touching the bumper too, slightly. But I think they can be mounted with maybe a sixteenth of an inch between the bracket and bumper. Any ideas? :confused:

    [​IMG]
     
  2. May 24, 2010 at 12:26 PM
    #2
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,188
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
    Hmmmm....no idea since I dont have any lights mounted on mine.:cool: Have you tried PM'in any of the people that do have lights mounted on theirs? That would probably be your best bet.:rolleyes:
     
  3. May 24, 2010 at 12:28 PM
    #3
    PreRunner

    PreRunner [OP] Well-Known Member

    Joined:
    Feb 7, 2010
    Member:
    #30930
    Messages:
    401
    Gender:
    Male
    yes only 1 wih this configuration, got PM's in from long ago. He hasn't been on in awhile.
     
  4. May 24, 2010 at 12:31 PM
    #4
    DeeKay21

    DeeKay21 Lieutenant Dan.

    Joined:
    Nov 11, 2008
    Member:
    #10651
    Messages:
    14,188
    Gender:
    Male
    Nevada/Utah
    Vehicle:
    06' TRD Sport 4x4
  5. May 24, 2010 at 12:50 PM
    #5
    jspadaro

    jspadaro Well-Known Member

    Joined:
    Jan 7, 2009
    Member:
    #12342
    Messages:
    2,994
    Gender:
    Male
    First Name:
    Jim
    Knoxville, TN
    Vehicle:
    Former Tacoma Owner
    Blue Oval Mod
    I couldn't get my hella 500's to point straight forward by dropping them in the tab, so I added some washers underneath it to make up the difference, worked perfect for me.
     
  6. May 24, 2010 at 1:26 PM
    #6
    HondaGM

    HondaGM Roll Tide

    Joined:
    Oct 28, 2009
    Member:
    #25056
    Messages:
    5,769
    Gender:
    Male
    First Name:
    James
    South-Pole
    Vehicle:
    09 DC 4x4 Blown Honda VTEC V8
    trd exhaust,step bars,vent visors,bed lights,tailgate mod
    turn the bracket on top around,and shim.or elongate the hole
     
  7. Aug 28, 2010 at 4:31 PM
    #7
    H2Otx

    H2Otx The Tinkerer

    Joined:
    Jun 10, 2010
    Member:
    #38728
    Messages:
    221
    Gender:
    Male
    First Name:
    Austin
    Houston, Texas
    Vehicle:
    10 DC 4x2 SR5 TRD Off-Road
    SilverStar Ultra Headlights; Nokya Ion Yellow Fogs; SuperBright LED Bulbs; 8" Shorty Antenna; WeatherTech Mats / Bug Shield / Vent Visors; TRD CAI with aFe Pro Dry S Filter; aFe Pre-Filter; Custom CAI Cover and Fuse Box Cover; TRD AT Shift Knob (Japan); TRD Oil Filler Cap (Japan); n-Fab Step Rails; Monster Hook
    Any luck getting the lights to fit right?
     
To Top