1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Truck making a squealing noise

Discussion in '1st Gen. Tacomas (1995-2004)' started by 2004Taco, Dec 26, 2009.

  1. Dec 26, 2009 at 7:35 PM
    #1
    2004Taco

    2004Taco [OP] Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9556
    Messages:
    527
    Gender:
    Male
    Long Beach,CA
    Vehicle:
    04 PreRunner SR5 Trd
    Magnaflow and Deckplate Mod Billet grille
    When I let off the gas, my truck makes a squealing noise. It stared when I put my new muffler on. Can anyone help me figure it out?
     
  2. Dec 26, 2009 at 7:44 PM
    #2
    JAG

    JAG Well-Known Member

    Joined:
    Oct 9, 2008
    Member:
    #9847
    Messages:
    1,753
    Was it a muffler to make your truck louder or quieter? Do you offroad in your truck? It may be your leaf pack needs grease.
     
  3. Dec 26, 2009 at 8:31 PM
    #3
    2004Taco

    2004Taco [OP] Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9556
    Messages:
    527
    Gender:
    Male
    Long Beach,CA
    Vehicle:
    04 PreRunner SR5 Trd
    Magnaflow and Deckplate Mod Billet grille
    It's a magna flow, I don't take it off roaring and I don't think it's the leafs. But i for got to mention that i got a new power steering pump. So maybe it's the belt?
     
  4. Dec 26, 2009 at 8:42 PM
    #4
    dexterdog

    dexterdog My pee parts itch

    Joined:
    Jul 12, 2009
    Member:
    #19571
    Messages:
    4,272
    Gender:
    Male
    Oly WA
    Vehicle:
    2012 F150
    Ding, ding, ding, we have a winner.
     
  5. Dec 26, 2009 at 8:48 PM
    #5
    2004Taco

    2004Taco [OP] Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9556
    Messages:
    527
    Gender:
    Male
    Long Beach,CA
    Vehicle:
    04 PreRunner SR5 Trd
    Magnaflow and Deckplate Mod Billet grille
    hahahah i was just reading yout thread. i did a search. So you think its the belt and not the pulley? i replace the pulley as well. my mechanic told me my belts are good.
     
  6. Dec 26, 2009 at 9:02 PM
    #6
    dexterdog

    dexterdog My pee parts itch

    Joined:
    Jul 12, 2009
    Member:
    #19571
    Messages:
    4,272
    Gender:
    Male
    Oly WA
    Vehicle:
    2012 F150
    Check belt tension. If that's good then check the pump and pulley.
     
  7. Dec 26, 2009 at 9:06 PM
    #7
    2004Taco

    2004Taco [OP] Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9556
    Messages:
    527
    Gender:
    Male
    Long Beach,CA
    Vehicle:
    04 PreRunner SR5 Trd
    Magnaflow and Deckplate Mod Billet grille
    well if its sqealing should i tighten it or loosen it? I'm not a mechanic so idk.
     
  8. Dec 27, 2009 at 6:18 AM
    #8
    dexterdog

    dexterdog My pee parts itch

    Joined:
    Jul 12, 2009
    Member:
    #19571
    Messages:
    4,272
    Gender:
    Male
    Oly WA
    Vehicle:
    2012 F150
    Does it squeal at idle then go away under load. If so, it's probably belt tension and needs to be tightened. Make sure the PS pump is turning without issue and the pulley is secure.
     
  9. Dec 27, 2009 at 10:11 AM
    #9
    2004Taco

    2004Taco [OP] Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9556
    Messages:
    527
    Gender:
    Male
    Long Beach,CA
    Vehicle:
    04 PreRunner SR5 Trd
    Magnaflow and Deckplate Mod Billet grille
    No. Sometimes when I'm driving it doesn't it, more so when I let off the gas
     
  10. Dec 27, 2009 at 3:55 PM
    #10
    2004Taco

    2004Taco [OP] Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9556
    Messages:
    527
    Gender:
    Male
    Long Beach,CA
    Vehicle:
    04 PreRunner SR5 Trd
    Magnaflow and Deckplate Mod Billet grille
    ok so i losen my belt. The sound is still there. my buddies think its an exhaust leak from when i put my new muffler on. Im sceptical about that because it sounds like a squealing noise, but the noise did start when i got the new muffler on.
     
  11. Dec 27, 2009 at 4:01 PM
    #11
    2004Taco

    2004Taco [OP] Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9556
    Messages:
    527
    Gender:
    Male
    Long Beach,CA
    Vehicle:
    04 PreRunner SR5 Trd
    Magnaflow and Deckplate Mod Billet grille
    I posted another thread about this. My truck is making a squealing noise. i thought it was my belts. So, i loosen them to where they should be.
    The noise started when i got my new exhaust on. My buddies think its an exhaust leak.

    Anyone have any clue what it might be?

    The noise is only there when i let off the gas. Im stummped! :goingcrazy:
     
  12. Dec 27, 2009 at 4:04 PM
    #12
    Afwrestler1986

    Afwrestler1986 Well-Known Member

    Joined:
    May 20, 2008
    Member:
    #6768
    Messages:
    3,662
    Gender:
    Male
    First Name:
    Matt
    Johnstown, NY
    Vehicle:
    01 trd 4X4 ex cab manual
    Gray wire, Some lights in the bed area, and some character marks throughout.
    Check the tensioner pulley. It may be seized up.
     
  13. Dec 27, 2009 at 4:05 PM
    #13
    2004Taco

    2004Taco [OP] Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9556
    Messages:
    527
    Gender:
    Male
    Long Beach,CA
    Vehicle:
    04 PreRunner SR5 Trd
    Magnaflow and Deckplate Mod Billet grille
    i had my mechanic cheak all that. he said it doesnt sound like the belts or pulley because it only does it when i drive and then let off the gas.
     
  14. Dec 27, 2009 at 4:13 PM
    #14
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,254
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
    So, it Squealing at idle (sitting still)?
    The first thing that comes to my mind...is the A/C idler pulley/bearing.

    Have you checked that?
     
  15. Dec 27, 2009 at 4:27 PM
    #15
    Janster

    Janster Old & Forgetful

    Joined:
    Mar 25, 2007
    Member:
    #1138
    Messages:
    14,254
    Gender:
    Female
    First Name:
    Jandy
    Lancaster, PA
    Vehicle:
    2016 GMC Canyon SLT w/ LineX and....
    Does the sound correlate with RPM's or SPEED?
     
  16. Dec 27, 2009 at 4:29 PM
    #16
    Afwrestler1986

    Afwrestler1986 Well-Known Member

    Joined:
    May 20, 2008
    Member:
    #6768
    Messages:
    3,662
    Gender:
    Male
    First Name:
    Matt
    Johnstown, NY
    Vehicle:
    01 trd 4X4 ex cab manual
    Gray wire, Some lights in the bed area, and some character marks throughout.
    I posted in your last thread to check the very bottom pulley, or the tensioner pulley for the AC compressor. The bearing can get gummed up and seize. when it seizes the pulley can't move and the belt is rubbing on the pulley. Mine was doing this exact same thing. Loosening and tightening won't make much , if any, difference.
     
  17. Dec 27, 2009 at 4:33 PM
    #17
    Afwrestler1986

    Afwrestler1986 Well-Known Member

    Joined:
    May 20, 2008
    Member:
    #6768
    Messages:
    3,662
    Gender:
    Male
    First Name:
    Matt
    Johnstown, NY
    Vehicle:
    01 trd 4X4 ex cab manual
    Gray wire, Some lights in the bed area, and some character marks throughout.
    That really has no bearing on whether or not it is the belts. Mine could only be heard loudly at 1200 rpm's. But if you listen really close when at highway speed you could barely make out the squeaking. The belt was just rubbung so fast it was less audible.
     
  18. Dec 27, 2009 at 5:01 PM
    #18
    2004Taco

    2004Taco [OP] Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9556
    Messages:
    527
    Gender:
    Male
    Long Beach,CA
    Vehicle:
    04 PreRunner SR5 Trd
    Magnaflow and Deckplate Mod Billet grille
    the sound doesnt make during idel. when i get a good amount of speed and then let off. thats when it starts. i just put some belt dressing just now and drove about the block and it still makes the sound.
     
  19. Dec 27, 2009 at 5:11 PM
    #19
    Afwrestler1986

    Afwrestler1986 Well-Known Member

    Joined:
    May 20, 2008
    Member:
    #6768
    Messages:
    3,662
    Gender:
    Male
    First Name:
    Matt
    Johnstown, NY
    Vehicle:
    01 trd 4X4 ex cab manual
    Gray wire, Some lights in the bed area, and some character marks throughout.
    Belt dressing will do nothing for you if a pulley is seized.
     
  20. Dec 27, 2009 at 5:48 PM
    #20
    2004Taco

    2004Taco [OP] Well-Known Member

    Joined:
    Sep 28, 2008
    Member:
    #9556
    Messages:
    527
    Gender:
    Male
    Long Beach,CA
    Vehicle:
    04 PreRunner SR5 Trd
    Magnaflow and Deckplate Mod Billet grille
    its a new pulley.
     
To Top