1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Trucks acting weird

Discussion in 'Technical Chat' started by th3bigk0, Dec 19, 2010.

  1. Dec 19, 2010 at 5:01 PM
    #1
    th3bigk0

    th3bigk0 [OP] GETTN IT

    Joined:
    Nov 5, 2009
    Member:
    #25512
    Messages:
    1,880
    Gender:
    Male
    First Name:
    Dylan
    Lamecaster
    Vehicle:
    13 TRD Double Cab
    Fox 2.5 RR C/O's,Camburg UCA,Camburg Spindles,KING 2.5,OME Dakar Leafs,285 KM2,XD HOSS 16'',BHLM,HID's,CB,Hornblasters Shocker 540 train horn,KICKER 12 ported....
    its clicking really fast so i thought it was the starter,which was replaced about 7 months ago,then i jumped it and it clicked for a second then started,its the battery huh?
     
  2. Dec 19, 2010 at 5:03 PM
    #2
    crf69

    crf69 scraping my emblems off my plasti-dip

    Joined:
    May 18, 2010
    Member:
    #37348
    Messages:
    3,558
    Gender:
    Male
    First Name:
    Ryan
    Ohio
    Vehicle:
    06 TRD OR BSP cab'n 1/2
    ummm yeah
    i would check your ground from the battery.....if the battery checks out
     
  3. Dec 19, 2010 at 5:10 PM
    #3
    Cr250jumper

    Cr250jumper Señor member

    Joined:
    Dec 2, 2010
    Member:
    #47033
    Messages:
    10,643
    Gender:
    Male
    The moon
    Vehicle:
    50 shades of tan©
    Tacoma with some stuff melted to it
    Def charge the battry first and check/clean connections at the battery terminals. You can even load test the battery to make sure before you buy anything
     
  4. Dec 19, 2010 at 5:20 PM
    #4
    TACOMA TRD

    TACOMA TRD Well-Known Member

    Joined:
    Apr 9, 2010
    Member:
    #34897
    Messages:
    2,207
    Gender:
    Male
    First Name:
    Tom
    PA
    Vehicle:
    2011 MGM SPORT DC 4x4
    Alpine HU, Apline 6.5 3 way Speakers, Access Cover.
    ummm...which truck....RC?
     
  5. Dec 19, 2010 at 5:56 PM
    #5
    th3bigk0

    th3bigk0 [OP] GETTN IT

    Joined:
    Nov 5, 2009
    Member:
    #25512
    Messages:
    1,880
    Gender:
    Male
    First Name:
    Dylan
    Lamecaster
    Vehicle:
    13 TRD Double Cab
    Fox 2.5 RR C/O's,Camburg UCA,Camburg Spindles,KING 2.5,OME Dakar Leafs,285 KM2,XD HOSS 16'',BHLM,HID's,CB,Hornblasters Shocker 540 train horn,KICKER 12 ported....
    haha my rc car just has an on-off switch lol and its brand new
     
  6. Dec 19, 2010 at 6:00 PM
    #6
    Max-4_Yota

    Max-4_Yota The Welfare Cadilac

    Joined:
    Dec 10, 2009
    Member:
    #27357
    Messages:
    4,247
    Gender:
    Male
    First Name:
    Michael
    South Carolina
    Vehicle:
    04 Tacoma 4x4, V6, 5spd
    Squattin'
    Sounds like the battery.
     
  7. Dec 19, 2010 at 6:16 PM
    #7
    th3bigk0

    th3bigk0 [OP] GETTN IT

    Joined:
    Nov 5, 2009
    Member:
    #25512
    Messages:
    1,880
    Gender:
    Male
    First Name:
    Dylan
    Lamecaster
    Vehicle:
    13 TRD Double Cab
    Fox 2.5 RR C/O's,Camburg UCA,Camburg Spindles,KING 2.5,OME Dakar Leafs,285 KM2,XD HOSS 16'',BHLM,HID's,CB,Hornblasters Shocker 540 train horn,KICKER 12 ported....
    ya im thinking the same,its a duralast(i think) may 09,some white corrosion on the terminals,so i think if i clean it up it should be ok
     
  8. Dec 20, 2010 at 12:39 PM
    #8
    Cr250jumper

    Cr250jumper Señor member

    Joined:
    Dec 2, 2010
    Member:
    #47033
    Messages:
    10,643
    Gender:
    Male
    The moon
    Vehicle:
    50 shades of tan©
    Tacoma with some stuff melted to it

    Yes you want to clean the posts often
     
To Top