1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Turbo sound after installing Cold Air Intake. Normal??

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Hiatt1991, Mar 15, 2011.

  1. Mar 15, 2011 at 10:37 PM
    #1
    Hiatt1991

    Hiatt1991 [OP] Well-Known Member

    Joined:
    Aug 19, 2010
    Member:
    #41917
    Messages:
    8,112
    Gender:
    Male
    First Name:
    Hiatt
    Flagstaff, AZ/Walnut, CA
    Vehicle:
    2005 Tacoma Prerunner SR5 TRD offroad
    4" Bodylift 20" Offroad shock spacers Turbo Encabulator
    So I just installed a K&N cai that my buddy gave to me. I double checked all of my connections, tightened everything down and it works great. I went from a dead stop to close to flat out :burnrubber: and while the engine was gaining power, in the higher RPMs I hear a sucking turbo esque noise coming from the airfilter. Is this just the sound of the air being sucked in since it is open? (stock intake is completely closed) or is it something more serious. I never noticed the sound with my stock intake. I also have a flowmaster exhaust, but I havent had any problems with that. Just good sounds:D
     
  2. Mar 15, 2011 at 11:07 PM
    #2
    Hiatt1991

    Hiatt1991 [OP] Well-Known Member

    Joined:
    Aug 19, 2010
    Member:
    #41917
    Messages:
    8,112
    Gender:
    Male
    First Name:
    Hiatt
    Flagstaff, AZ/Walnut, CA
    Vehicle:
    2005 Tacoma Prerunner SR5 TRD offroad
    4" Bodylift 20" Offroad shock spacers Turbo Encabulator
    Thanks just curious.
     
To Top