1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

turn signals not working

Discussion in 'Lighting' started by justin ensor, Jun 5, 2012.

  1. Jun 5, 2012 at 2:10 PM
    #1
    justin ensor

    justin ensor [OP] New Member

    Joined:
    Jun 5, 2012
    Member:
    #80141
    Messages:
    1
    Gender:
    Male
    Vehicle:
    83 tacoma
    I've got a 1983 Tacoma four wheel drive and just recently all the turn signals stopped working so far I've changed all the bulbs checked the fuses, could it be a wiring issue or a bad relay or maybe the turn signal switch?
     
  2. Jun 5, 2012 at 10:27 PM
    #2
    joes06tacoma

    joes06tacoma Well-Known Member

    Joined:
    Jan 1, 2010
    Member:
    #28588
    Messages:
    3,066
    Gender:
    Male
    First Name:
    Joe
    Central Coast, CA
    Vehicle:
    06 4x4 Off Road Access Cab v6 6spd
    LEER Shell with dome lights operated with 3 way switches, aux backup lights with relay and 3 position switch, modified wiring to compass/temp display and clock to include switch that disables dimming function (poor man's DRL solution), Scan Gauge 2
    Could be a lot of things. Do the hazards work? Not familiar with the older trucks, but there might be two flasher relays.....one for the signals, one for the hazards. If that's the case, might try swapping them.
     
To Top