1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

upstream o2 sensor replacement

Discussion in '1st Gen. Tacomas (1995-2004)' started by brent690069, Dec 23, 2011.

  1. Dec 23, 2011 at 9:33 AM
    #1
    brent690069

    brent690069 [OP] old man

    Joined:
    Dec 23, 2011
    Member:
    #69268
    Messages:
    11
    Gender:
    Male
    port angeles, wa.
    Vehicle:
    02 Tacoma 4wd SR5 3.4L
    AFE air intake system, leer canopy
    ive located where both upstream and downstream sensors are...where is the plug end of the upstream sensor located at?
     
  2. Dec 23, 2011 at 10:47 AM
    #2
    Alderleet

    Alderleet Ace of Spades

    Joined:
    Oct 16, 2011
    Member:
    #65324
    Messages:
    1,128
    Gender:
    Male
    First Name:
    Nick
    Salty Hell
    Vehicle:
    '00 Acc Cab TRD 4x4
    follow the cable up. It should only have about 6 inches of cable, unless your is a manual tranny, then its underneath your shifter housing.
     
  3. Dec 24, 2011 at 9:06 AM
    #3
    brent690069

    brent690069 [OP] old man

    Joined:
    Dec 23, 2011
    Member:
    #69268
    Messages:
    11
    Gender:
    Male
    port angeles, wa.
    Vehicle:
    02 Tacoma 4wd SR5 3.4L
    AFE air intake system, leer canopy
    thanks for the info brother....and thanks a million times over for your service to our country!!
     
  4. Dec 24, 2011 at 10:35 AM
    #4
    radcat692000

    radcat692000 Well-Known Member

    Joined:
    Oct 2, 2011
    Member:
    #64531
    Messages:
    188
    Gender:
    Male
    First Name:
    Rob
    Clayton N.C.
    Vehicle:
    95 tacoma 4x4 sr5
    none
    i just replaced mine, and it works best like this....go to the downstream 02 sensor and unplug it (it gives you more slack when you pull the main harness wires looking for the upstrean sensor connector) when you pull the main harness wires you will see the upstream 02 sensor wire tucked away on top of the tranny begin to come out...then its just a matter of unplugging and replugging up the new..
     
  5. Feb 9, 2013 at 11:30 AM
    #5
    simbew

    simbew New Member

    Joined:
    Feb 7, 2013
    Member:
    #96999
    Messages:
    4
    Gender:
    Male
    First Name:
    simon
    Vehicle:
    01 tacoma
    do you get a check engine light when the upstream sensor has gone
     
  6. Feb 10, 2013 at 7:36 AM
    #6
    brent690069

    brent690069 [OP] old man

    Joined:
    Dec 23, 2011
    Member:
    #69268
    Messages:
    11
    Gender:
    Male
    port angeles, wa.
    Vehicle:
    02 Tacoma 4wd SR5 3.4L
    AFE air intake system, leer canopy
    yes it does.
     
  7. Feb 10, 2013 at 12:03 PM
    #7
    tacoma04

    tacoma04 Laissez les bons temps rouler

    Joined:
    Mar 9, 2011
    Member:
    #52717
    Messages:
    499
    Gender:
    Male
    First Name:
    Bruce
    Northern Louisiana
    Vehicle:
    2007 DCSB SR5 4X4
    On my 03 manual, the upstream O2 sensor connection is on top of the gearbox. I had to get to it by removing the console and going through the hole where the shifters are located. It was mounted on a bracket that was bolted to the top in front of the shifter. Had to take that bolt out to pull the connection back to the hole so I could get my hands on the connection.
     
  8. Feb 10, 2013 at 5:47 PM
    #8
    Murph

    Murph ski-doo ride the best screw the rest!

    Joined:
    Apr 23, 2011
    Member:
    #55391
    Messages:
    281
    Gender:
    Male
    Co Springs
    Vehicle:
    2000 Extra Cab TRD O/R
    3" lift. American racing 15'' rims. 33x12.50 BFG A/T tires. tool box. ARB bumper, mile marker winch, kc highlights. No carpet inside sprayed with bed liner. Kicker door speakers. Alpine head unit.
    This! I did mine this way on Friday :D.
     
To Top