1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

URD MAF Calibrator Problem

Discussion in 'Technical Chat' started by mpleitez, Apr 7, 2009.

  1. Apr 7, 2009 at 9:33 PM
    #1
    mpleitez

    mpleitez [OP] Well-Known Member

    Joined:
    Apr 7, 2009
    Member:
    #15698
    Messages:
    449
    Gender:
    Male
    valencia
    Vehicle:
    08 tacoma 4x4
    ARB locked front and rear URD MAF Calibrator 3 in. lift Icon coil overs front Icon rear add a leafs airbags AFE stage2 si cold air intake DT Headers 02 sensor URD y-Pipe URD turbo Muffler
    Seems my URD MAF calibrator isn't working correctly. I was driving my truck the other day a bit fast thru some dips noticed my check engine light came on and I lost top end power. I think some wires came loose however next day check engine light disappeared but i still don't feel that extra boost in my top end anyone know of any good tune shops for this mod I want my power back!!!!
     
  2. Apr 8, 2009 at 10:45 AM
    #2
    Gadget@URD

    Gadget@URD Well-Known Member Vendor

    Joined:
    Sep 12, 2008
    Member:
    #9183
    Messages:
    663
    Southern Maryland USA
    Vehicle:
    URD Supercharged XRunner
    Give me a call in URD Tech Support 877-887-3872 x3

    Gadget
     
To Top