1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

URD O2 Sensor help

Discussion in 'Performance and Tuning' started by cookee62, May 30, 2013.

  1. May 30, 2013 at 8:14 PM
    #1
    cookee62

    cookee62 [OP] Well-Known Member

    Joined:
    Apr 11, 2011
    Member:
    #54723
    Messages:
    146
    Gender:
    Male
    Lake Mary, FL
    Vehicle:
    06 DBL Cab
    URD SS, URD Y-Pipe, DTLT Headers, 3" URD Cat Back, Fox 2.5 CO, TC UCA, Fox Rear Resi, SS brake Lines, All pro 1.5" leafs, Halo Projector Headlights, WE Bead-lock Rims, 33 BFG AT, No Sway Bar
    so Have any of you had this problem? I have DTLT headers and with that a URD o2 sensor and I keep getting a check engine light code PO154 low voltage so I changed the o2 senor and put a new one in but still same code? I'm thinking the URD o2 has shorted out. Any one have a problem like this? Is it covered by URD? Ive left Gadget a voicemail but didnt hear back but I'd figure I'd ask on here before I call again

    Thanks,
     
  2. May 31, 2013 at 11:19 AM
    #2
    Gadget@URD

    Gadget@URD Well-Known Member Vendor

    Joined:
    Sep 12, 2008
    Member:
    #9183
    Messages:
    638
    Southern Maryland USA
    Vehicle:
    URD Supercharged XRunner
    Not sure if we have spoken or not, but you can email Tech Support at Support@URDUSA.com or call 877-8URDUSA x3

    Gadget
     
To Top