1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

USA Spec PA20TOY issue

Discussion in 'Audio & Video' started by thebigk, Dec 15, 2010.

  1. Dec 15, 2010 at 10:07 AM
    #1
    thebigk

    thebigk [OP] 6 Double 5 3 2 1

    Joined:
    Aug 25, 2008
    Member:
    #8770
    Messages:
    3,330
    Gender:
    Male
    First Name:
    Ken....
    Odessa, TX
    My USA Spec PA20TOY has worked fine since I installed it last year. Just the other day it stopped charging my IPOD Touch. I contacted their tech support and they said one of the 2 fuses is blown......either in the cable or in the controller itself. I could send it in and have it replaced but I have to have my proof of purchase. I cannot even remember where I bought it from.

    Has anyone had this issue and replaced the fuse on their own?

    If not I'll contact and see how much it will cost to fix it out of warranty.
     
  2. Dec 15, 2010 at 10:10 AM
    #2
    Pugga

    Pugga Pasti-Dip Free 1983 - 2015... It was a good run

    Joined:
    Jun 18, 2010
    Member:
    #39131
    Messages:
    30,822
    Gender:
    Male
    First Name:
    Mike
    Massachusetts
    Vehicle:
    '13 Ford F-150 SCREW
    F-150 Mod
    Damn, that sucks! I've had mine for almost 3 years now, no issues at all. Maybe they could just send you the fuses?
     
To Top