1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

V-LED Customer service AMAZING!

Discussion in '2nd Gen. Tacomas (2005-2015)' started by reiss91, Apr 19, 2011.

  1. Apr 19, 2011 at 3:51 PM
    #1
    reiss91

    reiss91 [OP] Well-Known Member

    Joined:
    Mar 10, 2011
    Member:
    #52767
    Messages:
    75
    Gender:
    Male
    First Name:
    Mark
    Mass
    Vehicle:
    2011 Tacoma Gray
    I had another thread where I installed the switch back bulbs in my 2011 Tacoma but one of them was flashing amber-white-amber instead of amber-amber when the voltage of the system exceeded 12.5. But the bulbs are rated at 14.5 and only one of them had the problem.

    I cant switch back to regular bulbs cause the load resistors are soldered in. I emailed James at V-LED and explained to him the problem. TWO new LEDS on the way! bought these over a year ago and they are still replacing them. BY FAR the BEST customer service i've experienced in a while. I would recommend them to everyone.

    Thanks V-LED!

    Also the truck looks damn good with these installed.

    IMG_1075.jpg
    IMG_1073.jpg
     
  2. Apr 19, 2011 at 4:04 PM
    #2
    wildjerseyfirefighter

    wildjerseyfirefighter I sell fishing and fishing accessories

    Joined:
    Dec 17, 2008
    Member:
    #11677
    Messages:
    7,958
    Gender:
    Male
    First Name:
    Joe
    NJ
    Vehicle:
    05 Tacoma TRD Sport
    stock, for now
    good to know..Im intrested in ordering led's from them. I just cant justity spending $70 for two led bulbs
    ..lol
     
To Top