1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

very loud squeak

Discussion in '2nd Gen. Tacomas (2005-2015)' started by THXEY, Mar 5, 2009.

  1. Mar 5, 2009 at 6:35 PM
    #1
    THXEY

    THXEY [OP] Panda Jerk

    Joined:
    Dec 15, 2008
    Member:
    #11614
    Messages:
    12,739
    Gender:
    Male
    First Name:
    Jacob
    San Diego
    Vehicle:
    2013 Subaru WRX
    STi Short Shifter.OEM floor illumination kit. Rally Armor Mud Flaps. BC BR Coilovers. Invidia N1 Exhaust
    so whenever my truck like "goes down" there is a prett loud squeak noise that has gotten increasingli louder.. i dont know exactly where its coming from i just know its from the rear. i have a stock trd off road. Can anyone help me out?

    oh and i do go off roading
     
  2. Mar 5, 2009 at 6:36 PM
    #2
    DanGer

    DanGer Avatar approved by 98tacomav6

    Joined:
    Jun 7, 2008
    Member:
    #7155
    Messages:
    5,494
    Gender:
    Male
    Northern Virginia & Blacksburg
    Vehicle:
    07 Base 4Cyl 4x4 Manual
    White Head Light mod, White shorty antennae, Doug Thorley Long Tube headers, AFE Drop in air filter, Secondary Air Filter Removed,
    Something in the suspension. fasn8dave is in the same boat as you
     
  3. Mar 5, 2009 at 6:38 PM
    #3
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,149
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Probabl;y from your last trip to the mud. Take it to a car wash and spray the shit out of the springs.
     
  4. Mar 5, 2009 at 6:48 PM
    #4
    chabro

    chabro Well-Known Member

    Joined:
    Jan 10, 2009
    Member:
    #12449
    Messages:
    88
    Gender:
    Male
    Houston
    Vehicle:
    2011 SR5 4x4 DC
    After you clean all the mud, grease your universal joints real well. Mine made a squeaking noise for years which progressively got worse. Greased the u-joints and all gone. Don't just take it somewhere and ask them to do it. They won't do a complete job. Crawl under and do it yourself to be sure. Try spraying some silicon in your leaf spring hangers bolts too.
     
  5. Mar 5, 2009 at 6:52 PM
    #5
    fasn8dave

    fasn8dave Hey guys watch THIS!

    Joined:
    Sep 25, 2008
    Member:
    #9462
    Messages:
    335
    Gender:
    Male
    Lewisville, NC
    Vehicle:
    06 DC 4x4
    3" Suspension Lift Custom Wheels 265 / 75 / 16 Nitto Terra Grappler Tires (32") Hard Bed Cover Front Bull Bar / Skid Plate Tinted Glass Header Mount GPS Billet Grille
    hmmmm I like this - time to break out the grease. My UCA's also squeak like MAD, just as dgerm said...

    I drove my truck through some pretty deep muddy water several times. I'm going to give this a try....

    Thanks for posting this up!
     
  6. Mar 5, 2009 at 7:06 PM
    #6
    surfsupl

    surfsupl Well-Known Member

    Joined:
    Jan 8, 2008
    Member:
    #4161
    Messages:
    8,572
    Gender:
    Male
    First Name:
    Gregg
    WestCoast
    Vehicle:
    I DONT CARE IF IT'S A RE-POST
    Rear Diff Breather~ 5100's ~Fog Light Anytime~Tint~TRD Seat Covers~Weather Tech's~Pioneer H.U.~Lift~Eibach Springs~LED's......blah...blah...blah
    What he said and the other guy said! :D ^^^^^^^^^^^^^^^
     
  7. Mar 5, 2009 at 7:08 PM
    #7
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Moderator

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    106,149
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    What kind of UCA's???
     
  8. Mar 5, 2009 at 7:24 PM
    #8
    derekabraham

    derekabraham Living vicariously through everybody

    Joined:
    Jul 8, 2008
    Member:
    #7822
    Messages:
    29,052
    Gender:
    Male
    First Name:
    TW'S Hippy Liberal
    Portland, OR
    Vehicle:
    2002 4x4 4Runner
    Stick on hood scoop from Autozone.
    It's the leaf springs most likely. Give them a good cleaning.


    It happened at Ocotillo. I guarantee it. :p
     
  9. Mar 6, 2009 at 6:12 PM
    #9
    THXEY

    THXEY [OP] Panda Jerk

    Joined:
    Dec 15, 2008
    Member:
    #11614
    Messages:
    12,739
    Gender:
    Male
    First Name:
    Jacob
    San Diego
    Vehicle:
    2013 Subaru WRX
    STi Short Shifter.OEM floor illumination kit. Rally Armor Mud Flaps. BC BR Coilovers. Invidia N1 Exhaust
    no it started right after i went to ramona. i got my truck like completley brown from that trip so its probly from that:eek:
     
  10. Mar 6, 2009 at 6:17 PM
    #10
    dunkhi

    dunkhi CSULB socal

    Joined:
    Jan 5, 2009
    Member:
    #12257
    Messages:
    1,173
    Gender:
    Male
    First Name:
    Craig Sirois
    Southern California. Fountain Valley
    Vehicle:
    09 Ivan Stewart
    Toytec Coilover kit. Bilstein's 5100. Alcoa Wheels. General Tires. Magnaflow Cat-back. BLHM. Yellow fogs. 13TW5 jl sub. Stewart Decals.
    ya its definitely ur leaf springs pressure wash them then wd-40 them just incase it rusted
     
  11. Mar 6, 2009 at 9:05 PM
    #11
    derekabraham

    derekabraham Living vicariously through everybody

    Joined:
    Jul 8, 2008
    Member:
    #7822
    Messages:
    29,052
    Gender:
    Male
    First Name:
    TW'S Hippy Liberal
    Portland, OR
    Vehicle:
    2002 4x4 4Runner
    Stick on hood scoop from Autozone.



    That's possible, too. :D
     
To Top