1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

WalMart broke my TPMS

Discussion in 'Wheels & Tires' started by Dianna, Jun 1, 2010.

  1. Jun 1, 2010 at 7:20 PM
    #1
    Dianna

    Dianna [OP] Well-Known Member

    Joined:
    May 28, 2010
    Member:
    #37965
    Messages:
    67
    Gender:
    Female
    First Name:
    Dianna
    Ohio
    Vehicle:
    06 Sport
    I bought some of the original Revo's a while back and just took the truck to WalMart to have them installed, didn't think they could mess anything up installing tires. They broke the valve on the TPMS on one of the wheels and put a new TPMS on. I told them they had to program it and then they tell me they don't have the scanner. I'm beginning to wonder now if the TPMS they put on is even compatible with my truck. I'm glad I told them I wanted the box (I knew I needed the serial number). What do you suggest I do now? Take it to Toyota and have another TPMS installed and programmed and give WalMart the bill? Can you have one TPMS with a different serial number than the other 4?
     
  2. Jun 1, 2010 at 7:23 PM
    #2
    Brunes

    Brunes abides. Staff Member

    Joined:
    May 31, 2008
    Member:
    #7011
    Messages:
    17,730
    Gender:
    Male
    First Name:
    Rotorhead
    Big Easy, USA
    Vehicle:
    08 Red/Graphite and Satin Black
    Inside: Tint, Wet Okole 1/2 Piped Red/Black Covers, Black Weathertech Digital Fit Mats, URD Short Throw w/ TWM Weighted Knob, USA Spec iPod adapter. Outside: 4300K Retro w/ Angel Eyes and Red Shrouds, 5000K Blazer Fog Light Retrofit, Debadge, Bed Locking Handle, Satin Black Rims Performance: TRD/Steigmeier Blower w/ 2.7 Pulley. 668 Injectors and 320 LPH AEM Fuel pump. URD UCON and 7th Injector. DTLT Headers, URD Y-Pipe, Wicked Flow Muffler. Suspension: Both: OME Shocks Front: 886X's and TC UCAs Rear: Dakars Armor: Relentless Front Bumper Relentless High Clearance Rear w/ Tire/Rotopax Swing Out Relentless Front, Mid, and TCase skids BAMF Diff Skid Recovery and Spares: Fullsize Spare Tire 2x2 gal Rotopax 1x1 gal Rotopax 1x1 gal Water Rotopax Warn 9.5XP-S Winch Hi-Lift Extreme 60" Ironman Off-Road Recovery Kit Upcoming: ATO Gas Tank Skid and Sliders w/ kickout. ATO Shackle Flip Kit. Down the line: Front/Rear ARB Lockers w/ OBA. 4.56 Gears
    I think you can have different serials than the other sensors. Toyota should be able to reset it....and Walmart should pay for it.
     
  3. Jun 1, 2010 at 7:32 PM
    #3
    tacomakid96

    tacomakid96 Can you skin Grizz, pilgram?

    Joined:
    Jan 27, 2010
    Member:
    #30175
    Messages:
    3,507
    Gender:
    Male
    First Name:
    Phil
    Out n' about
    Vehicle:
    05 Tacoma
    Airbags, Projectors, Bilsteins front and rear, FM 50 series, Leer canopy, 265/75/16 Duratrac's...
    x2 make sure they pick up the tab, they broke it they pay for it.
     
  4. Jun 1, 2010 at 8:06 PM
    #4
    HondaGM

    HondaGM Roll Tide

    Joined:
    Oct 28, 2009
    Member:
    #25056
    Messages:
    5,774
    Gender:
    Male
    First Name:
    James
    South-Pole
    Vehicle:
    09 DC 4x4 Blown Honda VTEC V8
    trd exhaust,step bars,vent visors,bed lights,tailgate mod
    take to the dealer and have your TPMS initialized.
     
  5. Jun 1, 2010 at 8:15 PM
    #5
    Dianna

    Dianna [OP] Well-Known Member

    Joined:
    May 28, 2010
    Member:
    #37965
    Messages:
    67
    Gender:
    Female
    First Name:
    Dianna
    Ohio
    Vehicle:
    06 Sport
    I just went out and got the TPMS box out of the truck, Schrader AirAware 28380 and at least I know they put in the correct one. There isn't any kind of serial number on the box though, will Toyota have to take the tire back off the rim?
     
  6. Jun 2, 2010 at 3:23 AM
    #6
    alteredillusions

    alteredillusions Well-Known Member

    Joined:
    Oct 26, 2009
    Member:
    #24949
    Messages:
    101
    Gender:
    Male
    Wichita KS
    Vehicle:
    SR5 2.7 manual
    When I had my new tires installed had the same thing happen. Toyota charged $110 to reset. The shop that did finally paid for it after a week of bitching at them.
     
  7. Jun 2, 2010 at 8:27 AM
    #7
    numbah57

    numbah57 BORN AND RAISED MAUI BOY

    Joined:
    Oct 11, 2009
    Member:
    #24160
    Messages:
    2,939
    Gender:
    Male
    First Name:
    kahai
    Wailuku, Maui, Hawaii
    Vehicle:
    09 tacoma 2.7 timberland mica
    5% tint, camo wet okoles, AFE intake, shortie antenna, black front emblem/debaged, Morimoto FXR retro in blacked out stock housing, URD short shifter,no sway-bar, Ultra Guage, Camburg 2.5 coilovers and 1.25 uniball UCA, 4.88 gears, ARB front and rear, 255/85-16 KM2.
    I hate LOLmart, the auto department that is.
     
  8. Jun 2, 2010 at 8:33 AM
    #8
    crf69

    crf69 scraping my emblems off my plasti-dip

    Joined:
    May 18, 2010
    Member:
    #37348
    Messages:
    3,575
    Gender:
    Male
    First Name:
    Ryan
    Ohio
    Vehicle:
    06 TRD OR BSP cab'n 1/2
    ummm yeah
    ha! everytime i walk by it people are screaming hahah!
     
  9. Jun 2, 2010 at 8:34 AM
    #9
    HBMurphy

    HBMurphy Ban Pending

    Joined:
    Jun 27, 2009
    Member:
    #18993
    Messages:
    5,745
    Gender:
    Male
    First Name:
    Paul
    So California Coast
    Vehicle:
    09 Off Road
    None
    It depends what you were wearing when you went there. :)
     
  10. Jun 2, 2010 at 8:35 AM
    #10
    Zombie Runner

    Zombie Runner Are these black helicopters for me?

    Joined:
    Mar 13, 2008
    Member:
    #5246
    Messages:
    15,078
    Gender:
    Male
    First Name:
    Kevin
    Wichita Falls, TX
    Vehicle:
    Tundra, double cab.
    LED interior lights, stubby antenna, Pioneer in dash screen, good driver mod.
    I hate seeing people taking their cars to wal mart for service. Sorry this happend to you and good luck.
     
  11. Jun 2, 2010 at 8:36 AM
    #11
    RYNO

    RYNO Well-Known Member

    Joined:
    May 31, 2010
    Member:
    #38117
    Messages:
    85
    Gender:
    Male
    reason # 1,425 why I hate wal-mart, lol.
     
  12. Jun 2, 2010 at 2:41 PM
    #12
    Silver06Taco

    Silver06Taco Well-Known Member

    Joined:
    Aug 20, 2009
    Member:
    #21472
    Messages:
    174
    Gender:
    Male
    WA state
    Vehicle:
    Silver 06 DC TRD Sport
    It's $94.75 for an hour of labor time here in the Northwest. I've called four different Toyota dealers in the last 2 days.
     
  13. Jun 2, 2010 at 3:19 PM
    #13
    el_smurfo

    el_smurfo Well-Known Member

    Joined:
    Oct 22, 2007
    Member:
    #3179
    Messages:
    85
    Nearly every tire place I've been has a big disclaimer on the wall that they aren't liable for broken TPMS. Walmart is likely legally able to avoid paying for this...
     
  14. Jun 2, 2010 at 6:59 PM
    #14
    Dianna

    Dianna [OP] Well-Known Member

    Joined:
    May 28, 2010
    Member:
    #37965
    Messages:
    67
    Gender:
    Female
    First Name:
    Dianna
    Ohio
    Vehicle:
    06 Sport
    Went back to WalMart this morning and spoke to the manager of automotive and was pleasantly surprised. Apparently there have been many issues with the night crew and last night they left their display tires outside and some were stolen.
    I also didn't mention in my post that they scratched my alloy rim, nothing major but these were less than 6 months old and they scratched the clear coat off all the way around.
    Anyway manager told me to go to Toyota, buy a rim, get my TPMS programmed and bring them the bill that they would pay for it. Props to Walmart for stepping up.
     
  15. Jun 2, 2010 at 7:16 PM
    #15
    LostRebel

    LostRebel Well-Known Member

    Joined:
    Mar 31, 2009
    Member:
    #15389
    Messages:
    359
    Gender:
    Male
    Almost Canada, USA
    Vehicle:
    Black Access Cab 4x4 TRD Off Road
    Fisher plow, BakFlip and Snugtop cap, Demello Sliders, Scanguage,
    The sensors that came in my 09 are Pacific. Are you sure the Walmart supplied Schrader sensor is correct for your wheel? As far as the serial numbers: each sensor has a different serial (ID) number that is programmed individually into the Tire Pressure Warning ecu. A replacement sensor of the correct type should be no problem to program into your truck.
     
  16. Jun 2, 2010 at 7:18 PM
    #16
    rick

    rick `

    Joined:
    Mar 1, 2007
    Member:
    #993
    Messages:
    2,476
    Gender:
    Male
    welcome to tacomaworld Dianna
     
  17. Jun 2, 2010 at 7:21 PM
    #17
    SC4333

    SC4333 Well-Known Member

    Joined:
    Dec 9, 2008
    Member:
    #11412
    Messages:
    2,189
    Gender:
    Male
    First Name:
    Grant
    San Antonio, TX
    Vehicle:
    '08 PreRunner SR5
    SOLD!
    Join the crowd. Someone 'mechanic' ruined two of mine during a tire change once upon a time.
     
  18. Jun 2, 2010 at 11:18 PM
    #18
    Dianna

    Dianna [OP] Well-Known Member

    Joined:
    May 28, 2010
    Member:
    #37965
    Messages:
    67
    Gender:
    Female
    First Name:
    Dianna
    Ohio
    Vehicle:
    06 Sport
    Thanks Rick :D Been a stalker way too long!
     
  19. Jun 3, 2010 at 6:06 AM
    #19
    Boomtacoma01

    Boomtacoma01 Well-Known Member

    Joined:
    Dec 7, 2009
    Member:
    #27162
    Messages:
    868
    Gender:
    Male
    First Name:
    Chris
    Houston
    Vehicle:
    09 BSP SR5 DC 4x4
    285/70/17 Dynapro MTs, Shrockworks front bumper, Armortech rear bumper
    The TPMS is a joke on these trucks anyways..I have had mine removed and disabled the light in the dash on my 09.

    AS posted earlier at least WalMart stepped up.

    Oh and welcome to TW!
     
  20. Jun 7, 2010 at 6:20 PM
    #20
    skytower

    skytower Well-Known Member

    Joined:
    Jun 7, 2010
    Member:
    #38505
    Messages:
    3,221
    Gender:
    Male
    First Name:
    Dave
    virginia
    Vehicle:
    08 Tacoma 4x4
    Hitch and wiring, aux back-up light, rear strobe lights, radio and underseat sub.
    If, during a crash investigation, it is discovered you have removed a safety device, your insurance company will not pay. You will also be liable in a civil suit.
     
To Top