1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Weathertech holes / no holes issue

Discussion in 'Product Reviews' started by crawl, Sep 28, 2009.

  1. Sep 28, 2009 at 4:00 PM
    #1
    crawl

    crawl [OP] Well-Known Member

    Joined:
    Sep 3, 2009
    Member:
    #22246
    Messages:
    249
    Gender:
    Male
    First Name:
    Greg
    Valencia, CA
    Vehicle:
    2010 reg cab 4x4 sr5
    I ordered my front passenger side WITHOUT holes, assuming they are identical molds, just one with and the other without holes. According to Weathertech, they are in fact different molds :confused:

    [​IMG]

    [​IMG]

    Go figure. Sounds crazy to me, but proof will be when I receive my new set with pass holes for the retainer clips. I'll update with pics of the new set when they arrive.

    Btw, removing the retainer clips was a PITA!
     
  2. Sep 28, 2009 at 4:17 PM
    #2
    Stillfly199

    Stillfly199 ( . )( . )

    Joined:
    Feb 26, 2009
    Member:
    #14098
    Messages:
    5,004
    Gender:
    Male
    First Name:
    J.D.
    Bro Capital of the word
    Vehicle:
    2010 FJ Cruiser
    If they are for a Tacoma they should have been the same mold whether or not they have holes. Did you order for the correct year?
     
  3. Sep 28, 2009 at 4:51 PM
    #3
    crawl

    crawl [OP] Well-Known Member

    Joined:
    Sep 3, 2009
    Member:
    #22246
    Messages:
    249
    Gender:
    Male
    First Name:
    Greg
    Valencia, CA
    Vehicle:
    2010 reg cab 4x4 sr5
    I argued with the Weathertech rep for about 15 minutes regarding your exact point. I told her... maybe you sent me the wrong year, wrong model (non RC), or maybe the mold was just poop! Nothing got through. She INSISTED that my 2010 Toy. Tacoma has 2 diff. floor plans...one with holes and one without. She said she had the diagram in front of her and that they were different. I conceded my arguement and ordered a new set with pass holes :(
     
  4. Sep 28, 2009 at 5:03 PM
    #4
    Stillfly199

    Stillfly199 ( . )( . )

    Joined:
    Feb 26, 2009
    Member:
    #14098
    Messages:
    5,004
    Gender:
    Male
    First Name:
    J.D.
    Bro Capital of the word
    Vehicle:
    2010 FJ Cruiser
    Did they let you return them? Or was this all on you? I dont think my 07 has pass holes so maybe the 2010's have two different plans :confused: but I dont know. I would have thought they would be the same, aside from two holes
     
  5. Sep 28, 2009 at 5:03 PM
    #5
    Stillfly199

    Stillfly199 ( . )( . )

    Joined:
    Feb 26, 2009
    Member:
    #14098
    Messages:
    5,004
    Gender:
    Male
    First Name:
    J.D.
    Bro Capital of the word
    Vehicle:
    2010 FJ Cruiser
    Also, how did the drivers line up?
     
  6. Sep 28, 2009 at 5:43 PM
    #6
    crawl

    crawl [OP] Well-Known Member

    Joined:
    Sep 3, 2009
    Member:
    #22246
    Messages:
    249
    Gender:
    Male
    First Name:
    Greg
    Valencia, CA
    Vehicle:
    2010 reg cab 4x4 sr5
    yes, they are taking it back and sending me a call tag (free shipping). the rep was actually very kool at the end, after we argued.
     
  7. Sep 28, 2009 at 5:44 PM
    #7
    crawl

    crawl [OP] Well-Known Member

    Joined:
    Sep 3, 2009
    Member:
    #22246
    Messages:
    249
    Gender:
    Male
    First Name:
    Greg
    Valencia, CA
    Vehicle:
    2010 reg cab 4x4 sr5
    perfect.
     
  8. Sep 28, 2009 at 6:27 PM
    #8
    Simon's Mom

    Simon's Mom Wag More Bark Less

    Joined:
    Apr 12, 2007
    Member:
    #1297
    Messages:
    9,324
    Gender:
    Female
    First Name:
    Judy or Jude :)
    SBurl Vermont
    Vehicle:
    13 TRD OR DC MGM
    Stock for now
    I remember reading other model years had trouble with molds on the drivers side, but don't remember what year. :confused:
    Maybe something has changed now on the passenger side now, sorry to hear this but good you are reporting it for others in case of problems.
     
  9. Sep 28, 2009 at 7:14 PM
    #9
    crawl

    crawl [OP] Well-Known Member

    Joined:
    Sep 3, 2009
    Member:
    #22246
    Messages:
    249
    Gender:
    Male
    First Name:
    Greg
    Valencia, CA
    Vehicle:
    2010 reg cab 4x4 sr5
    yeah, I remember reading about some fitment issues in the past but I was hoping they worked that all out by now. Oh well.

    I still say it has nothing to do with the Toyota using a completely different floor plan for retaining clips vs. no clips. I think they just sent me the wrong part.
     
  10. Sep 28, 2009 at 7:23 PM
    #10
    Stillfly199

    Stillfly199 ( . )( . )

    Joined:
    Feb 26, 2009
    Member:
    #14098
    Messages:
    5,004
    Gender:
    Male
    First Name:
    J.D.
    Bro Capital of the word
    Vehicle:
    2010 FJ Cruiser
    Well at least they are taking care of you, thats good. I have been wanting to get some but have been procrastinating
     
  11. Sep 28, 2009 at 7:50 PM
    #11
    crawl

    crawl [OP] Well-Known Member

    Joined:
    Sep 3, 2009
    Member:
    #22246
    Messages:
    249
    Gender:
    Male
    First Name:
    Greg
    Valencia, CA
    Vehicle:
    2010 reg cab 4x4 sr5
    Yes they are being very cooperative and taking care of me. I'm actually glad I made the purchase directly thru them rather than a distributor. This would have taken much longer to resolve.
     
  12. Sep 28, 2009 at 7:56 PM
    #12
    wcm608

    wcm608 Well-Known Member

    Joined:
    May 2, 2008
    Member:
    #6348
    Messages:
    102
    Gender:
    Male
    Pittsburgh, Pa
    Vehicle:
    08 DC LB 4x4 SR5 Impulse Red
    I removed those carpet retainers simply by pulling them up. I bought a used
    pair of weathertechs (without holes) and they fit perfect.
     
  13. Sep 28, 2009 at 9:57 PM
    #13
    crawl

    crawl [OP] Well-Known Member

    Joined:
    Sep 3, 2009
    Member:
    #22246
    Messages:
    249
    Gender:
    Male
    First Name:
    Greg
    Valencia, CA
    Vehicle:
    2010 reg cab 4x4 sr5
    when/if you get a chance, I'd really like to know the part number on the back of the pass. matt. I want at least one without the holes, but WT says it wont fit.

    and my retainers would not just pull out. I had to pinch the hooks together from under the carpet and pull up. they must have made hooks more robust after 08?

    [edit.. wcm608, you were right about the retainers coming out easy. My drivers side popped right out by simply pulling them up while shoving in a flat head screwdriver to help release the hooks.]
     
  14. Sep 28, 2009 at 11:36 PM
    #14
    09tacoLI

    09tacoLI Well-Known Member

    Joined:
    Nov 16, 2008
    Member:
    #10817
    Messages:
    739
    Gender:
    Male
    long island ny
    Vehicle:
    09 off road
    Shrockworks sliders,Shrockworks Front bumper,Warn 9.5xp winch,Toytec Ult.3in,Total Chaos UCAs,AP expo Rear, Fox remote resi shocks Bud built skids,Piaa 7in,Piaa yellow plasma Off road lights.
    Thats wierd cus I just got mine this week and the passenger side didnt come with holes and I ordered them with holes. But mine fit perfect.
     
  15. Sep 29, 2009 at 3:17 PM
    #15
    crawl

    crawl [OP] Well-Known Member

    Joined:
    Sep 3, 2009
    Member:
    #22246
    Messages:
    249
    Gender:
    Male
    First Name:
    Greg
    Valencia, CA
    Vehicle:
    2010 reg cab 4x4 sr5
    The weird part is what WT is claiming. I say, holes or no holes...it should fit the same, period. Would you mind looking under the mat for the part number?
     
  16. Oct 7, 2009 at 11:12 AM
    #16
    jassco

    jassco Well-Known Member

    Joined:
    Aug 3, 2009
    Member:
    #20568
    Messages:
    558
    Gender:
    Male
    Boston
    Vehicle:
    2010 Access Cab 2.7L SR5 5spd, 4x4
    5100 set to .85 w/ rear TSB, 2012 Rear-view Mirror, Grillecraft, Team Trails FJ Wheels, TPMS canister, Rear headrest delete, Rear console delete, Valley Hitch, Frame undercoat, $2.99 Tailgate hose clamp lock, Avid light bar, 4x4 lighted switch ala Biceman.
    I recently purchased for my 2010 AC and got ones with 2 mat hooks. I wouldn't suspect it but my passenger mat does look different then the those. Mine seems to cover more over the sill then his by a little and fits perfectly. I think maybe you need to order the ones with hooks and plug them with silicone if you are that worried. I agree it shouldn't matter but it seems to....

    On another note: The hooks cover the holes well when installed and only a few sand flakes made it through after 3 weeks. I used some scotch guard on the carpet under them but I wouldn't worry about leaks. The mat holes are raised from the base of the mat so any fluids would have to either directly enter the hole or fill up over the line to cause issues. you could also probably seal the holes let it set up and still get the hooks through them to hold the mats.
     
  17. Oct 9, 2009 at 10:25 PM
    #17
    crawl

    crawl [OP] Well-Known Member

    Joined:
    Sep 3, 2009
    Member:
    #22246
    Messages:
    249
    Gender:
    Male
    First Name:
    Greg
    Valencia, CA
    Vehicle:
    2010 reg cab 4x4 sr5
    exactly. my new pass. mat just arrived and its as you described. I think when you specify no holes for the pass. side, you get an older year taco mat because thats whats in their system for no holes. I tried to explain this to the WT rep, but she wouldn't listen.
     
  18. Oct 25, 2009 at 9:58 PM
    #18
    bigrock22

    bigrock22 New Member

    Joined:
    Sep 17, 2009
    Member:
    #22902
    Messages:
    3
    Gender:
    Male
    First Name:
    Scott
    Winnipeg
    Vehicle:
    2009 Tacoma Sport leather
    no mods, got it a few days ago
    I'm thinking about getting WT mats for my new Tacoma... is everyone happy with theirs?? do they work great?? or not so much...
     
  19. Oct 26, 2009 at 8:29 PM
    #19
    crawl

    crawl [OP] Well-Known Member

    Joined:
    Sep 3, 2009
    Member:
    #22246
    Messages:
    249
    Gender:
    Male
    First Name:
    Greg
    Valencia, CA
    Vehicle:
    2010 reg cab 4x4 sr5
    I had a few issues and now question their quality controll.
     
  20. Oct 26, 2009 at 8:32 PM
    #20
    bigrock22

    bigrock22 New Member

    Joined:
    Sep 17, 2009
    Member:
    #22902
    Messages:
    3
    Gender:
    Male
    First Name:
    Scott
    Winnipeg
    Vehicle:
    2009 Tacoma Sport leather
    no mods, got it a few days ago
    what sort of problems did you encounter??
     
To Top