1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Weird rattle from undercarriage

Discussion in '2nd Gen. Tacomas' started by luco1029, May 12, 2011.

  1. May 12, 2011 at 6:37 PM
    #1
    luco1029

    luco1029 [OP] Well-Known Member

    Joined:
    Oct 8, 2009
    Member:
    #23987
    Messages:
    609
    Gender:
    Male
    First Name:
    Lucas
    Wilkes, NC
    Vehicle:
    09 SR5 DCSB 4x4 Timberland Mica
    Straight Pipe, Readylift 3" Spacer, 17x9 Matte Black XD Revolvers, 285/70/17 Cooper Discoverer AT3, Plastidipped emblems, Pioneer Double Din, OEM Roof Rack, N-Fab Side Steps
    Here lately, probably about the last month or two, ive noticed a weird rattling noise coming from the undercarriage of my taco. It seems to happen if i press the gas lightly and it sounds like its coming from my muffler. I have an aftermarket Thrush Cherry Bomb Glasspack on it and was wondering if anyone has heard this rattling from their taco or if it could be something with the welding on my muffler?
     
  2. Jul 14, 2011 at 6:27 PM
    #2
    BarkSlayer

    BarkSlayer Well-Known Member

    Joined:
    Aug 30, 2010
    Member:
    #42472
    Messages:
    73
    Gender:
    Male
    First Name:
    Jim
    Northwest Ohio
    Vehicle:
    Silver SR5 with 2.7 liter 5-speed stick
    Bed-Buddy motorcycle tie-down bar installed in headwall.
    At 73K miles on my 2007, I just developed a rattle coming from the muffler (stock, 2.7 liter four banger) and I'm thinking a baffle weld let go on the inside of the can. Anyone else?
     
  3. Jul 15, 2011 at 7:13 AM
    #3
    Gengle07

    Gengle07 Active Member

    Joined:
    Jun 15, 2011
    Member:
    #58318
    Messages:
    26
    Gender:
    Male
    Charleston, SC
    Vehicle:
    08 TRD Off-Road Rugged Trail 4x4
    Avid Offroad Light Bar OEM Roof Rack ARE Z-Series Shell
    I also have a strange rattle or creaking coming from my 07 Prerunner with 65k at slow take offs and turns. It might be coming from the lift spacers during weight transfer but not sure yet. Still trying to diagnose.
     
  4. Jul 15, 2011 at 7:15 AM
    #4
    myname150

    myname150 Well-Known Member

    Joined:
    Jul 5, 2010
    Member:
    #39827
    Messages:
    1,399
    Gender:
    Male
    Rattling? My floor vibrates now after installing my AT2525...its only at slow take offs, or under 1,500RPM.
     
  5. Jul 15, 2011 at 7:18 AM
    #5
    jedrovsky

    jedrovsky say NO to BRO!

    Joined:
    Jun 4, 2011
    Member:
    #57719
    Messages:
    188
    Gender:
    Male
    San Diego, CA
    Vehicle:
    07 PreRunner
    DIY stuff
    Same here mine is an 07 prerunner it somewhat rattles when I back up slowly and place it on gear and drive away...seems like it's coming from around the brake area or under the engine bay..seems like it's common on 07 prerunners...any opinions?
     
  6. Jul 15, 2011 at 7:24 AM
    #6
    LEX

    LEX --- --- --- - ----

    Joined:
    Oct 15, 2008
    Member:
    #9991
    Messages:
    3,600
    Gender:
    Male
    Houston, Texas
    Vehicle:
    100 Series LC
    Just a guess, but maybe it could be the cats.
     
  7. Jul 15, 2011 at 10:04 AM
    #7
    BarkSlayer

    BarkSlayer Well-Known Member

    Joined:
    Aug 30, 2010
    Member:
    #42472
    Messages:
    73
    Gender:
    Male
    First Name:
    Jim
    Northwest Ohio
    Vehicle:
    Silver SR5 with 2.7 liter 5-speed stick
    Bed-Buddy motorcycle tie-down bar installed in headwall.
    My rattle is also at low rpm, like if I short shift and underrev it for a split second while it torques up to a more comfortable engine speed. It will also rattle if I rev it out a bit beyond the normal shifting range, such as when I pull out into traffic and need to goose it a bit to get up to cruising speed. I got down on the driveway last night with the system cold and made it rattle by thumping the palm of my hand on the muffler. That's not encouraging, since I was looking for a simple, inexpensive fix.
     
  8. Jul 22, 2011 at 6:52 PM
    #8
    jdmbb

    jdmbb Member

    Joined:
    Dec 12, 2010
    Member:
    #47614
    Messages:
    23
    Gender:
    Male
    Miami and tallahassee
    Vehicle:
    06 BSP XRunner
    K&N drop-in filter, Aero Turbine 2525 Muffler on stock pipes, BFG KDW2's and TRD Duracon shift knob.
    i actually fixed this problem today with my aeroturbine 2525 i had installed at mieneke about a year and a half ago. by the way mieneke sucks and the welds they did were sub par to what i can do only having welded for the past 2 months.

    since the factory muffler is so big any muffler you put on there is going to be shorter for sure. that means you need to weld new hangers to hold the pipe that connects to the y-pipe sturdy enough in place to not come in contact with the rail for the cab that runs on top of it. the factory muffler made this section of pipe very sturdy with the hangers it came with. the sound you hear is this section of pipe vibrating against that rail during high stress moments on the truck like taking off slowly or turning. to make my life easier i cut out that small bend from the pipe before the muffler and added an 18 inch piece of straight pipe and rewelded the entire section from the behind the y-pipe with new hangers at my shop. the entire exhaust system is solid as a rock now and not to mention i got some torque back from the horrible exhaust leak ive had since those fools at mieneke installed it the first time. $15 worth of piping and steel rod and a few hours got it done. good luck
     
  9. Jul 22, 2011 at 7:03 PM
    #9
    TacoAviator

    TacoAviator Well-Known Member

    Joined:
    May 26, 2011
    Member:
    #57279
    Messages:
    46
    Gender:
    Male
    First Name:
    James
    Alabama
    Vehicle:
    07 4.0 Taco
    K&N 77 Series Intake, Doug Thorley Long Tube Headers, Borla Cat-Back, URD MAF Unit, Anzio black headlights, FABTECH 3'' Lift Kit, Halo Rims w/ Nitto Terra Grappler 285/75/17, Westin Nerf Bars and Bull Grill, Grille Craft Grille, WetherTech Wind deflectors, Custom Cup Holder
    Had the same problem at 62k. put DTLT headers on and now I cant hear it or my squeeky leaf springs or the beer cans floating around in the bed. easy fix
     
  10. Aug 8, 2011 at 1:57 PM
    #10
    chillindrdude

    chillindrdude Member

    Joined:
    Apr 27, 2011
    Member:
    #55659
    Messages:
    13
    Gender:
    Male
    First Name:
    Neil
    DC metro
    Vehicle:
    06 Toyota Tacoma TRD
    any specific causes as to the rattling? mine starting rattling especially when i roll over bumpy roads.
     
  11. Aug 8, 2011 at 10:21 PM
    #11
    jgray

    jgray Well-Known Member

    Joined:
    Nov 8, 2010
    Member:
    #45912
    Messages:
    60
    Gender:
    Male
    First Name:
    josh
    boyds,md
    Vehicle:
    05 Ext.cab "murder was the case"
    Aero turbine sidepipe 3" pipe Murdered out 3"revtek leveling kit 33's
    Found out the weird rattling in the front end of my 05 was cause passenger side lower ball joint bout to go. Leaked all its grease but I also got another vibration from the center of the truck startin to think it might be front u joints need grease
     
  12. Sep 12, 2011 at 12:04 PM
    #12
    Rob2.7Taco

    Rob2.7Taco Well-Known Member

    Joined:
    Apr 12, 2011
    Member:
    #54789
    Messages:
    69
    Gender:
    Male
    First Name:
    Rob
    Bay Area, CA
    Vehicle:
    2010 Tacoma Prerunner
    Having the same intermittent problem with my 2010 prerunner, it's only in low rpms in 1st and 2nd gear. I assume its gotta be something with the exhaust....
     
  13. Sep 12, 2011 at 1:11 PM
    #13
    907taco

    907taco Alaskan Assassin

    Joined:
    Mar 27, 2010
    Member:
    #34091
    Messages:
    1,364
    Gender:
    Male
    First Name:
    Bobby
    Alaska
    Vehicle:
    2010 BlackSandPearl 4x4
    ultimate lift kit ( toytec ) ome dakar leaf pack , w/ extended length billies, LR uca's, Pro comp 7089s, KM2's 285 70 17, neoprene seat covers, weather techs, CBI sliders w/kickout, URD ss, cab mount chop, VHT night shade tint>tails,3rd B-light. Debadged. Grillecraft grille, rear diff breather mod. CBI Moab front bumper, warn M8000 winch, HID kragens 7", Hella's micro fogs. retrofit headlights HIDS, LED solutions maps/license! 886 back up light mod,
    i had the same rattling issues with my truck, turned out to be my skid plate rattling, my fix was spraying entire skid with a rubber coating found at parts store and actually adding a rubber piece on the top rear corners of skid where the vibration was coming from. for added insurance I used loktite on bolts so they wouldn't come loose again.
     
  14. Sep 13, 2011 at 6:55 AM
    #14
    chillindrdude

    chillindrdude Member

    Joined:
    Apr 27, 2011
    Member:
    #55659
    Messages:
    13
    Gender:
    Male
    First Name:
    Neil
    DC metro
    Vehicle:
    06 Toyota Tacoma TRD
    stupid me, a simple inspection of my undercarriage revealed that a bolt holding the front protective metal plate was loose.

    tightened the bolt and rattle was gone. :rolleyes:
     
To Top