1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Westin brush guard

Discussion in '2nd Gen. Tacomas (2005-2015)' started by LonghornTaco, Nov 1, 2008.

  1. Nov 1, 2008 at 11:28 AM
    #1
    LonghornTaco

    LonghornTaco [OP] Can you pass the bailout please?

    Joined:
    Oct 6, 2008
    Member:
    #9763
    Messages:
    3,355
    Gender:
    Male
    First Name:
    Jason
    Minnesota
    Vehicle:
    Black 09 4x4 TRD Off Road Doublecab
    3" ToyTec coilover lift on Bilstein 5100s, Total Chaos UCAs, ToyTec diff drop, Scangauge II, 4D MagLite mounted on the drivers seat, Painted engine cover, Painted calipers (red), Painted skid plate (red) Valentine 1 radar detector hard wired, Damplifier Pro on the floor, back wall and doors, Luxury Liner Pro on the floor and doors, Kenwood DNX8120, 2 Pioneer TS-SW1041D 10" shallow mount subs, 2 Pioneer PRS-D4200F 1200W amps, Mr Marv sub enclosure, Hybrid Audio Clarus 6.5" components in the front doors, Alpine 5.25" coaxials in the rear doors, A.R.E. LSII fiberglass tonneau cover, All Pro bumper, All Pro sliders, Wet Okole seat covers, Sockmonkey Mountain badges, PIAA 510 SMR Driving Lights, Warn M8000 Winch, Bud Built skids
    Anyone else have a Westin brush guard installed? And this may apply to any brand really, but I notice that it shakes A LOT while driving down the road.

    I remember my Manik brush guard doing the same thing on my Chevy, but don't remember it being this much. Everything is tight, just wondering if anyone else has noticed this and/or been able to do anything about it...

    Thanks!
     
  2. Nov 3, 2008 at 12:01 PM
    #2
    LonghornTaco

    LonghornTaco [OP] Can you pass the bailout please?

    Joined:
    Oct 6, 2008
    Member:
    #9763
    Messages:
    3,355
    Gender:
    Male
    First Name:
    Jason
    Minnesota
    Vehicle:
    Black 09 4x4 TRD Off Road Doublecab
    3" ToyTec coilover lift on Bilstein 5100s, Total Chaos UCAs, ToyTec diff drop, Scangauge II, 4D MagLite mounted on the drivers seat, Painted engine cover, Painted calipers (red), Painted skid plate (red) Valentine 1 radar detector hard wired, Damplifier Pro on the floor, back wall and doors, Luxury Liner Pro on the floor and doors, Kenwood DNX8120, 2 Pioneer TS-SW1041D 10" shallow mount subs, 2 Pioneer PRS-D4200F 1200W amps, Mr Marv sub enclosure, Hybrid Audio Clarus 6.5" components in the front doors, Alpine 5.25" coaxials in the rear doors, A.R.E. LSII fiberglass tonneau cover, All Pro bumper, All Pro sliders, Wet Okole seat covers, Sockmonkey Mountain badges, PIAA 510 SMR Driving Lights, Warn M8000 Winch, Bud Built skids
  3. Nov 4, 2008 at 6:35 AM
    #3
    fasn8dave

    fasn8dave Hey guys watch THIS!

    Joined:
    Sep 25, 2008
    Member:
    #9462
    Messages:
    335
    Gender:
    Male
    Lewisville, NC
    Vehicle:
    06 DC 4x4
    3" Suspension Lift Custom Wheels 265 / 75 / 16 Nitto Terra Grappler Tires (32") Hard Bed Cover Front Bull Bar / Skid Plate Tinted Glass Header Mount GPS Billet Grille
    I don't have one, but I wonder if there's a bad weld somewhere?
     
To Top