1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

what is that smell?!

Discussion in '2nd Gen. Tacomas (2005-2015)' started by loaderman82, Nov 7, 2010.

  1. Nov 7, 2010 at 4:30 PM
    #1
    loaderman82

    loaderman82 [OP] Well-Known Member

    Joined:
    Sep 28, 2010
    Member:
    #43964
    Messages:
    523
    Gender:
    Male
    First Name:
    Dalton
    Flippin, AR
    Vehicle:
    2008 Off-Road
    I just noticed it today when I turned on my truck. It kind of smells like dirty socks, and only does it for just a minute and it comes out of the vents. The only thing I have done is took the secondary filter out! Is that what is caused this smell, or something else?
     
  2. Nov 7, 2010 at 4:44 PM
    #2
    BradleyScottETC

    BradleyScottETC Class IV Category 8 Elite VIP Member (Only)

    Joined:
    Aug 2, 2009
    Member:
    #20521
    Messages:
    1,754
    Gender:
    Male
    First Name:
    Bradley
    Lake County, FL
    Vehicle:
    10 4.0 AC 4x4
    I would check that, and maybe your condensate drain (firewall, passenger side) and make sure you don't have any goop in it.
     
  3. Nov 7, 2010 at 4:46 PM
    #3
    tacomaintraining

    tacomaintraining Well-Known Member

    Joined:
    Feb 16, 2010
    Member:
    #31505
    Messages:
    69
    Gender:
    Male
    what they said? My truck stinks too but I have the worse gas know to man. good luck.
     
  4. Nov 7, 2010 at 6:44 PM
    #4
    loaderman82

    loaderman82 [OP] Well-Known Member

    Joined:
    Sep 28, 2010
    Member:
    #43964
    Messages:
    523
    Gender:
    Male
    First Name:
    Dalton
    Flippin, AR
    Vehicle:
    2008 Off-Road
    I will give it a try!
     
  5. Nov 8, 2010 at 2:02 PM
    #5
    BradleyScottETC

    BradleyScottETC Class IV Category 8 Elite VIP Member (Only)

    Joined:
    Aug 2, 2009
    Member:
    #20521
    Messages:
    1,754
    Gender:
    Male
    First Name:
    Bradley
    Lake County, FL
    Vehicle:
    10 4.0 AC 4x4
    It could also be your floor mats smelling a little sour and getting circulated through during initial start-up.
     
  6. Nov 8, 2010 at 2:08 PM
    #6
    JanBoothius

    JanBoothius Well-Known Member

    Joined:
    Jul 29, 2010
    Member:
    #40965
    Messages:
    475
    Gender:
    Male
    First Name:
    Jan (Pronounced Yon)
    Salt Lake City, UT/Upstate New York
    Vehicle:
    '10 TRD Off Road Access Cab, 6 speed
    OME lift, 886 coils, Dakars w/AAL ARB front bumper Leer 180CC cap etc etc
    I had the same issue. Cabin air filter.
     
  7. Nov 8, 2010 at 5:49 PM
    #7
    jnoley07

    jnoley07 Well-Known Member

    Joined:
    Sep 25, 2007
    Member:
    #2796
    Messages:
    1,297
    Gender:
    Male
    First Name:
    Jay
    Tennessee
    Vehicle:
    2013 Black DC TRD SPORT 4X4
    Sorry. I farted...
     
To Top