1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

What "pumps up" when I start my 2.7?

Discussion in '2nd Gen. Tacomas (2005-2015)' started by Cusker, Oct 5, 2008.

  1. Oct 5, 2008 at 9:38 AM
    #1
    Cusker

    Cusker [OP] Member

    Joined:
    Feb 23, 2008
    Member:
    #4896
    Messages:
    11
    When cold starting my '08 regular cab 2wd it first idle's around 1500rpm for 20-30 seconds until I hear what sounds like something venting, similar to a blow off valve or waste gate opening on a turbo setup, and the idle then drops to ~1000rpm until the truck is fully warm, then it settles into it's normal idle.

    What is the "blow off valve" sound I'm hearing? I'm guessing something related to pressurizing of the fuel tank for emission reasons, but could be all wet.

    Thanks,

    Trenton
     
  2. Oct 5, 2008 at 10:22 AM
    #2
    RelentlessFab

    RelentlessFab Tacoma offroad armor fabricating beast Vendor

    Joined:
    Feb 17, 2008
    Member:
    #4772
    Messages:
    14,194
    Gender:
    Male
    First Name:
    Eric
    Eastern side of the Sierras: Sparks, NV
    Vehicle:
    07 SR5 4x4> 03 SR5 4x4 total> 14 Crewmax TRD
    Had tons on the old Taco's.... new Tundra is pretty stock
    Hi from Klamath falls! Anyways, i really dont think i've ever heard this sound you're talking about. its a sort of high pitched sound then? not just like the radiator fan running for a little while when you start the truck? Maybe the AC condenser from running the defroster on startup?.....
     
  3. Oct 5, 2008 at 1:02 PM
    #3
    Who Dat Popcorn

    Who Dat Popcorn Dafuq

    Joined:
    Feb 28, 2008
    Member:
    #4992
    Messages:
    1,459
    Gender:
    Male
    First Name:
    Ricky
    Richmond, VA
    Vehicle:
    Sold :/
    SOLD
    Yeah dude, mine does the same thing. Perfectly normal.

    EDIT: I dont know what it is though
     
  4. Oct 5, 2008 at 1:26 PM
    #4
    TacoNut

    TacoNut IgnoringChrisWatchingEdLi veVicariouslyThroughMJP2

    Joined:
    Mar 29, 2008
    Member:
    #5597
    Messages:
    5,243
    Gender:
    Male
    First Name:
    Adam
    Denver, Co
    Vehicle:
    16 TRD OR DCSB Quicksand
    I've had the same thing happening for a while. It's not the AC because I've had it happen with the AC off and on. I just can't wrap my head around what it is. :confused:

    Edit: And this is happening on my 4.0L V6
     
  5. Oct 6, 2008 at 8:13 AM
    #5
    Who Dat Popcorn

    Who Dat Popcorn Dafuq

    Joined:
    Feb 28, 2008
    Member:
    #4992
    Messages:
    1,459
    Gender:
    Male
    First Name:
    Ricky
    Richmond, VA
    Vehicle:
    Sold :/
    SOLD
    If you open your hood right when you start the car, you should hear a loud screeching noise. The noise stops and then you hear that "Blow off valve noise". Poke your head around and see where it is coming from. Be quick about it, because it doesn't last long.
     
  6. Oct 6, 2008 at 8:36 PM
    #6
    mclapperton

    mclapperton Active Member

    Joined:
    Jun 1, 2008
    Member:
    #7028
    Messages:
    43
    Gender:
    Male
    First Name:
    Matt
    Rocklin, CA
    Vehicle:
    2008 prerunner sr5
    5100s
    I think you're hearing the air injection pump. It injects air into the exhaust manifold at start up to get the cats up and running quicker. It sits on the right inner fender, I think in front of the air box.
     
  7. Oct 7, 2008 at 12:38 AM
    #7
    DEZ

    DEZ Member

    Joined:
    Feb 10, 2008
    Member:
    #4669
    Messages:
    10
    santa barbara ca
    Vehicle:
    06 prerunner 2wd
    you are right it is the air injection pump and it is located in front of the air box.
     
To Top