1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

What's Wrong With My Leaf's?

Discussion in 'Suspension' started by JayDirt, Oct 12, 2012.

  1. JayDirt

    JayDirt [OP] I owe it all to little chocolate donuts

    Joined:
    Oct 26, 2011
    Member:
    #65928
    Messages:
    1,108
    Gender:
    Male
    My leafs are squeaking after a recent trip in the mountains and I know lots of people complain about that, but look at these pictures and tell me whats wrong. I think they are spent, but need your input...thanks in advance. BTW, I did add a Deaver AAL about a year ago to the stock pack.

    [​IMG]

    [​IMG]
     
  2. blake5995

    blake5995 Well-Known Member

    Joined:
    Aug 12, 2012
    Member:
    #84632
    Messages:
    2,219
    Gender:
    Male
    First Name:
    Blake
    Truckee, CA
    Vehicle:
    98 Tacoma SR5 4x4 2.7L
    they look shot to me. They are almost sitting level i would say get a new pack.
     
  3. dad32509

    dad32509 Thinking of something clever

    Joined:
    Sep 27, 2011
    Member:
    #64230
    Messages:
    3,137
    Gender:
    Male
    First Name:
    Dave
    San Diego
    Vehicle:
    Blacked out 05
    5100's front and back, OME 885x's, LR UCA's, OMD rear springs, Pioneer AVH-P2300DVD, HVAC Green led's MOD, Blacked out bumper, Plastidip emblems, custom front tube bumper, 32" combo led bar, rigid duallys, otrattw switches, my own Satoshi grille, shorty antenna, Spyder LED halo headlights. csjumper2003 map/dome, 3rd brake, DTRL white/amber and parking LED's. Pelfreybilt IFS skid, Cab mount chop, sliders and rear light bar w/blitzpro 5LR dust light. Uniden CB, Magnaflow 18" exhaust, Rear tire carrier, sway bar removed, spidertrax 1.25" spacers, Wheelers 16" Alloys w/265/75r16 Goodyear DuraTracs
    Wow those are flat. Is your bil bent or is that sleeve just messed up? Id say time for some new springs man
     
  4. krimson

    krimson Nothin

    Joined:
    May 17, 2008
    Member:
    #6714
    Messages:
    3,436
    Vehicle:
    TRD Off Road
    OME 3" lift with 885 coils. OME Shocks with TSB 1.5 AAL. 285/75/16 KM2s. XD Hoss 16" wheels. DDM Tuning 6000K HIDs, H10 6000K Fogs. BHLM. Debaged. 20% tint on front windows.
    The AAL is probably causing the squeaking. Mine started to squeak after i installed my AAL.
     
  5. 97yota4wd

    97yota4wd Well-Known Member

    Joined:
    Aug 26, 2010
    Member:
    #42280
    Messages:
    13,025
    Gender:
    Male
    First Name:
    Eric
    Mesa, AZ
    Vehicle:
    alot of metal, small engine, decent travel.
    caged, camburg long travel, 50t leafpack (soon to be installed) light rack over cab, 5pt harnesses etc
    yes they are shot. and yes you can the AAL.
     
  6. OH-MAN

    OH-MAN Well-Known Member

    Joined:
    Apr 23, 2009
    Member:
    #16324
    Messages:
    2,262
    Gender:
    Male
    First Name:
    Steve
    Sunny Az.
    Vehicle:
    10 4X4 O.R. White
    TRD skid painted black,
    Std. leaf degradation.
    My overloads were almost contacting completely with the aal and the rest of the pack.
    I do have lot's of weight in it so I guess better ones are needed in the future.
     
  7. JayDirt

    JayDirt [OP] I owe it all to little chocolate donuts

    Joined:
    Oct 26, 2011
    Member:
    #65928
    Messages:
    1,108
    Gender:
    Male
    Sleeve/boot is just messed up. Thanks for the input guys. Time to go shopping!
     
  8. dad32509

    dad32509 Thinking of something clever

    Joined:
    Sep 27, 2011
    Member:
    #64230
    Messages:
    3,137
    Gender:
    Male
    First Name:
    Dave
    San Diego
    Vehicle:
    Blacked out 05
    5100's front and back, OME 885x's, LR UCA's, OMD rear springs, Pioneer AVH-P2300DVD, HVAC Green led's MOD, Blacked out bumper, Plastidip emblems, custom front tube bumper, 32" combo led bar, rigid duallys, otrattw switches, my own Satoshi grille, shorty antenna, Spyder LED halo headlights. csjumper2003 map/dome, 3rd brake, DTRL white/amber and parking LED's. Pelfreybilt IFS skid, Cab mount chop, sliders and rear light bar w/blitzpro 5LR dust light. Uniden CB, Magnaflow 18" exhaust, Rear tire carrier, sway bar removed, spidertrax 1.25" spacers, Wheelers 16" Alloys w/265/75r16 Goodyear DuraTracs
    Where in SoCal are you?
     
  9. JayDirt

    JayDirt [OP] I owe it all to little chocolate donuts

    Joined:
    Oct 26, 2011
    Member:
    #65928
    Messages:
    1,108
    Gender:
    Male
    Huntington Beach...looking for someone who has take off's with low mileage...
     
  10. BTO

    BTO Well-Known Member

    Joined:
    Nov 12, 2009
    Member:
    #25836
    Messages:
    387
    Gender:
    Male
    California
    Vehicle:
    '07 Silver PR DC AT SR5 TP LSD
    Defroster mod, Bilstein 5100s front, Adjustable Ranchos rear.
    Looks like you already flipped the stock overload leaf. That's the cause of the squeak. Never should have done that. Should have bit the bullet and installed new leafs.
     
  11. TacoDell

    TacoDell Truck ~n~ Tow

    Joined:
    Jun 20, 2008
    Member:
    #7448
    Messages:
    969
    Gender:
    Male
    Hemet/SoCal
    Vehicle:
    '00 Tacoma SR5 4X
    Donahoe CO's, Deaver leaf paks, Lockright Locker, All Pro body armor ( sliders, front and rear bumpers ), All Pro under belly skids, Warn M8K w/Masterpull synthetic line, Dual Optima battery system, 4 ea LightForce Striker 170 offroad lights, 8 ea wired rock lights, and plenty more I'm sure
    ^ the over load spring looks positioned correctly to me :confused:
    I think yer confusing an over load spring with an add a leaf spring.

    But yeah.. those springs look tired.

    Squeaks can normally be associated
    with the springs eye bushings...
    and even the shocks eye bushings.

    lube those up when replacing the springs.
     
  12. EVILSKEEMZ

    EVILSKEEMZ Well-Known Member

    Joined:
    Oct 7, 2012
    Member:
    #88496
    Messages:
    618
    Gender:
    Male
    First Name:
    EVILSKEEMZ
    New York
    Vehicle:
    2013 2.7L 4x4
    So, I've been following this forum for a bit since I just got my 2013 2.7l 4x4 regular cab. First off I love the truck but this past weekend I put about 480lbs of cement in the back and I noticed a harsh and noisy ride. I unloaded the bed and I noticed the back of the truck sagging. I didn't measure it before the load but it is considerably lower without it, especially on one side (left).The back suspension was making noise with the load and now without. I'm pissed! I called Toyota customer service and got a case number. I made an appointment to go back to the dealer this week. I know of the TSB for the other model years but has anybody had similar problems with any of the 2013's???
     
To Top