1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

when i brake turning signal comes on?

Discussion in '1st Gen. Tacomas (1995-2004)' started by djford193, May 27, 2010.

  1. May 27, 2010 at 4:57 PM
    #1
    djford193

    djford193 [OP] Member

    Joined:
    Feb 15, 2010
    Member:
    #31461
    Messages:
    22
    Gender:
    Male
    First Name:
    David
    Panama city
    Vehicle:
    2000 tacoma
    anybody know why my taco's doing this every time i touch the break turning signal comes on like its my brake light but also with brake lights on just started today.
     
  2. May 27, 2010 at 5:01 PM
    #2
    crazyasu45

    crazyasu45 Well-Known Member

    Joined:
    May 14, 2009
    Member:
    #17241
    Messages:
    707
    Gender:
    Male
    First Name:
    Matt
    Canada
    Vehicle:
    2013 MGM DCLB 4X4 TRD SPORT
    3" SUSPENSION LIFT
    have u done anything to you truck lately?
     
  3. May 27, 2010 at 5:09 PM
    #3
    djford193

    djford193 [OP] Member

    Joined:
    Feb 15, 2010
    Member:
    #31461
    Messages:
    22
    Gender:
    Male
    First Name:
    David
    Panama city
    Vehicle:
    2000 tacoma
    nothing at all within in the past months and ive done absolutely nothing with wiring or anything like that
     
  4. May 28, 2010 at 3:00 PM
    #4
    trailinTaco

    trailinTaco Well-Known Member

    Joined:
    May 18, 2008
    Member:
    #6721
    Messages:
    221
    Gender:
    Male
    Bel Air, MD
    Vehicle:
    2000 Tacoma SR5 TRD 3.4L 4x4
    3 inch suspension lift, 33 inch bfgoodrich mud terrain tires, toytech diff drop, Procomp alloy wheels, hella fog lights, black projector headlights with 8000k HID's, blacked out tail lights, two 12 inch subs, 20% tint, pioneer head unit and speakers
    I had the same problem with mine. It was the trailer harness shorted out and backfeeding to the turn signal. Do you have a trailer harness? If so disconect it and see if it fixes it.
     
  5. May 28, 2010 at 5:04 PM
    #5
    EnolaGaia

    EnolaGaia Well-Known Member

    Joined:
    Sep 9, 2006
    Member:
    #9
    Messages:
    1,129
    Gender:
    Male
    Midwest USA
    Vehicle:
    '01 & '04 S-Runners
    01 SR: Double Cab conversion, S/C, lowered.
    If you don't have a towing harness installed, check for blown / shorted bulbs or shorts in the taillight area.
     
  6. May 30, 2010 at 11:20 AM
    #6
    djford193

    djford193 [OP] Member

    Joined:
    Feb 15, 2010
    Member:
    #31461
    Messages:
    22
    Gender:
    Male
    First Name:
    David
    Panama city
    Vehicle:
    2000 tacoma
    i sure do have a towing harness..thanks a bunch yall
     
  7. May 31, 2010 at 9:17 AM
    #7
    saweetlou

    saweetlou Well-Known Member

    Joined:
    Mar 15, 2010
    Member:
    #33266
    Messages:
    184
    Gender:
    Male
    Guelph Ontario
    Vehicle:
    TRD Stepside
    2in Skyjacker
    Pull the tail lights, I was surprised to see that both sides, the tail light sockets were badly corroded and the ground came off of one causing the same problem you have.
     
To Top