1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Wipers WTF

Discussion in '2nd Gen. Tacomas (2005-2015)' started by jeeezy, Nov 16, 2011.

  1. Nov 16, 2011 at 10:36 AM
    #1
    jeeezy

    jeeezy [OP] jeeezy

    Joined:
    Dec 20, 2010
    Member:
    #48000
    Messages:
    398
    Gender:
    Male
    First Name:
    Jesse
    Timmins
    Vehicle:
    07 dbc long box speedway blue
    custom cold air intake 4 inch tubing, MBRP dual catback exhaust, readylift leveling kit with 265/75-17 on eagle alloy rims
    this morning as i was driving to work i went to use my windshield washer fluid as both wipers came up the passenger side arm stopped making the drivers side catch cause them the mangle, grind inside, and now not working :( were do i start on dissasembling? any help on this one is greatly appreciated guys
     
  2. Nov 16, 2011 at 10:41 AM
    #2
    jeeezy

    jeeezy [OP] jeeezy

    Joined:
    Dec 20, 2010
    Member:
    #48000
    Messages:
    398
    Gender:
    Male
    First Name:
    Jesse
    Timmins
    Vehicle:
    07 dbc long box speedway blue
    custom cold air intake 4 inch tubing, MBRP dual catback exhaust, readylift leveling kit with 265/75-17 on eagle alloy rims
    you sir are a god
     
To Top