1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

WTH? One of my horns doesn't work anyone!

Discussion in '2nd Gen. Tacomas (2005-2015)' started by w8n4mud, Mar 7, 2009.

  1. Mar 7, 2009 at 7:31 PM
    #1
    w8n4mud

    w8n4mud [OP] There's a mod for that!

    Joined:
    May 23, 2008
    Member:
    #6831
    Messages:
    6,204
    Gender:
    Male
    First Name:
    Albert
    San Diego, CA
    Vehicle:
    2015 Subaru WRX
    Bilsteins 5100's (Front & Rear), GrillCraft, Line-X'ed Skid Plate & Bumper Valence, Blacked out hood scoop, Avid Light Bar and much more.
    One day last week, I used my horn at work when driving around a blind corner. To my surprise, it sounded different. So I pulled over and put my hand to the horn and well you guessed it. I could hear one of the horns kicking in and out. So finally it died! I looked at the connectors and checked the fuse. No luck.
    I also checked to see if there were other threads about horns going bad. I only saw other owners upgrading to an air horn and simply replacing the factory with aftermarket. But has anyone had a similar issue? Does anyone have an extra horn laying around (assuming that's my problem)?
    Let me know. I love to use my horn. I feel stupid when I hear the damn thing. I never knew what a difference one horn could make. Anyways that's my story and I'm sticking to it!
     
  2. Mar 2, 2014 at 5:51 PM
    #2
    thunderone

    thunderone Trollin' TW since '09

    Joined:
    May 20, 2009
    Member:
    #17473
    Messages:
    2,097
    Gender:
    Male
    First Name:
    Mitchell
    Nashville, TN
    Vehicle:
    Not a Tacundra
    Mine has been doing this intermittently lately. When I hit the panic button is seems work fine, but sometimes when I honk the horn via the steering wheel is sounds like a damn Hyundai or something. Then sometimes it works again. Not sure what's going on.
     
  3. Mar 2, 2014 at 5:59 PM
    #3
    cnw126

    cnw126 Member

    Joined:
    Aug 8, 2013
    Member:
    #110050
    Messages:
    14
    Gender:
    Male
    Delaware
    Vehicle:
    2013, 4X4, 2.7, 5spd, access cab, Pyrite Mica
    Not Toyota related but the horn on my 1997 Mazda b2300 died about 8 years into ownership. If I remember correctly I got a replacement at Pep Boys for $15. I am not sure of the exact problem with the old horn but the new one solved the problem and worked until the truck got totaled in 2012.
     
  4. Mar 2, 2014 at 6:28 PM
    #4
    josh0351

    josh0351 Well-Known Member

    Joined:
    Mar 27, 2013
    Member:
    #100717
    Messages:
    1,026
    Gender:
    Male
    First Name:
    Josh
    VA
    Vehicle:
    Supercharged 2013 TRD OR | 1996 4X4 Shortbed Reg Cab (incapacitated)
    Stuff
    Well hell, one of my horns has been sounding funny and sporadically working and I thought it was something related to the fender-bender I was involved in in Nov. Maybe not. :confused:
     
  5. Mar 2, 2014 at 7:35 PM
    #5
    wannabetrd

    wannabetrd Well-Known Member

    Joined:
    Jan 25, 2014
    Member:
    #121441
    Messages:
    141
    Gender:
    Male
    First Name:
    Zach
    Michigan
    Vehicle:
    SR5
    3inch front 2inch rear lift with add a leaf and extended brake lines trd exhaust
    Your horn is grounded thru the mount pull your horn off clean and rust corrosion and or paint off where it mounts to the body and see if that helps you know of course as long as you have power
     
  6. Mar 2, 2014 at 10:31 PM
    #6
    G17GUY

    G17GUY Well-Known Member

    Joined:
    Jul 31, 2008
    Member:
    #8250
    Messages:
    182
    Modesto Ca
    Vehicle:
    tacoma
    spining hub caps chrome stick-on trim new car smell air freshiner stering wheel suicide knob nut sack on hitch back window curtain
    Do all 2nd gens have two horns? My single cab has always sounded like a bike horn.
     
  7. Mar 3, 2014 at 2:21 AM
    #7
    ZEROPILOT

    ZEROPILOT Can't re-MEMBER

    Joined:
    Jan 24, 2014
    Member:
    #121347
    Messages:
    508
    Gender:
    Male
    First Name:
    ED
    SUNRISE,FLORIDA
    Vehicle:
    09 2.7 XTRA CAB 5 SPEED
    LARGER WHEELS. DIFFERENT STEREO. PUSH BAR. TAILGATE EXTENDER. WIPER MOD. TPMS LIGHT DELETE MOD.
    There are two horns on the second generation. (One "beep-beep" horn on the first gen.) The gen two have a high note and a low note. Two high or two low notes wont sound right. It's the combination of high and low that makes the correct noise. Make sure that you get the right one. A Pep Boys horn will work, fine.
     
  8. Mar 3, 2014 at 2:25 AM
    #8
    aaronbuell

    aaronbuell Well-Known Member

    Joined:
    Nov 30, 2011
    Member:
    #67967
    Messages:
    306
    Gender:
    Male
    First Name:
    aaron
    windsor NY
    Vehicle:
    09 TRD/OR Access Cab V6 debadged
    Fog-light anytime mod, ,black grill,URD short throw,TRD decals removed ,debadged,black rear bumper, homemade tire carrier,TreadWright tires,Evo mod,removed rear headrests and seats,ABS kill switch mod,black center caps,Clarion CX501 head unit,Relentless hood brackets with floodlights.
    Mine does it on and off i've checked the contacts a few times, cleaned them they will be fine for awhile then one will go out of a few days.
     
  9. Mar 3, 2014 at 2:31 AM
    #9
    car78412

    car78412 Well-Known Member

    Joined:
    Oct 17, 2010
    Member:
    #44802
    Messages:
    562
    Gender:
    Male
    Hudson Valley NY
    Vehicle:
    13 Tacoma reg cab 4x4
    I only have one horn on my 13'. If you want to call it a horn. More like a pathetic noise. I had 2 horns on my 03'.
     
  10. Mar 3, 2014 at 2:33 AM
    #10
    ZEROPILOT

    ZEROPILOT Can't re-MEMBER

    Joined:
    Jan 24, 2014
    Member:
    #121347
    Messages:
    508
    Gender:
    Male
    First Name:
    ED
    SUNRISE,FLORIDA
    Vehicle:
    09 2.7 XTRA CAB 5 SPEED
    LARGER WHEELS. DIFFERENT STEREO. PUSH BAR. TAILGATE EXTENDER. WIPER MOD. TPMS LIGHT DELETE MOD.
    Oh, I see. There are a few changes year to year. You can run a two note high/low set off of your single horns wires. You'll have to crimp on some terminals. The horns on my 2009 will blow your hat off. Stock. I know that if they ever get water in them, it's soon all over. It's just a coil of wire in there and they need to stay dry and clean.
     
    Last edited: Mar 3, 2014
  11. Mar 3, 2014 at 2:46 AM
    #11
    car78412

    car78412 Well-Known Member

    Joined:
    Oct 17, 2010
    Member:
    #44802
    Messages:
    562
    Gender:
    Male
    Hudson Valley NY
    Vehicle:
    13 Tacoma reg cab 4x4
    I had been looking at replacing the single horn on my 13' but there is only one connection whereas the duel horn has 2. Without any complicated wiring alterations, how can I adapt the duel horns with the single connection?
     
  12. Mar 3, 2014 at 5:11 AM
    #12
    Jimmyh

    Jimmyh Well-Known Member

    Joined:
    May 16, 2012
    Member:
    #78991
    Messages:
    6,578
    Gender:
    Male
    SC
    Vehicle:
    2012 Prerunner SR5
    Like This:

    Wire from Horn Relay
    X_____________________|X Horn # 1
    |
    |_____________________|X Horn # 2
    Splice for horn # 2
     
  13. Mar 3, 2014 at 6:06 AM
    #13
    moondeath

    moondeath Winter is Coming

    Joined:
    Jan 8, 2011
    Member:
    #48948
    Messages:
    5,060
    Gender:
    Male
    First Name:
    Chris
    Pa, Carlisle
    Vehicle:
    2013 TRD Sport DCLB 4x4
    5100 @ 1.75", 1.5" Icon Progressive 3 leaf, Procomp Wheels, Grill Thin Lip (Custom Car Grills Mod), Access Tonneau Cover, Pop & Lock Tailgate Electronic Lock PL8521
    Test the voltage at the horn and make sure it's correct. If found to be correct, then buy a new horn from a Toyota parts web site or from your dealer. They don't cost that much.
     
  14. Mar 3, 2014 at 8:40 PM
    #14
    thunderone

    thunderone Trollin' TW since '09

    Joined:
    May 20, 2009
    Member:
    #17473
    Messages:
    2,097
    Gender:
    Male
    First Name:
    Mitchell
    Nashville, TN
    Vehicle:
    Not a Tacundra
    That's the thing... it works fine when I hit the panic button but it doesn't always work fine when I hit the steering wheel.
     
  15. Mar 3, 2014 at 8:49 PM
    #15
    moondeath

    moondeath Winter is Coming

    Joined:
    Jan 8, 2011
    Member:
    #48948
    Messages:
    5,060
    Gender:
    Male
    First Name:
    Chris
    Pa, Carlisle
    Vehicle:
    2013 TRD Sport DCLB 4x4
    5100 @ 1.75", 1.5" Icon Progressive 3 leaf, Procomp Wheels, Grill Thin Lip (Custom Car Grills Mod), Access Tonneau Cover, Pop & Lock Tailgate Electronic Lock PL8521
    Sorry, my comment wasn't directed at you. Didn't notice the thread was old. Maybe one of your horns is just starting to go bad and intermittently doesn't work. I've had that happen on other vehicles.
     
  16. Mar 3, 2014 at 9:06 PM
    #16
    thunderone

    thunderone Trollin' TW since '09

    Joined:
    May 20, 2009
    Member:
    #17473
    Messages:
    2,097
    Gender:
    Male
    First Name:
    Mitchell
    Nashville, TN
    Vehicle:
    Not a Tacundra
    Yeah haha I searched and this was the closest thing that came up
     
To Top