1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

00' Prerunner Running real rough

Discussion in 'Technical Chat' started by _Hammer, Jun 11, 2008.

  1. Jun 11, 2008 at 8:12 PM
    #1
    _Hammer

    _Hammer [OP] New Member

    Joined:
    Jun 11, 2008
    Member:
    #7260
    Messages:
    2
    I have a 2000 Prerunner 3.4 and the engine is running rough. The timming belt looks ok, could it have jumped? Has major power loss, runs rough until about 2k rpms unless driving. Possibly wires/plugs, bad head gasket idk? Did compression test with water neck to check for head leak(by hand).
     
  2. Jun 11, 2008 at 8:18 PM
    #2
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    103,903
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Sonds like your idle advance. Is there a code? I think there is a vacume line on the driver side of the engine by the brake booster. Check and see if it came loose. :)
     
  3. Jun 11, 2008 at 8:27 PM
    #3
    _Hammer

    _Hammer [OP] New Member

    Joined:
    Jun 11, 2008
    Member:
    #7260
    Messages:
    2
    Ya there is a code but not a place to read for about 45 miles away. probably wondnt make it. I just did a quik look, no hoses undun that I can see
     
  4. Jun 12, 2008 at 5:36 PM
    #4
    chris4x4

    chris4x4 With sufficient thrust, pigs fly just fine. Staff Member

    Joined:
    May 8, 2008
    Member:
    #6497
    Messages:
    103,903
    Gender:
    Male
    First Name:
    FlimFlubberJAM
    Tenoe, AZ
    Vehicle:
    2013 Rubicon Unlimited,
    4.10 gears, sliders, and lots of buttons.
    Hmm.....Need to get the code read.
     
To Top