1. Welcome to Tacoma World!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tacoma discussion topics
    • Communicate privately with other Tacoma owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

02 Problems

Discussion in 'Technical Chat' started by Auto, Nov 18, 2009.

  1. Nov 18, 2009 at 4:32 AM
    #1
    Auto

    Auto [OP] Well-Known Member

    Joined:
    Nov 1, 2009
    Member:
    #25281
    Messages:
    47
    Gender:
    Male
    Delaware
    Vehicle:
    01 TRD SR5
    None Yet Some Coming Soon
    I got this trouble code on a 01 Tacoma with the 3.4 and 5 speed the code is for the 02 sensor on bank 1 sensor 1. I changed the sensor before the converter with a Denso exact fit 02 sensor. I used a scanner to clear the code and it was fine for a weeks. Then check engine light came back on for the same bank one sensor 1 O2 sensor. Why would this code keep coming back? I did check the wires and they are okay. The truck has 88,000 miles on it.
     
  2. Nov 18, 2009 at 9:19 AM
    #2
    humanoid

    humanoid bite me

    Joined:
    Jun 27, 2007
    Member:
    #1932
    Messages:
    2,744
    Gender:
    Male
    Sunny SoCal
    Vehicle:
    I had a '99 Xtra Cab PreRunner SR5 V6
    Sometimes it may not be the O2 sensor. Are you running a K&N air filter or other oiled media type filter?
     
  3. Nov 18, 2009 at 9:48 AM
    #3
    Auto

    Auto [OP] Well-Known Member

    Joined:
    Nov 1, 2009
    Member:
    #25281
    Messages:
    47
    Gender:
    Male
    Delaware
    Vehicle:
    01 TRD SR5
    None Yet Some Coming Soon
    No the truck is all stock. So you think i should try to clean the MAF sensor.
     
  4. Nov 18, 2009 at 5:32 PM
    #4
    Auto

    Auto [OP] Well-Known Member

    Joined:
    Nov 1, 2009
    Member:
    #25281
    Messages:
    47
    Gender:
    Male
    Delaware
    Vehicle:
    01 TRD SR5
    None Yet Some Coming Soon
    I just cleaned the MAF it was pretty dirty thanks for the suggestion i can see that being a problem.
     
  5. Nov 18, 2009 at 5:36 PM
    #5
    humanoid

    humanoid bite me

    Joined:
    Jun 27, 2007
    Member:
    #1932
    Messages:
    2,744
    Gender:
    Male
    Sunny SoCal
    Vehicle:
    I had a '99 Xtra Cab PreRunner SR5 V6
    Is the CEL still there? If so, just undo the negative battery terminal for a couple minutes and that should reset it. If the CEL comes back then you have other problems.
     
  6. Nov 18, 2009 at 5:36 PM
    #6
    humanoid

    humanoid bite me

    Joined:
    Jun 27, 2007
    Member:
    #1932
    Messages:
    2,744
    Gender:
    Male
    Sunny SoCal
    Vehicle:
    I had a '99 Xtra Cab PreRunner SR5 V6
    BTW, how did you clean your MAF? Did you use an MAF cleaner? Hope you didn't use a Q-Tip to clean the wires, those things are very fragile and could be a costly mistake if you mess them up.
     
  7. Nov 18, 2009 at 5:38 PM
    #7
    98tacoma27

    98tacoma27 is gooder 'en chicken Moderator

    Joined:
    Dec 18, 2008
    Member:
    #11714
    Messages:
    49,750
    Gender:
    Male
    First Name:
    Ben
    Beech Creek
    Vehicle:
    05 Tundra SR5 (+250k AND COUNTING), 88 SR5 PU (SOLD), 98 TRD OR (CRUSHED)
    5100's all on fours
    Check for an exhaust leak also.
     
  8. Nov 18, 2009 at 5:49 PM
    #8
    MiikeyD

    MiikeyD The Green Machine

    Joined:
    Jul 6, 2007
    Member:
    #2017
    Messages:
    1,433
    Gender:
    Male
    First Name:
    Mike
    Upland, CA
    Vehicle:
    Green Prerunner DC 2.7L
    Suspension / Wheels / Tires 3.5" Fabtech lift w/ AAL 265/75/16 BFG A/T American Racing Baja Audio Alpine HU CDA-9886 Kicker DS650 Z-Edition 1000W Memphis M3 US Amps 4000W 2.5Farad Cap Lighting 6000K HID 2 Hella 500FF 2 Aux Bed Lights 2 Aux Driving Lights Performance Volant CAI Flomaster Super 44 Doug Thorley Long Tube headers (coming soon) NGK Iridium Sparkplugs Accessories Scanguage II Cobra LTD27-NW with 3' Firestik Radio Shack Triple Trunking Scanner Harbor Freight Hi-Lift Cosmetics Flat Black Bumper Trim Flat Black Grill Surrounding with Satoshi Clear Corners Future Modifications (not specific) Longtravel w/ king shocks or fox Caged bed Shackles rear suspension. Fox / king shocks custom front bumper Custom Glassworks extreme kit for 01-04 (only have hood and passenger side.. need driver panel) Supercharger + 8port intake manifold optima yellow top battery remounted new rims caged interior rear bench removal 4 sparc
    is that a p0168? i think thats what it is... i have that also.. says o2 sensor but it might be the cat.
     
To Top